aboutsummaryrefslogtreecommitdiff
path: root/www/axis2
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-09-27 18:38:18 +0000
committerChris Rees <crees@FreeBSD.org>2011-09-27 18:38:18 +0000
commita469f134ecfae2132d9301170b22611370a2213e (patch)
tree459be61b6799506382fb41d153eac2ac8fbd6cd9 /www/axis2
parentc0c81fbd9e7b6927244f89802f595cd6e0632fb3 (diff)
downloadports-a469f134ecfae2132d9301170b22611370a2213e.tar.gz
ports-a469f134ecfae2132d9301170b22611370a2213e.zip
Fix build and fail if no app servers are selected.
Submitted by: Jason Helfman (maintainer), eadler
Notes
Notes: svn path=/head/; revision=282506
Diffstat (limited to 'www/axis2')
-rw-r--r--www/axis2/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/www/axis2/Makefile b/www/axis2/Makefile
index 15a2dd3d3237..6248d362e91f 100644
--- a/www/axis2/Makefile
+++ b/www/axis2/Makefile
@@ -16,6 +16,8 @@ COMMENT= Provides a Web Services,SOAP and WSDL engine from Apache
LICENSE= ASL
+USE_ZIP= yes
+
OPTIONS= TOMCAT5 "Enable Tomcat 5.x support" on \
TOMCAT6 "Enable Tomcat 6.x support" off \
TOMCAT7 "Enable Tomcat 7.x support" off
@@ -47,18 +49,23 @@ WEBAPPDIR= ${APPHOME}/webapps
IGNORE= you can only define one application server
.elif ( defined(WITH_TOMCAT6) && defined(WITH_TOMCAT7) )
IGNORE= you can only define one application server
+.elif !defined(WEBAPPDIR)
+IGNORE= you need at least one application server
.endif
-.include <bsd.port.options.mk>
-
-USE_ZIP= yes
-NO_BUILD= YES
USE_JAVA= yes
JAVA_VERSION= 1.6+
+SHAREOWN= www
+SHAREGRP= www
PLIST_SUB+= WEBAPPS=${WEBAPPDIR:S|^${PREFIX}/||}
+do-build:
+ @${MKDIR} ${WRKSRC}
+ @(cd ${WRKSRC} && ${TAR} xf ${WRKDIR}/${PORTNAME}.war)
+
do-install:
${MKDIR} ${WEBAPPDIR}/${PORTNAME}
${UNZIP_CMD} ${WRKDIR}/${PORTNAME}.war -d ${WEBAPPDIR}/${PORTNAME}
+ ( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTNAME} )
.include <bsd.port.mk>