aboutsummaryrefslogtreecommitdiff
path: root/www/bacula-web
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2020-04-17 15:24:30 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2020-04-17 15:24:30 +0000
commit26ef697c95a95ed5a2724c2cbbd2cbe3ffb5111a (patch)
treed5ad324eab2e673939239d4ad716443681e72912 /www/bacula-web
parentc5beddb507d74be850bf9dcfe23d08860cc39ef7 (diff)
downloadports-26ef697c95a95ed5a2724c2cbbd2cbe3ffb5111a.tar.gz
ports-26ef697c95a95ed5a2724c2cbbd2cbe3ffb5111a.zip
Notes
Diffstat (limited to 'www/bacula-web')
-rw-r--r--www/bacula-web/Makefile36
-rw-r--r--www/bacula-web/distinfo6
-rw-r--r--www/bacula-web/files/pkg-message.in28
-rw-r--r--www/bacula-web/pkg-plist385
4 files changed, 193 insertions, 262 deletions
diff --git a/www/bacula-web/Makefile b/www/bacula-web/Makefile
index 1fad6623f20b..5016b9317b6e 100644
--- a/www/bacula-web/Makefile
+++ b/www/bacula-web/Makefile
@@ -2,32 +2,26 @@
# $FreeBSD$
PORTNAME= bacula-web
-DISTVERSION= 7.2.0
-PORTREVISION= 2
+DISTVERSIONPREFIX= v
+DISTVERSION= 8.3.3
+PORTREVISION= 0
CATEGORIES= www sysutils
-MASTER_SITES= http://www.bacula-web.org/files/bacula-web.org/downloads/
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
-MAINTAINER= dvl@FreeBSD.org
+MAINTAINER= mfechner@FreeBSD.org
COMMENT= Bacula-web provides a summarized output of Bacula jobs
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2020-05-05
-
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/docs/COPYING
-USES= php:web tar:tgz
-USE_PHP= gd gettext session
+RUN_DEPENDS= ${LOCALBASE}/bin/composer:devel/php-composer@${PHP_FLAVOR}
+
+USES= php:web,flavors
+USE_PHP= dom gd gettext session simplexml tokenizer xml xmlwriter
+USE_GITHUB= yes
NO_BUILD= yes
NO_ARCH= yes
-NO_WRKSUBDIR= yes
-
-BACULAWEB_HOME?=${WWWDIR}
-BASE= ${BACULAWEB_HOME:S|${PREFIX}/||}
SUB_FILES= pkg-message
-PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP} BASE=${BASE}
-SUB_LIST= BASE=${BASE}
OPTIONS_DEFINE= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= PGSQL
@@ -57,11 +51,9 @@ USE_PHP+= pdo_sqlite
.endif
do-install:
- @${ECHO} "Installing in ${BACULAWEB_HOME}"
- ${MKDIR} ${STAGEDIR}${BACULAWEB_HOME}
- cd ${WRKSRC} && ${COPYTREE_SHARE} application \
- ${STAGEDIR}${BACULAWEB_HOME}
- cd ${WRKSRC} && ${COPYTREE_SHARE} core ${STAGEDIR}${BACULAWEB_HOME}
- ${INSTALL_DATA} ${WRKSRC}/*.php ${STAGEDIR}${BACULAWEB_HOME}
+ # Maybe we should delete some files
+ ${FIND} ${WRKSRC} -name '*.orig' -delete
+ @${ECHO} "Installing in ${WWWDIR}"
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/www/${PORTNAME})
.include <bsd.port.mk>
diff --git a/www/bacula-web/distinfo b/www/bacula-web/distinfo
index 75b78fcedb2d..9b14fd308c3f 100644
--- a/www/bacula-web/distinfo
+++ b/www/bacula-web/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1472329073
-SHA256 (bacula-web-7.2.0.tgz) = 122b2d522aa98ea5b30b9791027822cbfdfb87feb875e4d84d4604756e321b02
-SIZE (bacula-web-7.2.0.tgz) = 1170149
+TIMESTAMP = 1587036292
+SHA256 (bacula-web-bacula-web-v8.3.3_GH0.tar.gz) = 509a4d3cfba9defc0f987d4f8b2346e626455efba9805b4afc7f6e92ea12cbe0
+SIZE (bacula-web-bacula-web-v8.3.3_GH0.tar.gz) = 1676748
diff --git a/www/bacula-web/files/pkg-message.in b/www/bacula-web/files/pkg-message.in
index 033a1c43d920..1f83fecbd8a0 100644
--- a/www/bacula-web/files/pkg-message.in
+++ b/www/bacula-web/files/pkg-message.in
@@ -1,20 +1,34 @@
[
{ type: install
message: <<EOM
-Please note that everything has been installed in %%BASE%%.
+Please note that everything has been installed in %%WWWDIR%%.
-You need to copy %%BASE%%/application/config/config.php.sample to
-%%BASE%%/application/config/config.php and modify with your preferences.
+Make sure to install dependencies with:
+ cd %%WWWDIR%% && composer i
-You will probably want to add an alias to your httpd.conf file, something
+Create inital user:
+ su -l www -c "cd %%WWWDIR%% && php bwc setupauth"
+
+Make sure you modify %%WWWDIR%%/application/config/config.php to your needs.
+The installed config.php should work with the standard setup already.
+Use the manual as a reference:
+http://docs.bacula-web.org/en/v8.3.3/02_install/configure.html
+
+Depending on the webserver you use,
+you will probably want to add an alias to your httpd.conf file, something
like this:
- Alias /bacula-web "%%BASE%%/"
+ Alias /bacula-web "%%WWWDIR%%/"
And restart Apache.
-Alternatively, you can create a host dedicated to bacula-web and use
-a DocumentRoot of %%BASE%%/.
+
+EOM
+}
+{ type:upgrade
+ message: <<EOM
+Make sure to update dependencies with:
+ cd %%WWWDIR%%; composer i
EOM
}
]
diff --git a/www/bacula-web/pkg-plist b/www/bacula-web/pkg-plist
index 6a885ab13b42..631c18acbe6e 100644
--- a/www/bacula-web/pkg-plist
+++ b/www/bacula-web/pkg-plist
@@ -1,233 +1,158 @@
-@owner %%WWWOWN%%
-@group %%WWWGRP%%
+%%WWWDIR%%/.codeclimate.yml
+%%WWWDIR%%/.csslintrc
+%%WWWDIR%%/.eslintignore
+%%WWWDIR%%/.eslintrc.yml
+%%WWWDIR%%/.htaccess
+%%WWWDIR%%/CONTRIBUTING.md
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/README.md
+%%WWWDIR%%/bwc
+%%WWWDIR%%/composer.json
+%%WWWDIR%%/composer.lock
%%WWWDIR%%/application/assets/css/default.css
+%%WWWDIR%%/application/assets/images/bacula-web-logo.png
%%WWWDIR%%/application/assets/js/default.js
%%WWWDIR%%/application/assets/js/ie10-viewport-bug-workaround.js
-%%BASE%%/application/config/.htaccess
-%%BASE%%/application/config/config.php.sample
-%%BASE%%/application/libs/fileconfig.class.php
-%%BASE%%/application/locale/de_DE/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/de_DE/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/en_EN/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/en_EN/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/es_ES/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/es_ES/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/fr_FR/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/fr_FR/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/it_IT/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/it_IT/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/ja_JP/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/ja_JP/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/nl_NL/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/nl_NL/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/pt_BR/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/pt_BR/LC_MESSAGES/messages.po
-%%BASE%%/application/locale/sv_SV/LC_MESSAGES/messages.mo
-%%BASE%%/application/locale/sv_SV/LC_MESSAGES/messages.po
-%%BASE%%/application/models/clients.model.php
-%%BASE%%/application/models/database.model.php
-%%BASE%%/application/models/filesets.model.php
-%%BASE%%/application/models/jobs.model.php
-%%BASE%%/application/models/pools.model.php
-%%BASE%%/application/models/volumes.model.php
-%%BASE%%/application/view/backupjob-report.tpl
-%%BASE%%/application/view/cache/README
-%%BASE%%/application/view/client-report.tpl
-%%BASE%%/application/view/footer.tpl
-%%BASE%%/application/view/header.tpl
-%%BASE%%/application/view/index.tpl
-%%BASE%%/application/view/joblogs.tpl
-%%BASE%%/application/view/jobs.tpl
-%%BASE%%/application/view/pools.tpl
-%%BASE%%/application/view/test.tpl
-%%BASE%%/backupjob-report.php
-%%BASE%%/client-report.php
-%%BASE%%/core/app/cerrorhandler.class.php
-%%BASE%%/core/app/classautoloader.class.php
-%%BASE%%/core/app/cmodel.class.php
-%%BASE%%/core/app/cview.class.php
-%%BASE%%/core/bweb.class.php
-%%BASE%%/core/const.inc.php
-%%BASE%%/core/db/cdb.class.php
-%%BASE%%/core/db/cdbquery.class.php
-%%BASE%%/core/db/cdbresult.class.php
-%%BASE%%/core/db/cdbutils.class.php
-%%BASE%%/core/global.inc.php
-%%BASE%%/core/graph/cgraph.class.php
-%%BASE%%/core/i18n/ctranslation.class.php
-%%BASE%%/core/utils/chttprequest.class.php
-%%BASE%%/core/utils/cutils.class.php
-%%BASE%%/core/utils/datetimeutil.class.php
-%%BASE%%/core/utils/file.class.php
-%%BASE%%/core/vendor/bootstrap
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap-theme.css
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap-theme.css.map
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap-theme.min.css
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap-theme.min.css.map
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap.css
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap.css.map
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap.min.css
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/css/bootstrap.min.css.map
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/fonts/glyphicons-halflings-regular.eot
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/fonts/glyphicons-halflings-regular.svg
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/fonts/glyphicons-halflings-regular.ttf
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/fonts/glyphicons-halflings-regular.woff
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/fonts/glyphicons-halflings-regular.woff2
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/js/bootstrap.js
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/js/bootstrap.min.js
-%%BASE%%/core/vendor/bootstrap-3.3.6-dist/js/npm.js
-%%BASE%%/core/vendor/bootstrap-datetimepicker-4.7.14/css/bootstrap-datetimepicker.min.css
-%%BASE%%/core/vendor/bootstrap-datetimepicker-4.7.14/js/bootstrap-datetimepicker.js
-%%BASE%%/core/vendor/bootstrap-datetimepicker-4.7.14/js/bootstrap-datetimepicker.min.js
-%%BASE%%/core/vendor/moment/moment-with-locales.min.js
-%%WWWDIR%%/core/vendor/font-awesome/css/font-awesome.css
-%%WWWDIR%%/core/vendor/font-awesome/css/font-awesome.min.css
-%%WWWDIR%%/core/vendor/font-awesome/fonts/FontAwesome.otf
-%%WWWDIR%%/core/vendor/font-awesome/fonts/fontawesome-webfont.eot
-%%WWWDIR%%/core/vendor/font-awesome/fonts/fontawesome-webfont.svg
-%%WWWDIR%%/core/vendor/font-awesome/fonts/fontawesome-webfont.ttf
-%%WWWDIR%%/core/vendor/font-awesome/fonts/fontawesome-webfont.woff
-%%WWWDIR%%/core/vendor/font-awesome/less/bordered-pulled.less
-%%WWWDIR%%/core/vendor/font-awesome/less/core.less
-%%WWWDIR%%/core/vendor/font-awesome/less/fixed-width.less
-%%WWWDIR%%/core/vendor/font-awesome/less/font-awesome.less
-%%WWWDIR%%/core/vendor/font-awesome/less/icons.less
-%%WWWDIR%%/core/vendor/font-awesome/less/larger.less
-%%WWWDIR%%/core/vendor/font-awesome/less/list.less
-%%WWWDIR%%/core/vendor/font-awesome/less/mixins.less
-%%WWWDIR%%/core/vendor/font-awesome/less/path.less
-%%WWWDIR%%/core/vendor/font-awesome/less/rotated-flipped.less
-%%WWWDIR%%/core/vendor/font-awesome/less/spinning.less
-%%WWWDIR%%/core/vendor/font-awesome/less/stacked.less
-%%WWWDIR%%/core/vendor/font-awesome/less/variables.less
-%%WWWDIR%%/core/vendor/font-awesome/scss/_bordered-pulled.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_core.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_fixed-width.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_icons.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_larger.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_list.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_mixins.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_path.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_rotated-flipped.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_spinning.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_stacked.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/_variables.scss
-%%WWWDIR%%/core/vendor/font-awesome/scss/font-awesome.scss
-%%WWWDIR%%/core/vendor/jquery-1.11.1/jquery-1.11.1.min.js
-%%WWWDIR%%/core/vendor/phplot-6.1.0/COPYING
-%%WWWDIR%%/core/vendor/phplot-6.1.0/ChangeLog
-%%WWWDIR%%/core/vendor/phplot-6.1.0/NEWS.txt
-%%WWWDIR%%/core/vendor/phplot-6.1.0/NEWS_part1.txt
-%%WWWDIR%%/core/vendor/phplot-6.1.0/README.txt
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/README.txt
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/color_range.example.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/color_range.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/color_range.test1.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/color_range.test2.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/data_table.example1.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/data_table.example2.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/data_table.example3.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/data_table.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/prune_labels.example.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/prune_labels.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/contrib/prune_labels.test.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/phplot.php
-%%WWWDIR%%/core/vendor/phplot-6.1.0/rgb.inc.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/BUGS
-%%WWWDIR%%/core/vendor/smarty-2.6.28/COPYING.lib
-%%WWWDIR%%/core/vendor/smarty-2.6.28/ChangeLog
-%%WWWDIR%%/core/vendor/smarty-2.6.28/FAQ
-%%WWWDIR%%/core/vendor/smarty-2.6.28/INSTALL
-%%WWWDIR%%/core/vendor/smarty-2.6.28/NEWS
-%%WWWDIR%%/core/vendor/smarty-2.6.28/QUICK_START
-%%WWWDIR%%/core/vendor/smarty-2.6.28/README
-%%WWWDIR%%/core/vendor/smarty-2.6.28/RELEASE_NOTES
-%%WWWDIR%%/core/vendor/smarty-2.6.28/TODO
-%%WWWDIR%%/core/vendor/smarty-2.6.28/demo/configs/test.conf
-%%WWWDIR%%/core/vendor/smarty-2.6.28/demo/index.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/demo/templates/footer.tpl
-%%WWWDIR%%/core/vendor/smarty-2.6.28/demo/templates/header.tpl
-%%WWWDIR%%/core/vendor/smarty-2.6.28/demo/templates/index.tpl
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/Config_File.class.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/Smarty.class.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/Smarty_Compiler.class.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/debug.tpl
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.assemble_plugin_filepath.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.assign_smarty_interface.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.create_dir_structure.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.display_debug_console.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.get_include_path.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.get_microtime.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.get_php_resource.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.is_secure.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.is_trusted.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.load_plugins.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.load_resource_plugin.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.process_cached_inserts.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.process_compiled_include.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.read_cache_file.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.rm_auto.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.rmdir.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.run_insert_handler.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.smarty_include_php.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.write_cache_file.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.write_compiled_include.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.write_compiled_resource.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/internals/core.write_file.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/block.textformat.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/compiler.assign.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.assign_debug_info.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.config_load.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.counter.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.cycle.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.debug.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.eval.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.fetch.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.html_checkboxes.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.html_image.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.html_options.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.html_radios.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.html_select_date.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.html_select_time.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.html_table.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.mailto.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.math.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.popup.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/function.popup_init.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.capitalize.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.cat.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.count_characters.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.count_paragraphs.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.count_sentences.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.count_words.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.date_format.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.debug_print_var.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.default.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.escape.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.indent.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.lower.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.nl2br.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.regex_replace.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.replace.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.spacify.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.string_format.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.strip.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.strip_tags.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.truncate.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.upper.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/modifier.wordwrap.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/outputfilter.trimwhitespace.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/shared.escape_special_chars.php
-%%WWWDIR%%/core/vendor/smarty-2.6.28/libs/plugins/shared.make_timestamp.php
-%%WWWDIR%%/core/vendor/smarty-gettext-1.1/COPYING
-%%WWWDIR%%/core/vendor/smarty-gettext-1.1/ChangeLog
-%%WWWDIR%%/core/vendor/smarty-gettext-1.1/README
-%%WWWDIR%%/core/vendor/smarty-gettext-1.1/smarty-gettext.php
-%%WWWDIR%%/core/vendor/smarty-gettext-1.1/tsmarty2c.php
-%%BASE%%/index.php
-%%BASE%%/joblogs.php
-%%BASE%%/jobs.php
-%%BASE%%/pools.php
-%%BASE%%/test.php
-@owner
-@group
+%%WWWDIR%%/application/assets/protected/.htaccess
+%%WWWDIR%%/application/config/.htaccess
+%%WWWDIR%%/application/config/application.php
+%%WWWDIR%%/application/libs/fileconfig.class.php
+%%WWWDIR%%/application/locale/be_BY/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/be_BY/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/ca_ES/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/ca_ES/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/de_DE/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/de_DE/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/en_EN/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/en_EN/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/es_ES/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/es_ES/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/fr_FR/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/fr_FR/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/it_IT/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/it_IT/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/ja_JP/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/ja_JP/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/nl_NL/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/nl_NL/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/no_NO/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/no_NO/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/pl_PL/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/pl_PL/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/pt_BR/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/pt_BR/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/ru_RU/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/ru_RU/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/sv_SE/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/sv_SE/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/locale/zh_CN/LC_MESSAGES/messages.mo
+%%WWWDIR%%/application/locale/zh_CN/LC_MESSAGES/messages.po
+%%WWWDIR%%/application/models/clients.model.php
+%%WWWDIR%%/application/models/database.model.php
+%%WWWDIR%%/application/models/filesets.model.php
+%%WWWDIR%%/application/models/jobfiles.model.php
+%%WWWDIR%%/application/models/jobs.model.php
+%%WWWDIR%%/application/models/pools.model.php
+%%WWWDIR%%/application/models/volumes.model.php
+%%WWWDIR%%/application/views/backupjob.view.php
+%%WWWDIR%%/application/views/cache/README
+%%WWWDIR%%/application/views/client.view.php
+%%WWWDIR%%/application/views/dashboard.view.php
+%%WWWDIR%%/application/views/directors.view.php
+%%WWWDIR%%/application/views/jobfiles.php
+%%WWWDIR%%/application/views/joblogs.view.php
+%%WWWDIR%%/application/views/jobs.view.php
+%%WWWDIR%%/application/views/login.view.php
+%%WWWDIR%%/application/views/pools.view.php
+%%WWWDIR%%/application/views/settings.view.php
+%%WWWDIR%%/application/views/templates/backupjob-report.tpl
+%%WWWDIR%%/application/views/templates/client-report.tpl
+%%WWWDIR%%/application/views/templates/dashboard.tpl
+%%WWWDIR%%/application/views/templates/directors.tpl
+%%WWWDIR%%/application/views/templates/footer.tpl
+%%WWWDIR%%/application/views/templates/header.tpl
+%%WWWDIR%%/application/views/templates/jobfiles.tpl
+%%WWWDIR%%/application/views/templates/joblogs.tpl
+%%WWWDIR%%/application/views/templates/jobs.tpl
+%%WWWDIR%%/application/views/templates/layouts/default.tpl
+%%WWWDIR%%/application/views/templates/login.tpl
+%%WWWDIR%%/application/views/templates/pools.tpl
+%%WWWDIR%%/application/views/templates/settings.tpl
+%%WWWDIR%%/application/views/templates/test.tpl
+%%WWWDIR%%/application/views/templates/usersettings.tpl
+%%WWWDIR%%/application/views/templates/volumes.tpl
+%%WWWDIR%%/application/views/test.view.php
+%%WWWDIR%%/application/views/usersettings.view.php
+%%WWWDIR%%/application/views/volumes.view.php
+%%WWWDIR%%/console.php
+%%WWWDIR%%/core/app/cerrorhandler.class.php
+%%WWWDIR%%/core/app/cmodel.class.php
+%%WWWDIR%%/core/app/cview.class.php
+%%WWWDIR%%/core/app/userauth.class.php
+%%WWWDIR%%/core/app/webapplication.class.php
+%%WWWDIR%%/core/bweb.class.php
+%%WWWDIR%%/core/const.inc.php
+%%WWWDIR%%/core/db/cdb.class.php
+%%WWWDIR%%/core/db/cdbquery.class.php
+%%WWWDIR%%/core/db/cdbresult.class.php
+%%WWWDIR%%/core/db/cdbutils.class.php
+%%WWWDIR%%/core/global.inc.php
+%%WWWDIR%%/core/graph/chart.class.php
+%%WWWDIR%%/core/i18n/ctranslation.class.php
+%%WWWDIR%%/core/utils/chttprequest.class.php
+%%WWWDIR%%/core/utils/cutils.class.php
+%%WWWDIR%%/core/utils/datetimeutil.class.php
+%%WWWDIR%%/core/utils/file.class.php
+%%WWWDIR%%/core/utils/htmlhelper.class.php
+%%WWWDIR%%/docs/Changelog
+%%WWWDIR%%/docs/source/01_about/about.rst
+%%WWWDIR%%/docs/source/01_about/features.rst
+%%WWWDIR%%/docs/source/01_about/index.rst
+%%WWWDIR%%/docs/source/01_about/license.rst
+%%WWWDIR%%/docs/source/01_about/release.rst
+%%WWWDIR%%/docs/source/02_install/configure.rst
+%%WWWDIR%%/docs/source/02_install/configwebserver.rst
+%%WWWDIR%%/docs/source/02_install/finalize.rst
+%%WWWDIR%%/docs/source/02_install/index.rst
+%%WWWDIR%%/docs/source/02_install/install.rst
+%%WWWDIR%%/docs/source/02_install/installarchive.rst
+%%WWWDIR%%/docs/source/02_install/installcomposer.rst
+%%WWWDIR%%/docs/source/02_install/installnginx.rst
+%%WWWDIR%%/docs/source/02_install/overview.rst
+%%WWWDIR%%/docs/source/02_install/requirements.rst
+%%WWWDIR%%/docs/source/02_install/test.rst
+%%WWWDIR%%/docs/source/02_install/upgrade.rst
+%%WWWDIR%%/docs/source/03_gethelp/faq.rst
+%%WWWDIR%%/docs/source/03_gethelp/index.rst
+%%WWWDIR%%/docs/source/03_gethelp/support.rst
+%%WWWDIR%%/docs/source/04_contribute/development.rst
+%%WWWDIR%%/docs/source/04_contribute/index.rst
+%%WWWDIR%%/docs/source/04_contribute/translations.rst
+%%WWWDIR%%/docs/source/_static/bacula-web-backupjob-report.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-client-report.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-dashboard.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-directors.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-job-logs-option.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-job-logs.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-jobfiles.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-jobs-report-options.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-jobs-report.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-logo.png
+%%WWWDIR%%/docs/source/_static/bacula-web-pools.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-settings-menu.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-settings.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-test-page.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-user-settings-menu.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-user-settings.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-users.jpg
+%%WWWDIR%%/docs/source/_static/bacula-web-volumes.jpg
+%%WWWDIR%%/docs/source/_static/js/custom.js
+%%WWWDIR%%/docs/source/conf.py
+%%WWWDIR%%/docs/source/index.rst
+%%WWWDIR%%/index.php
+@owner www
+@group www
+@dir(,,744) %%WWWDIR%%/application/assets/protected
+@dir(,,744) %%WWWDIR%%/application/views/cache
+@sample %%WWWDIR%%/application/config/config.php.sample
+