aboutsummaryrefslogtreecommitdiff
path: root/www/bluefish
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-01 22:34:02 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-01 22:34:02 +0000
commit3bcee6a7c51f8338c03fea56f89ac7af26628ba1 (patch)
tree8972511fefcd238fac4b24875c0913226b03f82c /www/bluefish
parentbff269a5a6856dca39db3a75eade4ada2270ba48 (diff)
- Update to 2.0.0
Approved by: itetcu (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=250470
Diffstat (limited to 'www/bluefish')
-rw-r--r--www/bluefish/Makefile13
-rw-r--r--www/bluefish/distinfo6
-rw-r--r--www/bluefish/files/patch-data_bflang-Makefile.in26
-rw-r--r--www/bluefish/pkg-plist351
4 files changed, 360 insertions, 36 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 00325f82af70..9c1f8f349eac 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= bluefish
-PORTVERSION= 1.0.7
-PORTREVISION= 7
+PORTVERSION= 2.0.0
CATEGORIES= www editors
MASTER_SITES= SF
@@ -18,6 +17,9 @@ COMMENT= HTML editor designed for the experienced web designer
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
aspell.16:${PORTSDIR}/textproc/aspell
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+
.if !defined(WITHOUT_WEBLINT)
RUN_DEPENDS+= weblint:${PORTSDIR}/www/weblint
.endif
@@ -26,6 +28,7 @@ RUN_DEPENDS+= tidy:${PORTSDIR}/www/tidy
.endif
USE_BZIP2= yes
+USE_GMAKE= yes
USE_GNOME= gnomeprefix gtk20 gnomevfs2 gnomemimedata desktopfileutils
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -77,4 +80,10 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/bflang
+ ${INSTALL_DATA} ${WRKSRC}/data/bflang/sample.bflang2 ${DOCSDIR}/bflang
+.endif
.include <bsd.port.post.mk>
diff --git a/www/bluefish/distinfo b/www/bluefish/distinfo
index 838e5a26bab8..889acef4821b 100644
--- a/www/bluefish/distinfo
+++ b/www/bluefish/distinfo
@@ -1,3 +1,3 @@
-MD5 (bluefish-1.0.7.tar.bz2) = 2c3b3c9c8f8e32b9473dfd879f216dea
-SHA256 (bluefish-1.0.7.tar.bz2) = 68cb74b993ad31a86083e8eed482b2f5b4d523806538ea9bc42bfa8b4c0a1110
-SIZE (bluefish-1.0.7.tar.bz2) = 1495619
+MD5 (bluefish-2.0.0.tar.bz2) = ac9b1e8ef6d5691718a0daa6c78d5618
+SHA256 (bluefish-2.0.0.tar.bz2) = c0e41ba6a7d78392e5c62cf79744078f435d5e4188c58c406495c503871c916e
+SIZE (bluefish-2.0.0.tar.bz2) = 3287346
diff --git a/www/bluefish/files/patch-data_bflang-Makefile.in b/www/bluefish/files/patch-data_bflang-Makefile.in
new file mode 100644
index 000000000000..b904e29a7247
--- /dev/null
+++ b/www/bluefish/files/patch-data_bflang-Makefile.in
@@ -0,0 +1,26 @@
+--- data/bflang/Makefile.in.orig 2010-02-27 19:09:52.000000000 -0300
++++ data/bflang/Makefile.in 2010-02-27 19:53:42.000000000 -0300
+@@ -369,23 +369,6 @@
+ echo " rm -f '$(DESTDIR)$(bflangrngdir)/$$f'"; \
+ rm -f "$(DESTDIR)$(bflangrngdir)/$$f"; \
+ done
+-install-bflangsampleDATA: $(bflangsample_DATA)
+- @$(NORMAL_INSTALL)
+- test -z "$(bflangsampledir)" || $(MKDIR_P) "$(DESTDIR)$(bflangsampledir)"
+- @list='$(bflangsample_DATA)'; for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f=$(am__strip_dir) \
+- echo " $(bflangsampleDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(bflangsampledir)/$$f'"; \
+- $(bflangsampleDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(bflangsampledir)/$$f"; \
+- done
+-
+-uninstall-bflangsampleDATA:
+- @$(NORMAL_UNINSTALL)
+- @list='$(bflangsample_DATA)'; for p in $$list; do \
+- f=$(am__strip_dir) \
+- echo " rm -f '$(DESTDIR)$(bflangsampledir)/$$f'"; \
+- rm -f "$(DESTDIR)$(bflangsampledir)/$$f"; \
+- done
+ install-bflangxmlDATA: $(bflangxml_DATA)
+ @$(NORMAL_INSTALL)
+ test -z "$(bflangxmldir)" || $(MKDIR_P) "$(DESTDIR)$(bflangxmldir)"
diff --git a/www/bluefish/pkg-plist b/www/bluefish/pkg-plist
index 4817ee543072..9cd82ca4f13f 100644
--- a/www/bluefish/pkg-plist
+++ b/www/bluefish/pkg-plist
@@ -1,58 +1,347 @@
bin/bluefish
-%%DATADIR%%/bluefish_splash.png
-%%DATADIR%%/custom_menu.de.default
-%%DATADIR%%/custom_menu.default
-%%DATADIR%%/custom_menu.fr.default
-%%DATADIR%%/encodings.default
-%%DATADIR%%/filetypes.default
-%%DATADIR%%/funcref_css.xml
-%%DATADIR%%/funcref_html.xml
-%%DATADIR%%/funcref_php.xml
-%%DATADIR%%/funcref_python.xml
-%%DATADIR%%/highlighting.default
-%%DATADIR%%/icon_c.png
-%%DATADIR%%/icon_cfml.png
-%%DATADIR%%/icon_dir.png
-%%DATADIR%%/icon_html.png
-%%DATADIR%%/icon_image.png
-%%DATADIR%%/icon_java.png
-%%DATADIR%%/icon_pascal.png
-%%DATADIR%%/icon_php.png
-%%DATADIR%%/icon_python.png
-%%DATADIR%%/icon_r.png
-%%DATADIR%%/icon_unknown.png
-%%DATADIR%%/icon_xml.png
-share/applications/bluefish-project.desktop
+lib/bluefish/about.la
+lib/bluefish/about.so
+lib/bluefish/entities.la
+lib/bluefish/entities.so
+lib/bluefish/htmlbar.la
+lib/bluefish/htmlbar.so
+lib/bluefish/infbrowser.la
+lib/bluefish/infbrowser.so
+lib/bluefish/snippets.la
+lib/bluefish/snippets.so
share/applications/bluefish.desktop
-share/pixmaps/bluefish-icon.png
-share/pixmaps/gnome-mime-application-bluefish-project.png
+share/icons/hicolor/128x128/apps/bluefish.png
+share/icons/hicolor/128x128/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/16x16/apps/bluefish.png
+share/icons/hicolor/16x16/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/192x192/apps/bluefish.png
+share/icons/hicolor/192x192/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/22x22/apps/bluefish.png
+share/icons/hicolor/22x22/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/32x32/apps/bluefish.png
+share/icons/hicolor/32x32/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/36x36/apps/bluefish.png
+share/icons/hicolor/36x36/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/48x48/apps/bluefish.png
+share/icons/hicolor/48x48/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/64x64/apps/bluefish.png
+share/icons/hicolor/64x64/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/72x72/apps/bluefish.png
+share/icons/hicolor/72x72/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/96x96/apps/bluefish.png
+share/icons/hicolor/96x96/mimetypes/application-x-bluefish-project.png
+share/icons/hicolor/scalable/apps/bluefish-icon.svg
+share/icons/hicolor/scalable/mimetypes/bluefish-project.svg
share/locale/bg/LC_MESSAGES/bluefish.mo
+share/locale/bg/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/bg/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/bg/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/bg/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/bg/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/bg/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/cs/LC_MESSAGES/bluefish.mo
+share/locale/cs/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/cs/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/cs/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/cs/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/cs/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/cs/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/da/LC_MESSAGES/bluefish.mo
+share/locale/da/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/da/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/da/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/da/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/da/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/da/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/de/LC_MESSAGES/bluefish.mo
+share/locale/de/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/de/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/de/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/de/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/de/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/de/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/locale/el/LC_MESSAGES/bluefish.mo
+share/locale/el/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/el/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/el/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/el/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/el/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/el/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/es/LC_MESSAGES/bluefish.mo
+share/locale/es/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/es/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/es/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/es/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/es/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/es/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/eu/LC_MESSAGES/bluefish.mo
+share/locale/eu/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/eu/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/eu/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/eu/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/eu/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/eu/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/fi/LC_MESSAGES/bluefish.mo
+share/locale/fi/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/fi/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/fi/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/fi/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/fi/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/fi/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/fr/LC_MESSAGES/bluefish.mo
+share/locale/fr/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/fr/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/fr/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/fr/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/fr/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/fr/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/locale/gl/LC_MESSAGES/bluefish.mo
+share/locale/gl/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/gl/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/gl/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/gl/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/gl/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/gl/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/hu/LC_MESSAGES/bluefish.mo
+share/locale/hu/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/hu/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/hu/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/hu/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/hu/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/hu/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/it/LC_MESSAGES/bluefish.mo
+share/locale/it/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/it/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/it/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/it/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/it/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/it/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/ja/LC_MESSAGES/bluefish.mo
-share/locale/no/LC_MESSAGES/bluefish.mo
+share/locale/ja/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/ja/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/ja/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/ja/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/ja/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/ja/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/locale/ko_KR/LC_MESSAGES/bluefish.mo
+share/locale/ko_KR/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/ko_KR/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/ko_KR/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/ko_KR/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/ko_KR/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/ko_KR/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/locale/nb/LC_MESSAGES/bluefish.mo
+share/locale/nb/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/nb/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/nb/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/nb/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/nb/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/nb/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/locale/nl/LC_MESSAGES/bluefish.mo
+share/locale/nl/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/nl/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/nl/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/nl/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/nl/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/nl/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/pl/LC_MESSAGES/bluefish.mo
+share/locale/pl/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/pl/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/pl/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/pl/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/pl/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/pl/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/pt/LC_MESSAGES/bluefish.mo
+share/locale/pt/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/pt/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/pt/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/pt/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/pt/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/pt/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/pt_BR/LC_MESSAGES/bluefish.mo
+share/locale/pt_BR/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/pt_BR/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/pt_BR/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/pt_BR/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/pt_BR/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/pt_BR/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/locale/ro/LC_MESSAGES/bluefish.mo
+share/locale/ro/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/ro/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/ro/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/ro/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/ro/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/ro/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/ru/LC_MESSAGES/bluefish.mo
+share/locale/ru/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/ru/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/ru/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/ru/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/ru/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/ru/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/sk/LC_MESSAGES/bluefish.mo
+share/locale/sk/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/sk/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/sk/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/sk/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/sk/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/sk/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/sr/LC_MESSAGES/bluefish.mo
+share/locale/sr/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/sr/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/sr/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/sr/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/sr/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/sr/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/sv/LC_MESSAGES/bluefish.mo
+share/locale/sv/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/sv/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/sv/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/sv/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/sv/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/sv/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/ta/LC_MESSAGES/bluefish.mo
+share/locale/ta/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/ta/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/ta/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/ta/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/ta/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/ta/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/tr/LC_MESSAGES/bluefish.mo
+share/locale/tr/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/tr/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/tr/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/tr/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/tr/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/tr/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/locale/uk/LC_MESSAGES/bluefish.mo
+share/locale/uk/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/uk/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/uk/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/uk/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/uk/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/uk/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/zh_CN/LC_MESSAGES/bluefish.mo
+share/locale/zh_CN/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/zh_CN/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/zh_CN/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/zh_CN/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/zh_CN/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/zh_CN/LC_MESSAGES/bluefish_plugin_snippets.mo
share/locale/zh_TW/LC_MESSAGES/bluefish.mo
+share/locale/zh_TW/LC_MESSAGES/bluefish_plugin_about.mo
+share/locale/zh_TW/LC_MESSAGES/bluefish_plugin_charmap.mo
+share/locale/zh_TW/LC_MESSAGES/bluefish_plugin_entities.mo
+share/locale/zh_TW/LC_MESSAGES/bluefish_plugin_htmlbar.mo
+share/locale/zh_TW/LC_MESSAGES/bluefish_plugin_infbrowser.mo
+share/locale/zh_TW/LC_MESSAGES/bluefish_plugin_snippets.mo
+share/mime/application/x-bluefish-language2.xml
+share/mime/application/x-bluefish-project.xml
share/mime/packages/bluefish.xml
-@dirrm share/bluefish
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+share/pixmaps/application-x-bluefish-project.png
+share/pixmaps/bluefish.png
+share/xml/bluefish/2.0/bflang2.rng
+share/xml/bluefish/catalog.xml
+%%DATADIR%%/bflang/ada.bflang2
+%%DATADIR%%/bflang/all-html.bfinc
+%%DATADIR%%/bflang/all-javascript.bfinc
+%%DATADIR%%/bflang/all-php.bfinc
+%%DATADIR%%/bflang/all-vbscript.bfinc
+%%DATADIR%%/bflang/asp-vbscript.bflang2
+%%DATADIR%%/bflang/asp.bflang2
+%%DATADIR%%/bflang/bflang2.bflang2
+%%DATADIR%%/bflang/c.bflang2
+%%DATADIR%%/bflang/cpp.bflang2
+%%DATADIR%%/bflang/css-rules.bfinc
+%%DATADIR%%/bflang/css-selectors.bfinc
+%%DATADIR%%/bflang/css.bflang2
+%%DATADIR%%/bflang/d.bflang2
+%%DATADIR%%/bflang/diff.bflang2
+%%DATADIR%%/bflang/html.bflang2
+%%DATADIR%%/bflang/java.bflang2
+%%DATADIR%%/bflang/javascript.bflang2
+%%DATADIR%%/bflang/jsp.bflang2
+%%DATADIR%%/bflang/mediawiki.bflang2
+%%DATADIR%%/bflang/nsis.bflang2
+%%DATADIR%%/bflang/perl.bflang2
+%%DATADIR%%/bflang/php.bflang2
+%%DATADIR%%/bflang/po.bflang2
+%%DATADIR%%/bflang/python.bflang2
+%%DATADIR%%/bflang/ruby.bflang2
+%%DATADIR%%/bflang/shell.bflang2
+%%DATADIR%%/bflang/smarty.bflang2
+%%DATADIR%%/bflang/sql.bflang2
+%%DATADIR%%/bflang/text.bflang2
+%%DATADIR%%/bflang/vbscript.bflang2
+%%DATADIR%%/bflang/xhtml.bflang2
+%%DATADIR%%/bflang/xml.bflang2
+%%DATADIR%%/bflib/bflib_DocBook_4_5.xml.gz
+%%DATADIR%%/bflib/bflib_DocBook_5_0.xml.gz
+%%DATADIR%%/bflib/bflib_SVG_1_0.xml.gz
+%%DATADIR%%/bflib/bflib_SVG_1_1_Basic.xml.gz
+%%DATADIR%%/bflib/bflib_SVG_1_1_Full.xml.gz
+%%DATADIR%%/bflib/bflib_SVG_1_1_Tiny.xml.gz
+%%DATADIR%%/bflib/bflib_XHTML_1_0_Frameset.xml.gz
+%%DATADIR%%/bflib/bflib_XHTML_1_0_Strict.xml.gz
+%%DATADIR%%/bflib/bflib_XHTML_1_0_Transitional.xml.gz
+%%DATADIR%%/bflib/bflib_XHTML_1_0_W3C.xml.gz
+%%DATADIR%%/bflib/bflib_XHTML_1_1.xml.gz
+%%DATADIR%%/bflib/bflib_css2.xml.gz
+%%DATADIR%%/bflib/bflib_dom.xml.gz
+%%DATADIR%%/bflib/bflib_php4.xml.gz
+%%DATADIR%%/bflib/bflib_php5.xml.gz
+%%DATADIR%%/bflib/bflib_php5_with_examples.xml.gz
+%%DATADIR%%/bflib/bflib_python_2.3.xml.gz
+%%DATADIR%%/bflib/bflib_xhtml.xml.gz
+%%DATADIR%%/bluefish_splash.png
+%%DATADIR%%/encodings
+%%PORTDOCS%%%%DOCSDIR%%/bflang/sample.bflang2
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/bflang
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/xml/bluefish/2.0
+@dirrm share/xml/bluefish
+@dirrmtry share/mime/packages
+@dirrmtry share/mime/application
@dirrmtry share/mime
+@dirrmtry share/locale/ko_KR/LC_MESSAGES
+@dirrmtry share/locale/ko_KR
+@dirrmtry share/icons/hicolor/scalable/mimetypes
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/96x96/mimetypes
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/mimetypes
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/mimetypes
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/mimetypes
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/36x36/mimetypes
+@dirrmtry share/icons/hicolor/36x36/apps
+@dirrmtry share/icons/hicolor/36x36
+@dirrmtry share/icons/hicolor/32x32/mimetypes
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/22x22/mimetypes
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/192x192/mimetypes
+@dirrmtry share/icons/hicolor/192x192/apps
+@dirrmtry share/icons/hicolor/192x192
+@dirrmtry share/icons/hicolor/16x16/mimetypes
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/mimetypes
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
@dirrmtry share/applications
+@dirrm lib/bluefish
+@dirrm %%DATADIR%%/bflib
+@dirrm %%DATADIR%%/bflang
+@dirrm %%DATADIR%%