aboutsummaryrefslogtreecommitdiff
path: root/www/buku
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-03 07:27:21 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-03 07:27:21 +0000
commit98d6c51f04c64913baaa563a689cf06e700402e0 (patch)
tree6cb98a14bdd8e5d285114cbc33870758857e7930 /www/buku
parent1722513b5c2aa3273920b36f2c91b9f08fcc0e65 (diff)
downloadports-98d6c51f04c64913baaa563a689cf06e700402e0.tar.gz
ports-98d6c51f04c64913baaa563a689cf06e700402e0.zip
Starting with buku 3.8 buku comes with a new command bukuserver that spins up a
web server for hosting buku as a webinstance. This new command depends on a bunch of Flask dependencies some of which are not available in ports. Unbundle bukuserver at this point until we have the Flask dependencies available. Buku requires www/py-html5lib to run. PR: 231112 (based on) Notified by: Greg Fitzgerald <gregf@hugops.pw>
Notes
Notes: svn path=/head/; revision=478845
Diffstat (limited to 'www/buku')
-rw-r--r--www/buku/Makefile7
-rw-r--r--www/buku/files/patch-setup.py35
2 files changed, 41 insertions, 1 deletions
diff --git a/www/buku/Makefile b/www/buku/Makefile
index 2f459d4c06fa..561e2539842d 100644
--- a/www/buku/Makefile
+++ b/www/buku/Makefile
@@ -4,6 +4,7 @@
PORTNAME= buku
PORTVERSION= 3.9
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www python
MAINTAINER= ehaupt@FreeBSD.org
@@ -15,7 +16,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0:www/py-beautifulsoup@${PY
${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.0.1:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>=1.21.1:net/py-urllib3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${PY_FLAVOR}
USES= python:3.4+
USE_GITHUB= yes
@@ -27,6 +29,9 @@ GH_PROJECT= Buku
PLIST_FILES= man/man1/buku.1.gz
+post-extract:
+ @${RM} -rf ${WRKSRC}/bukuserver
+
post-install:
${INSTALL_MAN} ${WRKSRC}/buku.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/www/buku/files/patch-setup.py b/www/buku/files/patch-setup.py
new file mode 100644
index 000000000000..24f58936204d
--- /dev/null
+++ b/www/buku/files/patch-setup.py
@@ -0,0 +1,35 @@
+--- setup.py.orig 2018-08-30 12:28:10 UTC
++++ setup.py
+@@ -28,19 +28,6 @@ tests_require = [
+ ]
+
+
+-server_require = [
+- 'arrow>=0.12.1',
+- 'click>=6.7',
+- 'Flask-Admin==1.5.1',
+- 'Flask-API>=0.6.9',
+- 'Flask-Bootstrap>=3.3.7.1',
+- 'flask-paginate>=0.5.1',
+- 'Flask-WTF>=0.14.2',
+- 'Flask>=0.12',
+- 'requests>=2.18.4',
+- 'Werkzeug>=0.11.15',
+-]
+-
+ setup(
+ name='buku',
+ version=version,
+@@ -63,11 +50,10 @@ setup(
+ packages=find_packages(exclude=['tests']),
+ include_package_data=True,
+ entry_points={
+- 'console_scripts': ['buku=buku:main', 'bukuserver=bukuserver.server:cli']
++ 'console_scripts': ['buku=buku:main']
+ },
+ extras_require={
+ 'tests': tests_require,
+- 'server': server_require,
+ 'packaging': ['twine>=1.11.0']
+ },
+ test_suite='tests',