aboutsummaryrefslogtreecommitdiff
path: root/www/c-icap-modules
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-05-14 17:00:23 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-05-14 17:00:23 +0000
commit71d821e2a4e0453c620c9e3216ba1d6bf23b5459 (patch)
treeb4d7dbe2868606ca461ede326ba623ddc728362a /www/c-icap-modules
parent5ede0f006925c5401e8b54c45b5e1d2096025b75 (diff)
downloadports-71d821e2a4e0453c620c9e3216ba1d6bf23b5459.tar.gz
ports-71d821e2a4e0453c620c9e3216ba1d6bf23b5459.zip
. Use new LIB_DEPENDS syntax
. INSTALL_TARGET = install-strip . USES libtool and drop .la files . Let the copy of default conf to .conf to pkg-plist only and make check-plist happy Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=354076
Diffstat (limited to 'www/c-icap-modules')
-rw-r--r--www/c-icap-modules/Makefile18
-rw-r--r--www/c-icap-modules/files/patch-services__url_check__Makefile.in10
-rw-r--r--www/c-icap-modules/files/patch-services__virus_scan__Makefile.in10
-rw-r--r--www/c-icap-modules/pkg-plist4
4 files changed, 25 insertions, 17 deletions
diff --git a/www/c-icap-modules/Makefile b/www/c-icap-modules/Makefile
index 9432eb84070e..cd26aab4627d 100644
--- a/www/c-icap-modules/Makefile
+++ b/www/c-icap-modules/Makefile
@@ -3,7 +3,7 @@
PORTNAME= c-icap
PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/0.3.x/
PKGNAMESUFFIX= -modules
@@ -14,10 +14,12 @@ COMMENT= c-icap modules virus_scan and srv_url_check
LICENSE= GPLv2
-LIB_DEPENDS+= icapapi.3:${PORTSDIR}/www/c-icap \
- clamav:${PORTSDIR}/security/clamav
+LIB_DEPENDS+= libicapapi.so:${PORTSDIR}/www/c-icap \
+ libclamav.so:${PORTSDIR}/security/clamav
+USES= libtool
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
DATADIR= ${PREFIX}/share/c_icap
CFLAGS+= -DHAVE_STRNSTR
@@ -29,14 +31,4 @@ CONFIGURE_ARGS+= --enable-static \
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/c-icap
-post-install:
- @${CP} -np ${STAGEDIR}${PREFIX}/etc/c-icap/clamav_mod.conf.default \
- ${STAGEDIR}${PREFIX}/etc/c-icap/clamav_mod.conf || ${TRUE}
- @${CP} -np ${STAGEDIR}${PREFIX}/etc/c-icap/clamd_mod.conf.default \
- ${STAGEDIR}${PREFIX}/etc/c-icap/clamd_mod.conf || ${TRUE}
- @${CP} -np ${STAGEDIR}${PREFIX}/etc/c-icap/srv_url_check.conf.default \
- ${STAGEDIR}${PREFIX}/etc/c-icap/srv_url_check.conf || ${TRUE}
- @${CP} -np ${STAGEDIR}${PREFIX}/etc/c-icap/virus_scan.conf.default \
- ${STAGEDIR}${PREFIX}/etc/c-icap/virus_scan.conf || ${TRUE}
-
.include <bsd.port.mk>
diff --git a/www/c-icap-modules/files/patch-services__url_check__Makefile.in b/www/c-icap-modules/files/patch-services__url_check__Makefile.in
new file mode 100644
index 000000000000..a86c1627dfcc
--- /dev/null
+++ b/www/c-icap-modules/files/patch-services__url_check__Makefile.in
@@ -0,0 +1,10 @@
+--- services/url_check/Makefile.in.orig 2014-05-14 16:56:34.000000000 -0300
++++ services/url_check/Makefile.in 2014-05-14 16:56:46.000000000 -0300
+@@ -731,7 +731,6 @@
+
+ install-data-local:
+ $(INSTALL) srv_url_check.conf $(DESTDIR)$(CONFIGDIR)/srv_url_check.conf.default
+- if test ! -f $(DESTDIR)$(CONFIGDIR)/srv_url_check.conf; then $(INSTALL) srv_url_check.conf $(DESTDIR)$(CONFIGDIR)/srv_url_check.conf; fi
+ $(mkinstalldirs) $(DESTDIR)$(cicapdatadir)/templates/srv_url_check/en
+ $(INSTALL) $(TMPLS) $(DESTDIR)$(cicapdatadir)/templates/srv_url_check/en/
+
diff --git a/www/c-icap-modules/files/patch-services__virus_scan__Makefile.in b/www/c-icap-modules/files/patch-services__virus_scan__Makefile.in
new file mode 100644
index 000000000000..4268eebd87b7
--- /dev/null
+++ b/www/c-icap-modules/files/patch-services__virus_scan__Makefile.in
@@ -0,0 +1,10 @@
+--- services/virus_scan/Makefile.in.orig 2014-05-14 16:54:38.000000000 -0300
++++ services/virus_scan/Makefile.in 2014-05-14 16:54:56.000000000 -0300
+@@ -647,7 +647,6 @@
+ install-data-local:
+ for f in $(CONFS); do \
+ $(INSTALL) $$f $(DESTDIR)$(CONFIGDIR)/$$f.default; \
+- if test ! -f $(DESTDIR)$(CONFIGDIR)/$$f; then $(INSTALL) $$f $(DESTDIR)$(CONFIGDIR)/$$f; fi \
+ done
+ $(mkinstalldirs) $(DESTDIR)$(cicapdatadir)/templates/virus_scan/en/
+ for f in $(TMPLS); do $(INSTALL) $$f $(DESTDIR)$(cicapdatadir)/templates/virus_scan/en/; done
diff --git a/www/c-icap-modules/pkg-plist b/www/c-icap-modules/pkg-plist
index b944e7aea10f..550f56cc2231 100644
--- a/www/c-icap-modules/pkg-plist
+++ b/www/c-icap-modules/pkg-plist
@@ -11,16 +11,12 @@ etc/c-icap/srv_url_check.conf.default
etc/c-icap/virus_scan.conf.default
@exec [ -f %B/virus_scan.conf ] || cp %B/%f %B/virus_scan.conf
lib/c_icap/clamav_mod.a
-lib/c_icap/clamav_mod.la
lib/c_icap/clamav_mod.so
lib/c_icap/clamd_mod.a
-lib/c_icap/clamd_mod.la
lib/c_icap/clamd_mod.so
lib/c_icap/srv_url_check.a
-lib/c_icap/srv_url_check.la
lib/c_icap/srv_url_check.so
lib/c_icap/virus_scan.a
-lib/c_icap/virus_scan.la
lib/c_icap/virus_scan.so
man/man8/c-icap-mods-sguardDB.8.gz
%%DATADIR%%/templates/srv_url_check/en/DENY