aboutsummaryrefslogtreecommitdiff
path: root/www/c-icap
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2018-09-30 08:58:41 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2018-09-30 08:58:41 +0000
commit34ef2472882103e21c3db6563d2be62a804705a0 (patch)
treeaf49bda5656931008369a7a82da8f9fadd81f576 /www/c-icap
parent9e8cb43713a2985169557e6b4d87b54062dfabfc (diff)
downloadports-34ef2472882103e21c3db6563d2be62a804705a0.tar.gz
ports-34ef2472882103e21c3db6563d2be62a804705a0.zip
Upgrade c-icap to 0.5.5
- Update c-icap to 0.5.5 - Move USES to a better place and silence portlint - Remove 'ListenAddress 127.0.0.1' parameter from sample c-icap.conf since it doesn't work. Instead, replace the change to 'Port 127.0.0.1:1344'. More references about this problem at https://redmine.pfsense.org/issues/8832#note-10 - Regenerate patches with 'make makepatch' c-icap-0.5.5 changes - c-icap may crash with a SIGBUS while using mmap to map files to memory. - Fix multiple brotli decoding bugs - c-icap-client does not send the ";ieof" preview termination sequence when sends zero sized files PR: 231377 Submitted by: garga
Notes
Notes: svn path=/head/; revision=480943
Diffstat (limited to 'www/c-icap')
-rw-r--r--www/c-icap/Makefile5
-rw-r--r--www/c-icap/distinfo6
-rw-r--r--www/c-icap/files/patch-c-icap.conf.in24
-rw-r--r--www/c-icap/files/patch-modules_memcached.c4
-rw-r--r--www/c-icap/pkg-plist2
5 files changed, 17 insertions, 24 deletions
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index 5e3ddf9462de..3cd810054440 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= c-icap
-PORTVERSION= 0.5.3
+PORTVERSION= 0.5.5
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.5.x/
@@ -17,11 +17,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libbrotlicommon.so:archivers/brotli \
libpcre.so:devel/pcre
+USES= cpe libtool localbase
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir="${PREFIX}/etc/c-icap" \
--localstatedir=/var
INSTALL_TARGET= install-strip
-USES= cpe libtool localbase
CPE_VENDOR= c-icap_project
USE_LDCONFIG= yes
USE_RC_SUBR= c-icap
diff --git a/www/c-icap/distinfo b/www/c-icap/distinfo
index 26ab3beee7c2..6ab914417029 100644
--- a/www/c-icap/distinfo
+++ b/www/c-icap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1523315387
-SHA256 (c_icap-0.5.3.tar.gz) = 0238508c94a406c7a2c8a0ff9659e7ba631554eda55001b43351bb68f85121d2
-SIZE (c_icap-0.5.3.tar.gz) = 690423
+TIMESTAMP = 1537896280
+SHA256 (c_icap-0.5.5.tar.gz) = 5eafc7775ecb3fe49545451eaa31f045716d0242977588c0ba27c2c1b4683d8a
+SIZE (c_icap-0.5.5.tar.gz) = 690954
diff --git a/www/c-icap/files/patch-c-icap.conf.in b/www/c-icap/files/patch-c-icap.conf.in
index baeb5d8d8fe0..1e795e66ecac 100644
--- a/www/c-icap/files/patch-c-icap.conf.in
+++ b/www/c-icap/files/patch-c-icap.conf.in
@@ -1,19 +1,11 @@
---- c-icap.conf.in.orig 2016-03-29 09:27:15 UTC
+--- c-icap.conf.in.orig 2018-09-12 13:40:37 UTC
+++ c-icap.conf.in
-@@ -123,6 +123,16 @@ MaxRequestsPerChild 0
+@@ -132,7 +132,7 @@ MaxRequestsPerChild 0
+ # Port [::1]:1346
# Default:
- # InterProcessLockingScheme file
+ # None
+-Port 1344
++Port 127.0.0.1:1344
-+# TAG: ListenAddress
-+# Format: ListenAddress address
-+# Description:
-+# Network address that the c-icap server uses to listen to requests.
-+# By default c-icap will bind to all available network addresses. Use
-+# this directive to restrict it to specific network address.
-+# Default:
-+# No value
-+ListenAddress 127.0.0.1
-+
- # TAG: Port
- # Format: Port port
- # Description:
+ # TAG: TlsPort
+ # Format: TlsPort [address:]port [tls-method=method] [cert=path_to_pem_cert] [key=path_to_pem_key] [client_ca=path_to_pem_file] [ciphers=ciph1:ciph2...] [tls_options=[!]Opt1|[!]Opt2|...]
diff --git a/www/c-icap/files/patch-modules_memcached.c b/www/c-icap/files/patch-modules_memcached.c
index 56f0d7ed50d6..3fd1844c9b21 100644
--- a/www/c-icap/files/patch-modules_memcached.c
+++ b/www/c-icap/files/patch-modules_memcached.c
@@ -1,4 +1,4 @@
---- modules/memcached.c.orig 2016-04-30 12:42:52 UTC
+--- modules/memcached.c.orig 2017-10-21 06:57:48 UTC
+++ modules/memcached.c
@@ -47,7 +47,7 @@
#include <libmemcached/memcached_pool.h>
@@ -8,4 +8,4 @@
+/* #include <crypt.h> */
int USE_MD5_SUM_KEYS = 1;
-
+
diff --git a/www/c-icap/pkg-plist b/www/c-icap/pkg-plist
index 1a69b92542f3..404740ce67a7 100644
--- a/www/c-icap/pkg-plist
+++ b/www/c-icap/pkg-plist
@@ -53,7 +53,7 @@ lib/c_icap/srv_ex206.so
lib/c_icap/sys_logger.so
lib/libicapapi.so
lib/libicapapi.so.5
-lib/libicapapi.so.5.0.3
+lib/libicapapi.so.5.0.5
man/man8/c-icap-client.8.gz
man/man8/c-icap-config.8.gz
man/man8/c-icap-libicapapi-config.8.gz