aboutsummaryrefslogtreecommitdiff
path: root/www/calamaris-devel
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2016-06-21 12:05:39 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2016-06-21 12:05:39 +0000
commit117bbba7ab71ae216c389e138a5b7ec7cb9a4cfd (patch)
treebb5c8b3c8eff8d5e0accc6d119c138c4edd3c285 /www/calamaris-devel
parentf2e766b1be60deea7f02921bcd88c770dd70445c (diff)
downloadports-117bbba7ab71ae216c389e138a5b7ec7cb9a4cfd.tar.gz
ports-117bbba7ab71ae216c389e138a5b7ec7cb9a4cfd.zip
Add devel version of calamaris port (which is able to parse fresh squid logs)
Notes
Notes: svn path=/head/; revision=417202
Diffstat (limited to 'www/calamaris-devel')
-rw-r--r--www/calamaris-devel/Makefile35
-rw-r--r--www/calamaris-devel/distinfo2
-rw-r--r--www/calamaris-devel/pkg-descr6
-rw-r--r--www/calamaris-devel/pkg-plist10
4 files changed, 53 insertions, 0 deletions
diff --git a/www/calamaris-devel/Makefile b/www/calamaris-devel/Makefile
new file mode 100644
index 000000000000..99455aef865b
--- /dev/null
+++ b/www/calamaris-devel/Makefile
@@ -0,0 +1,35 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= calamaris
+PORTVERSION= 2.99.4.5
+CATEGORIES= www textproc
+MASTER_SITES= http://cord.de/files/calamaris/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Perl script to produce statistics out of Squid log files
+
+LICENSE= GPLv2
+
+CONFLICTS_INSTALL= calamaris-[0-9]*
+
+USES= shebangfix perl5
+NO_BUILD= yes
+SHEBANG_FILES= calamaris calamaris-cache-convert
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/calamaris-cache-convert ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}
+ ${INSTALL_DATA} ${WRKSRC}/calAxestype.pm ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}
+ ${INSTALL_DATA} ${WRKSRC}/calAxestype3d.pm ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}
+ ${INSTALL_DATA} ${WRKSRC}/calBars3d.pm ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}
+ ${INSTALL_DATA} ${WRKSRC}/calamaris.conf ${STAGEDIR}${PREFIX}/etc/calamaris.conf.sample
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/EXAMPLES ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/www/calamaris-devel/distinfo b/www/calamaris-devel/distinfo
new file mode 100644
index 000000000000..ba82198ad05c
--- /dev/null
+++ b/www/calamaris-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (calamaris-2.59.tar.gz) = 60103bf6bfe0142bf2a0dfa7f7647ae7ed739b8b3082f11b8e55e21c2546d7ae
+SIZE (calamaris-2.59.tar.gz) = 56168
diff --git a/www/calamaris-devel/pkg-descr b/www/calamaris-devel/pkg-descr
new file mode 100644
index 000000000000..4ed76d781488
--- /dev/null
+++ b/www/calamaris-devel/pkg-descr
@@ -0,0 +1,6 @@
+Calamaris parses the Squid Native Log and generates reports
+about Peak-usage, Request-Methods, Status-reports of incoming
+and outgoing requests, second and Top-level destinations,
+content-types and performance.
+
+WWW: http://Cord.de/tools/squid/calamaris/
diff --git a/www/calamaris-devel/pkg-plist b/www/calamaris-devel/pkg-plist
new file mode 100644
index 000000000000..c6ed76b2c425
--- /dev/null
+++ b/www/calamaris-devel/pkg-plist
@@ -0,0 +1,10 @@
+bin/calamaris
+bin/calamaris-cache-convert
+man/man1/calamaris.1.gz
+%%SITE_ARCH%%/calAxestype.pm
+%%SITE_ARCH%%/calAxestype3d.pm
+%%SITE_ARCH%%/calBars3d.pm
+%%PORTDOCS%%share/doc/calamaris/EXAMPLES
+%%PORTDOCS%%share/doc/calamaris/EXAMPLES.v3
+%%PORTDOCS%%share/doc/calamaris/README
+@sample etc/calamaris.conf.sample