aboutsummaryrefslogtreecommitdiff
path: root/www/carbonapi
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-10-31 16:11:13 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-10-31 16:11:13 +0000
commit542ce8bc634e0b02cd7ee339ca3ea0b5a57f5627 (patch)
treed9ccac1fb30f1fcc1f6e761eeac7d23f3bf66d49 /www/carbonapi
parent1c5dc9d9b5243cf81e031b050b99995aea49a4d3 (diff)
downloadports-542ce8bc634e0b02cd7ee339ca3ea0b5a57f5627.tar.gz
ports-542ce8bc634e0b02cd7ee339ca3ea0b5a57f5627.zip
www/carbonapi: Update to 0.14.1
- update to 0.14.1 - switch to go:modules - drop gmake and use GO_TARGET instead - build carbonzipper - move examples files to EXAMPLESDIR - remove excessive tabs PR: 247083 Approved by: a.andersson.thn@gmail.com (maintainer timeout)
Notes
Notes: svn path=/head/; revision=553776
Diffstat (limited to 'www/carbonapi')
-rw-r--r--www/carbonapi/Makefile61
-rw-r--r--www/carbonapi/distinfo6
-rw-r--r--www/carbonapi/files/patch-cmd_carbonapi_carbonapi.example.toml (renamed from www/carbonapi/files/patch-carbonapi.example.toml)11
-rw-r--r--www/carbonapi/files/patch-cmd_carbonapi_carbonapi.example.yaml (renamed from www/carbonapi/files/patch-carbonapi.example.yaml)8
-rw-r--r--www/carbonapi/pkg-plist14
5 files changed, 52 insertions, 48 deletions
diff --git a/www/carbonapi/Makefile b/www/carbonapi/Makefile
index 12a51687467e..d11ca26e0ab9 100644
--- a/www/carbonapi/Makefile
+++ b/www/carbonapi/Makefile
@@ -1,45 +1,44 @@
# $FreeBSD$
-PORTNAME= carbonapi
-DISTVERSION= 0.11.0
-CATEGORIES= www
+PORTNAME= carbonapi
+DISTVERSION= 0.14.1
+CATEGORIES= www
-MAINTAINER= a.andersson.thn@gmail.com
-COMMENT= Go implementation of carbonapi
+MAINTAINER= a.andersson.thn@gmail.com
+COMMENT= Go implementation of carbonapi
-LICENSE= BSD2CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake go
+USES= go:modules
-USE_GITHUB= yes
-GH_ACCOUNT= go-graphite
-GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
-USE_RC_SUBR= ${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= go-graphite
-USERS= carbon
-GROUPS= carbon
+USE_RC_SUBR= ${PORTNAME}
-OPTIONS_DEFINE= CAIRO
+GO_TARGET= ./cmd/carbonapi \
+ ./cmd/carbonzipper
+GO_BUILDFLAGS= -v \
+ ${CARBON_ARGS} \
+ -ldflags="-X main.BuildVersion=${DISTVERSION}"
-CAIRO_USES= pkgconfig
-CAIRO_VARS= CARBON_API_ARGS=${PORTNAME}
-CAIRO_VARS_OFF= CARBON_API_ARGS=nocairo
-CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
+USERS= carbon
+GROUPS= carbon
+
+OPTIONS_DEFINE= CAIRO EXAMPLES
-do-build:
- @cd ${WRKSRC}/${GH_SUBDIR} && \
- ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} VERSION=${DISTVERSION} \
- ${MAKE_CMD} ${CARBON_API_ARGS}
+CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
+CAIRO_USES= pkgconfig
+CAIRO_VARS= CARBON_ARGS="-tags cairo"
-do-install:
- @${MKDIR} ${STAGEDIR}/${PREFIX}/etc/carbonapi
+post-install:
@${MKDIR} ${STAGEDIR}/var/log/carbonapi
- ${INSTALL_PROGRAM} ${WRKSRC}/carbonapi ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/carbonapi.example.toml ${STAGEDIR}${PREFIX}/etc/carbonapi
- ${INSTALL_DATA} ${WRKSRC}/carbonapi.example.yaml ${STAGEDIR}${PREFIX}/etc/carbonapi
- ${INSTALL_DATA} ${WRKSRC}/graphiteWeb.example.yaml ${STAGEDIR}${PREFIX}/etc/carbonapi
- ${INSTALL_DATA} ${WRKSRC}/graphTemplates.example.toml ${STAGEDIR}${PREFIX}/etc/carbonapi
- ${INSTALL_DATA} ${WRKSRC}/graphTemplates.example.yaml ${STAGEDIR}${PREFIX}/etc/carbonapi
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/cmd/carbonapi/*.toml ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/cmd/carbonapi/*.yaml ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/cmd/carbonzipper/example.conf ${STAGEDIR}${EXAMPLESDIR}/carbonzipper.example.conf
.include <bsd.port.mk>
diff --git a/www/carbonapi/distinfo b/www/carbonapi/distinfo
index 35963113e94e..15e47084a466 100644
--- a/www/carbonapi/distinfo
+++ b/www/carbonapi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522042565
-SHA256 (go-graphite-carbonapi-0.11.0_GH0.tar.gz) = d54228f0fce17db1ed319bc7a65c4296b539e6fec34645bfcaed4baf39840efc
-SIZE (go-graphite-carbonapi-0.11.0_GH0.tar.gz) = 1898657
+TIMESTAMP = 1601718887
+SHA256 (go-graphite-carbonapi-0.14.1_GH0.tar.gz) = 5f33a3aa8c9f8edfce8a26b358b6edf8c455f4156cf25e2a2399712d67282379
+SIZE (go-graphite-carbonapi-0.14.1_GH0.tar.gz) = 3485133
diff --git a/www/carbonapi/files/patch-carbonapi.example.toml b/www/carbonapi/files/patch-cmd_carbonapi_carbonapi.example.toml
index ab3b9eda510e..50639baac89e 100644
--- a/www/carbonapi/files/patch-carbonapi.example.toml
+++ b/www/carbonapi/files/patch-cmd_carbonapi_carbonapi.example.toml
@@ -1,15 +1,15 @@
---- carbonapi.example.toml.orig 2018-03-20 21:03:28 UTC
-+++ carbonapi.example.toml
-@@ -11,7 +11,7 @@ maxBatchSize = 100
+--- cmd/carbonapi/carbonapi.example.toml.orig 2020-08-19 11:50:06 UTC
++++ cmd/carbonapi/carbonapi.example.toml
+@@ -9,7 +9,7 @@ idleConnections = 10
+ listen = "localhost:8081"
pidFile = ""
- sendGlobsAsIs = false
tz = ""
-graphTemplates = "graphTemplates.example.toml"
+graphTemplates = "/usr/local/etc/carbonapi/graphTemplates.example.toml"
[cache]
defaultTimeoutSec = 60
-@@ -35,7 +35,7 @@ logger = ""
+@@ -36,7 +36,7 @@ logger = ""
[[logger]]
encoding = "json"
@@ -17,3 +17,4 @@
+file = "/var/log/carbonapi/carbonapi.log"
level = "info"
logger = ""
+
diff --git a/www/carbonapi/files/patch-carbonapi.example.yaml b/www/carbonapi/files/patch-cmd_carbonapi_carbonapi.example.yaml
index 5319261d3958..df3bec3df6d6 100644
--- a/www/carbonapi/files/patch-carbonapi.example.yaml
+++ b/www/carbonapi/files/patch-cmd_carbonapi_carbonapi.example.yaml
@@ -1,6 +1,6 @@
---- carbonapi.example.yaml.orig 2018-03-20 21:04:44 UTC
-+++ carbonapi.example.yaml
-@@ -106,7 +106,7 @@ upstreams:
+--- cmd/carbonapi/carbonapi.example.yaml.orig 2020-08-19 11:50:06 UTC
++++ cmd/carbonapi/carbonapi.example.yaml
+@@ -222,7 +222,7 @@ upstreams:
# If not zero, enabled cache for find requests
# This parameter controls when it will expire (in seconds)
# Default: 600 (10 minutes)
@@ -9,7 +9,7 @@
expireDelaySec: 10
# Uncomment this to get the behavior of graphite-web as proposed in https://github.com/graphite-project/graphite-web/pull/2239
# Beware this will make darkbackground graphs less readable
-@@ -125,6 +125,6 @@ logger:
+@@ -241,6 +241,6 @@ logger:
encodingTime: "iso8601"
encodingDuration: "seconds"
- logger: ""
diff --git a/www/carbonapi/pkg-plist b/www/carbonapi/pkg-plist
index c7a813ca1c01..c92507ea39cd 100644
--- a/www/carbonapi/pkg-plist
+++ b/www/carbonapi/pkg-plist
@@ -1,7 +1,11 @@
bin/carbonapi
-%%ETCDIR%%/carbonapi.example.toml
-%%ETCDIR%%/carbonapi.example.yaml
-%%ETCDIR%%/graphTemplates.example.toml
-%%ETCDIR%%/graphTemplates.example.yaml
-%%ETCDIR%%/graphiteWeb.example.yaml
+bin/carbonzipper
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/carbonapi.example.clickhouse.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/carbonapi.example.prometheus.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/carbonapi.example.toml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/carbonapi.example.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphTemplates.example.toml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphTemplates.example.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphiteWeb.example.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/carbonzipper.example.conf
@dir(carbon,carbon,0750) /var/log/carbonapi