aboutsummaryrefslogtreecommitdiff
path: root/www/cgiwrap
diff options
context:
space:
mode:
authorJeremy Chadwick <koitsu@FreeBSD.org>2007-08-27 14:47:11 +0000
committerJeremy Chadwick <koitsu@FreeBSD.org>2007-08-27 14:47:11 +0000
commit93e3d458ea02ae2c145159e5767968d5bc59b522 (patch)
tree247509028e3d13b5f2cea89a2afa37e918818cd6 /www/cgiwrap
parent760a81c78b5c067159cfe10d6aa081a176c883b9 (diff)
downloadports-93e3d458ea02ae2c145159e5767968d5bc59b522.tar.gz
ports-93e3d458ea02ae2c145159e5767968d5bc59b522.zip
Add WITH_USE_SCRIPT_URL and WITH_USE_REDIRECT_URL knobs, allowing for
the SCRIPT_NAME environment variable to be built based on $SCRIPT_URL or $REDIRECT_URL.
Notes
Notes: svn path=/head/; revision=198387
Diffstat (limited to 'www/cgiwrap')
-rw-r--r--www/cgiwrap/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/cgiwrap/Makefile b/www/cgiwrap/Makefile
index 951a53a14e03..695633f76dd5 100644
--- a/www/cgiwrap/Makefile
+++ b/www/cgiwrap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cgiwrap
PORTVERSION= 4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -24,6 +24,8 @@ OPTIONS= CGI_OWNER "Check CGI file owner" on \
CGI_SETGID "Check CGI file setgid permissions" on \
CGI_GROUP_WRITABLE "Check CGI g+w file permissions" on \
CGI_WORLD_WRITABLE "Check CGI o+w file permissions" on \
+ USE_SCRIPT_URL "Use REDIRECT_URL to build SCRIPT_NAME" off \
+ USE_SCRIPT_URL "Use SCRIPT_URL to build SCRIPT_NAME" off \
NPH "Enable nph binaries" off \
DEBUG "Enable cgiwrapd binaries" off
@@ -96,6 +98,12 @@ CONFIGURE_ARGS+= --without-check-group-writable
.if !defined(WITH_CGI_WORLD_WRITABLE)
CONFIGURE_ARGS+= --without-check-world-writable
.endif
+.if defined(WITH_USE_REDIRECT_URL)
+CONFIGURE_ARGS+= --with-use-redirect-url
+.endif
+.if defined(WITH_USE_SCRIPT_URL)
+CONFIGURE_ARGS+= --with-use-script-url
+.endif
.if !defined(WITH_NPH)
PLIST_SUB+= NPHFLAG="@comment "