aboutsummaryrefslogtreecommitdiff
path: root/www/cgiwrap
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-05 17:09:34 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-05 17:09:34 +0000
commitcc7354fd705f56390fdbb17cf89ee5a1fea3a5b5 (patch)
treed4e148970a8217677820af95eb39b1c631981dd1 /www/cgiwrap
parente75ce28db701a75ad6d14e9c7452772cf6e3c0c5 (diff)
downloadports-cc7354fd705f56390fdbb17cf89ee5a1fea3a5b5.tar.gz
ports-cc7354fd705f56390fdbb17cf89ee5a1fea3a5b5.zip
Move LOG_FILE code to after bsd.port.pre.mk
PR: ports/85687 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=142010
Diffstat (limited to 'www/cgiwrap')
-rw-r--r--www/cgiwrap/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/www/cgiwrap/Makefile b/www/cgiwrap/Makefile
index c38799fd4ff9..ae3fb05b8e38 100644
--- a/www/cgiwrap/Makefile
+++ b/www/cgiwrap/Makefile
@@ -55,18 +55,6 @@ USER_CGIDIR?= public_html/cgi-bin
ALLOW_FILE?= ${PREFIX}/etc/${PORTNAME}.allow
DENY_FILE?= ${PREFIX}/etc/${PORTNAME}.deny
-##
-# LOG_FILE
-#
-# Enables cgiwrap logging (when a user called cgiwrap, its arguments,
-# and who ran it). Specify the full path to the logfile.
-#
-.if defined(LOG_FILE)
-CONFIGURE_ARGS+= --with-logging-file=${LOG_FILE}
-.else
-CONFIGURE_ARGS+= --without-logging-file
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-httpd-user=${WWWOWN} \
--with-install-group=${WWWGRP} \
@@ -78,6 +66,17 @@ CONFIGURE_ARGS= --with-httpd-user=${WWWOWN} \
.include <bsd.port.pre.mk>
+##
+# LOG_FILE
+#
+# Enables cgiwrap logging (when a user called cgiwrap, its arguments,
+# and who ran it). Specify the full path to the logfile.
+#
+.if defined(LOG_FILE)
+CONFIGURE_ARGS+= --with-logging-file=${LOG_FILE}
+.else
+CONFIGURE_ARGS+= --without-logging-file
+.endif
.if !defined(WITH_CGI_OWNER)
CONFIGURE_ARGS+= --without-check-owner
.endif