aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-15 01:16:48 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-15 01:16:48 +0000
commitadf5ba865e3c4636f0a4ded3ec6d10f25d6adcea (patch)
treea1ff7ccdacf83e4112ee1c77adccc228cd8330c3 /www/cherokee
parent257fda23175718d20fa8618bf0016d115a8baba3 (diff)
downloadports-adf5ba865e3c4636f0a4ded3ec6d10f25d6adcea.tar.gz
ports-adf5ba865e3c4636f0a4ded3ec6d10f25d6adcea.zip
Notes
Diffstat (limited to 'www/cherokee')
-rw-r--r--www/cherokee/Makefile33
-rw-r--r--www/cherokee/pkg-message23
2 files changed, 44 insertions, 12 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 9737cf2cebf5..39de938488fe 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -55,7 +55,8 @@ MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee-admin.1 \
cherokee-tweak.1 cherokee-worker.1
PORTDOCS= *
-OPTIONS= IPV6 "IPv6 support" on \
+OPTIONS= WWWUSER "Run as www:www user" on \
+ IPV6 "IPv6 support" on \
MYSQL "MySQL Database" off \
LDAP "LDAP Support" off \
GEOIP "GeoIP Support (recommended)" on \
@@ -76,34 +77,38 @@ PLIST_SUB+= ADMIN="@comment "
.include <bsd.port.pre.mk>
+.ifdef WITH_WWWUSER
+CONFIGURE_ARGS+= --with-wwwuser=www --with-wwwgroup=www
+.endif
+
.ifdef WITHOUT_IPV6
-CONFIGURE_ARGS+=--disable-ipv6
+CONFIGURE_ARGS+= --disable-ipv6
.endif
.ifdef WITH_MYSQL
USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql=yes
+CONFIGURE_ARGS+= --with-mysql=yes
PLIST_SUB+= MYSQL=""
.else
-CONFIGURE_ARGS+=--with-mysql=no
+CONFIGURE_ARGS+= --with-mysql=no
PLIST_SUB+= MYSQL="@comment "
.endif
.ifdef WITH_LDAP
USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-ldap=yes
+CONFIGURE_ARGS+= --with-ldap=yes
PLIST_SUB+= LDAP=""
.else
-CONFIGURE_ARGS+=--with-ldap=no
+CONFIGURE_ARGS+= --with-ldap=no
PLIST_SUB+= LDAP="@comment "
.endif
.ifdef WITH_GEOIP
LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
-CONFIGURE_ARGS+=--with-geoip=yes
+CONFIGURE_ARGS+= --with-geoip=yes
PLIST_SUB+= GEOIP=""
.else
-CONFIGURE_ARGS+=--with-geoip=no
+CONFIGURE_ARGS+= --with-geoip=no
PLIST_SUB+= GEOIP="@comment "
.endif
@@ -111,20 +116,20 @@ PLIST_SUB+= GEOIP="@comment "
LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg \
avcodec:${PORTSDIR}/multimedia/ffmpeg \
avutil:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+=--with-ffmpeg=yes
+CONFIGURE_ARGS+= --with-ffmpeg=yes
.else
-CONFIGURE_ARGS+=--with-ffmpeg=no
+CONFIGURE_ARGS+= --with-ffmpeg=no
.endif
.ifdef WITH_NLS
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
+CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
.ifdef WITH_INTPCRE
-CONFIGURE_ARGS+=--enable-internal-pcre
+CONFIGURE_ARGS+= --enable-internal-pcre
.else
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
.endif
@@ -191,4 +196,8 @@ post-install:
${XARGS} ${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py
.endif
+ @${ECHO_MSG} "==============================================================="
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} "==============================================================="
+
.include <bsd.port.post.mk>
diff --git a/www/cherokee/pkg-message b/www/cherokee/pkg-message
new file mode 100644
index 000000000000..44d08378a798
--- /dev/null
+++ b/www/cherokee/pkg-message
@@ -0,0 +1,23 @@
+Please note that if you intend to run Cherokee as www user,
+you'll have to manually create the log files and set the
+proper ownership and permissions on them.
+
+You can do it with (as root):
+
+ touch /var/log/cherokee.error /var/log/cherokee.access
+ chown -v www:www /var/log/cherokee.*
+ chmod -v 0640 /var/log/cherokee.*
+
+If you run Cherokee as root (NOT recommended) this is not
+necessary.
+
+To run Cherokee at startup or using the rc script, add
+'cherokee_enable="YES"' to /etc/rc.conf
+
+To start the Cherokee administrative interface, run (as root)
+
+ cherokee-admin
+
+For more information on cherokee-admin(1), please refer to
+the official documentation and manpage.
+