aboutsummaryrefslogtreecommitdiff
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-10-11 15:33:47 +0000
committerRene Ladan <rene@FreeBSD.org>2013-10-11 15:33:47 +0000
commitbc997e68ac05cb9a7272172ee92bcb43878b37ee (patch)
treec85b32d5fa5b0d29e52ce267ed778e7c2cb83d8e /www/chromium/Makefile
parentf3a2625ef09b1065d7aeb2e94937b8031c29d542 (diff)
downloadports-bc997e68ac05cb9a7272172ee92bcb43878b37ee.tar.gz
ports-bc997e68ac05cb9a7272172ee92bcb43878b37ee.zip
Notes
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 04d26ea2cd62..7a674bc32f38 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -47,12 +47,13 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/a
ONLY_FOR_ARCHS= i386 amd64
USE_XZ= yes
-USES= bison desktop-file-utils pkgconfig perl5
+USES= bison desktop-file-utils pkgconfig perl5 shebangfix
USE_PERL5= build
USE_PYTHON_BUILD= 2.6-2.7
USE_XORG= scrnsaverproto x11 xproto xscrnsaver xtst
USE_GNOME= glib20 gtk20 dconf libxslt
+SHEBANG_FILES= chrome/tools/build/linux/chrome-wrapper
NINJA_TARGETS= chrome
# See build/common.gypi for all the available variables.
@@ -140,9 +141,10 @@ CXX= clang++
.endif
GYP_DEFINES+= clang=1
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang
-#.if ${OSVERSION} >= 1000054
-#EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libc++
-#.endif
+.endif
+
+.if ${OSVERSION} >= 1000052
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fixup-execinfo
.endif
.if ${PORT_OPTIONS:MTEST}