aboutsummaryrefslogtreecommitdiff
path: root/www/chromium
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2020-11-14 15:08:00 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2020-11-14 15:08:00 +0000
commit3c7c4cb53c9475851571a6738e154b1d8ceae878 (patch)
treead31c1a18024d5830a089d4351e852ce7c1257f2 /www/chromium
parent0f4109f1b1c916ac44ce3c38cac1e0be03e05d19 (diff)
downloadports-3c7c4cb53c9475851571a6738e154b1d8ceae878.tar.gz
ports-3c7c4cb53c9475851571a6738e154b1d8ceae878.zip
www/chromium: Make online detection always positive
Summary: navigator.onLine is currently broken in www/chromium. This change introduce a workaround that always return positive for online detection. Sponsored by: The FreeBSD Foundation Submitted by: Ka Ho Ng <khng300@gmail.com> Differential Revision: https://reviews.freebsd.org/D26490
Notes
Notes: svn path=/head/; revision=555115
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/files/patch-net_base_network__change__notifier.cc18
2 files changed, 8 insertions, 12 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 0b32ce197dc1..b912e104e4c9 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= chromium
PORTVERSION= 85.0.4183.121
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www java
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/rene/chromium/:fonts
diff --git a/www/chromium/files/patch-net_base_network__change__notifier.cc b/www/chromium/files/patch-net_base_network__change__notifier.cc
index b570610a6483..b037e73a1fb9 100644
--- a/www/chromium/files/patch-net_base_network__change__notifier.cc
+++ b/www/chromium/files/patch-net_base_network__change__notifier.cc
@@ -1,4 +1,4 @@
---- net/base/network_change_notifier.cc.orig 2020-02-03 21:52:49 UTC
+--- net/base/network_change_notifier.cc.orig 2020-08-10 18:39:31 UTC
+++ net/base/network_change_notifier.cc
@@ -35,7 +35,7 @@
#include "net/base/network_change_notifier_linux.h"
@@ -9,18 +9,14 @@
#include "net/base/network_change_notifier_posix.h"
#elif defined(OS_FUCHSIA)
#include "net/base/network_change_notifier_fuchsia.h"
-@@ -229,7 +229,7 @@ std::unique_ptr<NetworkChangeNotifier> NetworkChangeNo
- // service in a separate process.
- return std::make_unique<NetworkChangeNotifierPosix>(initial_type,
- initial_subtype);
--#elif defined(OS_CHROMEOS)
-+#elif defined(OS_CHROMEOS) || defined(OS_BSD)
- return std::make_unique<NetworkChangeNotifierPosix>(initial_type,
- initial_subtype);
- #elif defined(OS_LINUX)
-@@ -241,7 +241,6 @@ std::unique_ptr<NetworkChangeNotifier> NetworkChangeNo
+@@ -240,8 +240,11 @@ std::unique_ptr<NetworkChangeNotifier> NetworkChangeNo
+ #elif defined(OS_FUCHSIA)
return std::make_unique<NetworkChangeNotifierFuchsia>(
0 /* required_features */);
++#elif defined(OS_BSD)
++ return std::make_unique<MockNetworkChangeNotifier>(
++ std::make_unique<SystemDnsConfigChangeNotifier>(
++ nullptr /* task_runner */, nullptr /* dns_config_service */));
#else
- NOTIMPLEMENTED();
return NULL;