aboutsummaryrefslogtreecommitdiff
path: root/www/chromium
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-08-01 20:41:11 +0000
committerRene Ladan <rene@FreeBSD.org>2020-08-01 20:41:11 +0000
commit7358d11020d2fd314746d5b8e7ca8e9a442276c5 (patch)
treead6f6357a529d9a03cd2b9ad48deff2fd7664747 /www/chromium
parentc574b013b3f758e35a0c806b23b27215c28c6745 (diff)
downloadports-7358d11020d2fd314746d5b8e7ca8e9a442276c5.tar.gz
ports-7358d11020d2fd314746d5b8e7ca8e9a442276c5.zip
www/chromium: fix build when using Python 3.{x!=7} as default
Submitted by: kib (private mail) MFH: 2020Q3
Notes
Notes: svn path=/head/; revision=543922
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 0cf732ded20c..36d67da93f47 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -256,12 +256,12 @@ pre-configure:
./build/linux/unbundle/replace_gn_files.py --system-libraries \
ffmpeg flac fontconfig freetype harfbuzz-ng libdrm libpng libwebp libxml libxslt openh264 opus snappy || ${FALSE}
- # We need the site package from xcbgen, which installs as python3.7 (really: default version), while the chromium
+ # We need the site package from xcbgen, which installs as python3.x (really: default version), while the chromium
# build still needs to use python2.7. It works, because xcbgen can run with both versions, but we want to avoid
- # having the pre-compiled pyc files from 2.7 in the 3.7 site packages
+ # having the pre-compiled pyc files from 2.7 in the 3.x site packages
# Remove this as soon as chromium uses python3.x as well
@${MKDIR} ${WRKDIR}/site-packages/xcbgen
- ${CP} ${PYTHONBASE}/lib/python3.7/site-packages/xcbgen/*.py \
+ ${CP} ${PYTHONBASE}/lib/python${PYTHON_DEFAULT}/site-packages/xcbgen/*.py \
${WRKDIR}/site-packages/xcbgen
.endif