aboutsummaryrefslogtreecommitdiff
path: root/www/cl-lml-sbcl
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:39:32 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:39:32 +0000
commitb1ab63dfffb5b1fc873332d0cee76a60db41ebb3 (patch)
treec6ed444138720291fe20f027125b406c780290b4 /www/cl-lml-sbcl
parentd3e1a105e8e66d9797459b8f8f0402e1a27f2dbc (diff)
downloadports-b1ab63dfffb5b1fc873332d0cee76a60db41ebb3.tar.gz
ports-b1ab63dfffb5b1fc873332d0cee76a60db41ebb3.zip
Notes
Diffstat (limited to 'www/cl-lml-sbcl')
-rw-r--r--www/cl-lml-sbcl/Makefile37
-rw-r--r--www/cl-lml-sbcl/pkg-descr6
-rw-r--r--www/cl-lml-sbcl/pkg-plist8
3 files changed, 51 insertions, 0 deletions
diff --git a/www/cl-lml-sbcl/Makefile b/www/cl-lml-sbcl/Makefile
new file mode 100644
index 000000000000..d841e918b397
--- /dev/null
+++ b/www/cl-lml-sbcl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection Makefile for: cl-lml-sbcl
+# Date created: 18 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= lml
+PORTVERSION= 2.3.4
+CATEGORIES= www textproc
+MASTER_SITES= http://files.b9.com/lml/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= Lisp Markup Language
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/system-registry/lml.asd:${PORTSDIR}/www/cl-lml \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/system-registry/lml.asd:${PORTSDIR}/www/cl-lml \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ sbcl --noinform --userinit /dev/null \
+ --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
+ --eval "(asdf:oos 'asdf:compile-op :lml)" \
+ --eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/lml/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/lml/sbclfasl/
+
+.include <bsd.port.mk>
diff --git a/www/cl-lml-sbcl/pkg-descr b/www/cl-lml-sbcl/pkg-descr
new file mode 100644
index 000000000000..576ffc570084
--- /dev/null
+++ b/www/cl-lml-sbcl/pkg-descr
@@ -0,0 +1,6 @@
+A Common Lisp package for generating HTML and XHTML documents.
+
+WWW: http://lml.b9.com/
+
+-- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/www/cl-lml-sbcl/pkg-plist b/www/cl-lml-sbcl/pkg-plist
new file mode 100644
index 000000000000..8ee20cde5cf2
--- /dev/null
+++ b/www/cl-lml-sbcl/pkg-plist
@@ -0,0 +1,8 @@
+lib/common-lisp/lml/sbclfasl/base.fasl
+lib/common-lisp/lml/sbclfasl/downloads.fasl
+lib/common-lisp/lml/sbclfasl/files.fasl
+lib/common-lisp/lml/sbclfasl/package.fasl
+lib/common-lisp/lml/sbclfasl/stdsite.fasl
+lib/common-lisp/lml/sbclfasl/utils.fasl
+lib/common-lisp/lml/sbclfasl/read-macro.fasl
+@dirrm lib/common-lisp/lml/sbclfasl