aboutsummaryrefslogtreecommitdiff
path: root/www/clearsilver
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-20 12:43:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-20 12:43:35 +0000
commit145ac14fbc85bc3f6acf2e21d5b2ddf866d7f87e (patch)
treee907becee337df2c53e567580d74153c0a22f6c7 /www/clearsilver
parent772054ce1260d8648924a2fe6b9181b61f92c49a (diff)
downloadports-145ac14fbc85bc3f6acf2e21d5b2ddf866d7f87e.tar.gz
ports-145ac14fbc85bc3f6acf2e21d5b2ddf866d7f87e.zip
Add clearsilver, a fast, powerful, and language-neutral HTML template system.
In both static content sites and dynamic HTML applications, it provides a separation between presentation code and application logic which makes working with your project easier. Add clearsilver-python, a slave port that enabled python extension in clearsilver. WWW: http://www.clearsilver.net/ PR: ports/65652, ports/65653 Submitted by: thinker <thinker@branda.to> (original submission) Rui Lopes (fixes)
Notes
Notes: svn path=/head/; revision=107708
Diffstat (limited to 'www/clearsilver')
-rw-r--r--www/clearsilver/Makefile72
-rw-r--r--www/clearsilver/distinfo2
-rw-r--r--www/clearsilver/pkg-descr15
-rw-r--r--www/clearsilver/pkg-plist34
4 files changed, 123 insertions, 0 deletions
diff --git a/www/clearsilver/Makefile b/www/clearsilver/Makefile
new file mode 100644
index 000000000000..08c72f30bd24
--- /dev/null
+++ b/www/clearsilver/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: ClearSilver
+# Date created: 17 April 2004
+# Whom: thinker <thinker@branda.to>
+# Whom: Rui Lopes <rui@ruilopes.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clearsilver
+PORTVERSION= 0.9.7
+CATEGORIES= www
+MASTER_SITES= http://www.clearsilver.net/downloads/
+
+MAINTAINER= thinker@branda.to
+COMMENT= A fast, powerful, and language-neutral template system
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+MANCOMPRESSED= no
+
+CONFIGURE_ARGS= --disable-apache --disable-perl --disable-ruby \
+ --disable-java --disable-csharp
+
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+= --with-python=${PYTHON_CMD}
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
+PKGNAMESUFFIX= -python
+.else
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+MAN3= cBroadcast.3 cCreate.3 cDestroy.3 cSignal.3 cWait.3 \
+ cgi_cookie_authority.3 cgi_cookie_clear.3 cgi_cookie_set.3 \
+ cgi_cs_init.3 cgi_debug_init.3 cgi_destroy.3 cgi_display.3 cgi_error.3 \
+ cgi_filehandle.3 cgi_init.3 cgi_neo_error.3 cgi_output.3 cgi_parse.3 \
+ cgi_redirect.3 cgi_redirect_uri.3 cgi_register_parse_cb.3 \
+ cgi_url_escape.3 cgi_url_escape_more.3 cgi_url_unescape.3 \
+ cgi_vredirect.3 cgiwrap_getenv.3 cgiwrap_init_emu.3 cgiwrap_init_std.3 \
+ cgiwrap_iterenv.3 cgiwrap_putenv.3 cgiwrap_read.3 cgiwrap_write.3 \
+ cgiwrap_writef.3 cgiwrap_writevf.3 cs_destroy.3 cs_dump.3 cs_init.3 \
+ cs_parse_file.3 cs_parse_string.3 cs_register_strfunc.3 cs_render.3 \
+ dictCleanup.3 dictCreate.3 dictDestroy.3 dictModifyValue.3 dictNext.3 \
+ dictReleaseLock.3 dictRemove.3 dictSearch.3 dictSetValue.3 fCreate.3 \
+ fDestroy.3 fFind.3 fLock.3 fUnlock.3 filter_create_fd.3 \
+ filter_create_fp.3 filter_wait.3 hdf_copy.3 hdf_destroy.3 hdf_dump.3 \
+ hdf_dump_format.3 hdf_dump_str.3 hdf_get_attr.3 hdf_get_child.3 \
+ hdf_get_copy.3 hdf_get_int_value.3 hdf_get_node.3 hdf_get_obj.3 \
+ hdf_get_value.3 hdf_get_valuef.3 hdf_get_valuevf.3 hdf_init.3 \
+ hdf_obj_attr.3 hdf_obj_child.3 hdf_obj_name.3 hdf_obj_next.3 \
+ hdf_obj_top.3 hdf_obj_value.3 hdf_read_string.3 \
+ hdf_read_string_ignore.3 hdf_remove_tree.3 hdf_search_path.3 \
+ hdf_set_attr.3 hdf_set_buf.3 hdf_set_copy.3 hdf_set_int_value.3 \
+ hdf_set_symlink.3 hdf_set_value.3 hdf_set_valuef.3 hdf_sort_obj.3 \
+ hdf_write_file.3 hdf_write_file_atomic.3 hdf_write_string.3 mCreate.3 \
+ mDestroy.3 mLock.3 mUnlock.3 nerr_ignore.3 nerr_log_error.3 \
+ nerr_pass.3 nerr_pass_ctx.3 nerr_raise.3 skipDelete.3 skipFreeList.3 \
+ skipInsert.3 skipNewList.3 skipNext.3 skipRelease.3 skipSearch.3 \
+ wdb_keys.3
+
+post-patch:
+ @# Exclude lemon.c, it gives some errors and its not used at all.
+ @${MV} ${WRKSRC}/cs/lemon.c ${WRKSRC}/cs/lemon.c.not_used
+ @# Remove CFLAGS when building the python module, pydistfile is used
+ @# and will do the right thing.
+ @${REINPLACE_CMD} -E 's,(\$$\(PYTHON\)),CFLAGS="" \1,g' ${WRKSRC}/python/Makefile
+ @# Avoid rebuiling man pages
+ @${REINPLACE_CMD} -e 's,all man,all,g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/www/clearsilver/distinfo b/www/clearsilver/distinfo
new file mode 100644
index 000000000000..d776cd24dbe7
--- /dev/null
+++ b/www/clearsilver/distinfo
@@ -0,0 +1,2 @@
+MD5 (clearsilver-0.9.7.tar.gz) = a83844356c92b0ce060c5ba08e55c401
+SIZE (clearsilver-0.9.7.tar.gz) = 377694
diff --git a/www/clearsilver/pkg-descr b/www/clearsilver/pkg-descr
new file mode 100644
index 000000000000..4edc383f8343
--- /dev/null
+++ b/www/clearsilver/pkg-descr
@@ -0,0 +1,15 @@
+ClearSilver is a fast, powerful, and language-neutral template system. It is
+designed to make it easy to create template driven static or dynamic
+websites.
+
+ClearSilver is first and foremost designed to be extremely fast. It is coded
+completely in C and exported to your script language of choice (i.e. Python,
+Perl). As a result, it is notably faster than template systems written in a
+script language. However, its design has additional benefits. It is also one
+of the only template systems available which allows you to easily
+mix-and-match multiple programming languages with the same templates, even
+on the same page. This allows you to optimize your website by writing
+C-modules to handle speed-sensitive sections, while leaving the majority of
+your site in easy to write script code.
+
+WWW: http://www.clearsilver.net/
diff --git a/www/clearsilver/pkg-plist b/www/clearsilver/pkg-plist
new file mode 100644
index 000000000000..88e2ac7dbb6d
--- /dev/null
+++ b/www/clearsilver/pkg-plist
@@ -0,0 +1,34 @@
+bin/cstest
+bin/static.cgi
+include/ClearSilver/ClearSilver.h
+include/ClearSilver/cgi/cgi.h
+include/ClearSilver/cgi/cgiwrap.h
+include/ClearSilver/cgi/date.h
+include/ClearSilver/cgi/html.h
+include/ClearSilver/cs/cs.h
+include/ClearSilver/cs_config.h
+include/ClearSilver/util/dict.h
+include/ClearSilver/util/filter.h
+include/ClearSilver/util/neo_date.h
+include/ClearSilver/util/neo_err.h
+include/ClearSilver/util/neo_files.h
+include/ClearSilver/util/neo_hash.h
+include/ClearSilver/util/neo_hdf.h
+include/ClearSilver/util/neo_misc.h
+include/ClearSilver/util/neo_net.h
+include/ClearSilver/util/neo_rand.h
+include/ClearSilver/util/neo_server.h
+include/ClearSilver/util/neo_str.h
+include/ClearSilver/util/rcfs.h
+include/ClearSilver/util/skiplist.h
+include/ClearSilver/util/ulist.h
+include/ClearSilver/util/ulocks.h
+include/ClearSilver/util/wildmat.h
+lib/libneo_cgi.a
+lib/libneo_cs.a
+lib/libneo_utl.a
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/neo_cgi.so
+@dirrm include/ClearSilver/util
+@dirrm include/ClearSilver/cs
+@dirrm include/ClearSilver/cgi
+@dirrm include/ClearSilver