aboutsummaryrefslogtreecommitdiff
path: root/www/clearsilver
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-21 02:16:16 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-21 02:16:16 +0000
commita5363d092568ccc76af1737338bcb86ab2977ee6 (patch)
treef0e80cc32e5992802a8b9cba846f00d67fda500e /www/clearsilver
parent8737103be0d1508b855a5846bd95ee153ce3d976 (diff)
- unbreak on 4.x
- www/clearsilver was marked BROKEN on FreeBSD 4.X because of a missing pthread library. However, pthread.h exists on 4.X, and that causes the configure script to get confused. Clearsilver can be built successfully on 4.X as long as the proper HAVE_PTHREAD value is set. PR: ports/106744 Submitted by: Greg Larkin <glarkin_AT_sourcehosting dot net>
Notes
Notes: svn path=/head/; revision=180306
Diffstat (limited to 'www/clearsilver')
-rw-r--r--www/clearsilver/Makefile7
-rw-r--r--www/clearsilver/files/patch-configure17
-rw-r--r--www/clearsilver/pkg-plist4
3 files changed, 24 insertions, 4 deletions
diff --git a/www/clearsilver/Makefile b/www/clearsilver/Makefile
index dd5ab0a7991e..9e3f41fe131a 100644
--- a/www/clearsilver/Makefile
+++ b/www/clearsilver/Makefile
@@ -62,8 +62,11 @@ MAN3= cBroadcast.3 cCreate.3 cDestroy.3 cSignal.3 cWait.3 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
+.if ${OSVERSION} >= 500000
+PATCHDIR= dont-patch
+PLIST_SUB+= PTHREAD=""
+.else
+PLIST_SUB+= PTHREAD="@comment "
.endif
post-patch:
diff --git a/www/clearsilver/files/patch-configure b/www/clearsilver/files/patch-configure
new file mode 100644
index 000000000000..bec430194cb3
--- /dev/null
+++ b/www/clearsilver/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig Thu Dec 14 19:15:07 2006
++++ configure Thu Dec 14 19:16:25 2006
+@@ -4969,14 +4969,6 @@
+ fi
+
+
+- if test $cs_cv_pthread = yes; then
+- cat >>confdefs.h <<\_ACEOF
+-#define HAVE_PTHREADS 1
+-_ACEOF
+-
+- EXTRA_UTL_SRC="$EXTRA_UTL_SRC skiplist.c dict.c"
+- fi
+-
+ fi
+
+
diff --git a/www/clearsilver/pkg-plist b/www/clearsilver/pkg-plist
index 88e2ac7dbb6d..42576f1bf31b 100644
--- a/www/clearsilver/pkg-plist
+++ b/www/clearsilver/pkg-plist
@@ -7,7 +7,7 @@ include/ClearSilver/cgi/date.h
include/ClearSilver/cgi/html.h
include/ClearSilver/cs/cs.h
include/ClearSilver/cs_config.h
-include/ClearSilver/util/dict.h
+%%PTHREAD%%include/ClearSilver/util/dict.h
include/ClearSilver/util/filter.h
include/ClearSilver/util/neo_date.h
include/ClearSilver/util/neo_err.h
@@ -20,7 +20,7 @@ include/ClearSilver/util/neo_rand.h
include/ClearSilver/util/neo_server.h
include/ClearSilver/util/neo_str.h
include/ClearSilver/util/rcfs.h
-include/ClearSilver/util/skiplist.h
+%%PTHREAD%%include/ClearSilver/util/skiplist.h
include/ClearSilver/util/ulist.h
include/ClearSilver/util/ulocks.h
include/ClearSilver/util/wildmat.h