aboutsummaryrefslogtreecommitdiff
path: root/www/codeigniter17
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-03 19:51:37 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-03 19:51:37 +0000
commitc8e608dcc63bdeb8db87475b2ba176fa7654e54d (patch)
treefbca5df903cd9590e66b805add0a74b0e78aa18d /www/codeigniter17
parent4b24c3fdb52f10be9ca00a39f5875a0336d772de (diff)
downloadports-c8e608dcc63bdeb8db87475b2ba176fa7654e54d.tar.gz
ports-c8e608dcc63bdeb8db87475b2ba176fa7654e54d.zip
Notes
Diffstat (limited to 'www/codeigniter17')
-rw-r--r--www/codeigniter17/Makefile9
-rw-r--r--www/codeigniter17/distinfo6
-rw-r--r--www/codeigniter17/pkg-plist26
3 files changed, 27 insertions, 14 deletions
diff --git a/www/codeigniter17/Makefile b/www/codeigniter17/Makefile
index 3c7da45fa684..c44434092201 100644
--- a/www/codeigniter17/Makefile
+++ b/www/codeigniter17/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= codeigniter
-PORTVERSION= 1.6.2
+PORTVERSION= 1.6.3
CATEGORIES= www
MASTER_SITES= http://codeigniter.com/download_files/
DISTNAME= CodeIgniter_${PORTVERSION}
@@ -172,6 +172,11 @@ post-install:
@for i in ${CI_CONF_FILES}; do \
if [ ! -f ${WWWDIR}/$$i ]; then \
${CP} -p ${WWWDIR}/$$i.sample ${WWWDIR}/$$i; \
+ else \
+ ${ECHO_MSG} "===> Customized ${WWWDIR}/$$i has not been overwritten"; \
+ if [ ! -z "$UPGRADE_TOOL" ]; then \
+ ${ECHO_MSG} "===> WARNING: You may have to manually merge changes to ${WWWDIR}/$$i.sample into ${WWWDIR}/$$i"; \
+ fi; \
fi; \
done
.if defined(WITH_APACHE)
@@ -189,7 +194,9 @@ post-install:
.if !defined(NOPORTDOCS)
@cd ${WRKSRC}/user_guide/ && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
+
@${CAT} ${PKGMESSAGE}
+
.if ${CGI_EXT} == "-cgi"
@${ECHO_MSG} ""
@${ECHO_MSG} "Your CodeIgniter installation was configured to use the PHP CGI binary."
diff --git a/www/codeigniter17/distinfo b/www/codeigniter17/distinfo
index 1af31479deed..8269db3ecac1 100644
--- a/www/codeigniter17/distinfo
+++ b/www/codeigniter17/distinfo
@@ -1,3 +1,3 @@
-MD5 (CodeIgniter_1.6.2.zip) = 0922830f96dfd40874b39ad018a49206
-SHA256 (CodeIgniter_1.6.2.zip) = ebe28a60400cae87172e45c013bb5f897547a28cbfa4d7afe148facced1d953e
-SIZE (CodeIgniter_1.6.2.zip) = 861202
+MD5 (CodeIgniter_1.6.3.zip) = 5ffab52b39b235ed6bd08ee5dd64d2f6
+SHA256 (CodeIgniter_1.6.3.zip) = 6bb61037e5a8fc51d27009eb89a85205247438a864eb8237f1c0791dd1d02791
+SIZE (CodeIgniter_1.6.3.zip) = 872665
diff --git a/www/codeigniter17/pkg-plist b/www/codeigniter17/pkg-plist
index 6231f881cc90..addeb8d1fb31 100644
--- a/www/codeigniter17/pkg-plist
+++ b/www/codeigniter17/pkg-plist
@@ -54,6 +54,8 @@
%%PORTDOCS%%%%DOCSDIR%%/helpers/form_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/html_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/inflector_helper.html
+%%PORTDOCS%%%%DOCSDIR%%/helpers/language_helper.html
+%%PORTDOCS%%%%DOCSDIR%%/helpers/number_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/path_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/security_helper.html
%%PORTDOCS%%%%DOCSDIR%%/helpers/smiley_helper.html
@@ -92,6 +94,7 @@
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_160.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_161.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_162.html
+%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_163.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_b11.html
%%PORTDOCS%%%%DOCSDIR%%/installation/upgrading.html
%%PORTDOCS%%%%DOCSDIR%%/libraries/benchmark.html
@@ -134,35 +137,35 @@
%%PORTDOCS%%%%DOCSDIR%%/userguide.css
@unexec if cmp -s %D/%%WWWDIR%%/index.php.sample %D/%%WWWDIR%%/index.php; then rm -f %D/%%WWWDIR%%/index.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/index.php has not been removed"; fi
%%WWWDIR%%/index.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/index.php ]; then cp -p %D/%F %B/index.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/index.php ]; then cp -p %D/%F %B/index.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/index.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php ]; then cp -p %D/%F %B/autoload.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php ]; then cp -p %D/%F %B/autoload.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/autoload.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/config.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php ]; then cp -p %D/%F %B/config.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php ]; then cp -p %D/%F %B/config.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/config.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php ]; then cp -p %D/%F %B/constants.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php ]; then cp -p %D/%F %B/constants.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/constants.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/database.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php ]; then cp -p %D/%F %B/database.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php ]; then cp -p %D/%F %B/database.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/database.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php ]; then cp -p %D/%F %B/hooks.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php ]; then cp -p %D/%F %B/hooks.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/hooks.php has not been overwritten"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/index.html
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php ]; then cp -p %D/%F %B/mimes.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php ]; then cp -p %D/%F %B/mimes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/mimes.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php ]; then cp -p %D/%F %B/routes.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php ]; then cp -p %D/%F %B/routes.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/routes.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php ]; then cp -p %D/%F %B/smileys.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php ]; then cp -p %D/%F %B/smileys.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/smileys.php has not been overwritten"; fi
@unexec if cmp -s %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php.sample %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php; then rm -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php has not been removed"; fi
%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php.sample
-@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php ]; then cp -p %D/%F %B/user_agents.php; fi
+@exec if [ ! -f %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php ]; then cp -p %D/%F %B/user_agents.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/%%CI_CONF_DIR%%/user_agents.php has not been overwritten"; fi
%%WWWDIR%%/system/application/controllers/index.html
%%WWWDIR%%/system/application/controllers/welcome.php
%%WWWDIR%%/system/application/errors/error_404.php
@@ -243,6 +246,8 @@
%%WWWDIR%%/system/helpers/html_helper.php
%%WWWDIR%%/system/helpers/index.html
%%WWWDIR%%/system/helpers/inflector_helper.php
+%%WWWDIR%%/system/helpers/language_helper.php
+%%WWWDIR%%/system/helpers/number_helper.php
%%WWWDIR%%/system/helpers/path_helper.php
%%WWWDIR%%/system/helpers/security_helper.php
%%WWWDIR%%/system/helpers/smiley_helper.php
@@ -258,6 +263,7 @@
%%WWWDIR%%/system/language/english/ftp_lang.php
%%WWWDIR%%/system/language/english/imglib_lang.php
%%WWWDIR%%/system/language/english/index.html
+%%WWWDIR%%/system/language/english/number_lang.php
%%WWWDIR%%/system/language/english/profiler_lang.php
%%WWWDIR%%/system/language/english/scaffolding_lang.php
%%WWWDIR%%/system/language/english/unit_test_lang.php