aboutsummaryrefslogtreecommitdiff
path: root/www/codeigniter
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-06-15 16:06:08 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-06-15 16:06:08 +0000
commitb79a0619063eadc3dd9e0462e50863b3df6812fb (patch)
tree83a1fb74c65d79f66451b77bc76c6305bd47e939 /www/codeigniter
parent4fa07c7f2cc3c3ba6d3267c5cd1c3a2f5d5ba057 (diff)
downloadports-b79a0619063eadc3dd9e0462e50863b3df6812fb.tar.gz
ports-b79a0619063eadc3dd9e0462e50863b3df6812fb.zip
- update to 2.1.1
- while here migrate to optionsNG PR: ports/169049 Submitted by: maintainer, appleboy.tw@gmail.com
Notes
Notes: svn path=/head/; revision=299356
Diffstat (limited to 'www/codeigniter')
-rw-r--r--www/codeigniter/Makefile42
-rw-r--r--www/codeigniter/distinfo4
-rw-r--r--www/codeigniter/pkg-plist6
3 files changed, 29 insertions, 23 deletions
diff --git a/www/codeigniter/Makefile b/www/codeigniter/Makefile
index 0b446682d891..affd99c36c2b 100644
--- a/www/codeigniter/Makefile
+++ b/www/codeigniter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= codeigniter
-PORTVERSION= 2.1.0
+PORTVERSION= 2.1.1
CATEGORIES= www
MASTER_SITES= http://downloads.codeigniter.com/reactor/ \
http://www.codeigniter.org.tw/download_files/
@@ -66,18 +66,20 @@ STD_BITS= ${CI_CONF_DIR}/index.html \
${CI_SYS_DIR}/language \
${CI_SYS_DIR}/libraries
-OPTIONS= APACHE "Configure for Apache-2.x" off \
- PROD "Install for production server (see: make confighelp)" Off \
- MSSQL "Install MSSQL support for PHP" Off \
- MYSQL "Install MySQL support for PHP" Off \
- MYSQLI "Install MySQLi support for PHP" Off \
- ODBC "Install ODBC support for PHP" Off \
- PGSQL "Install PostgreSQL support for PHP" Off \
- SQLITE "Install SQLite support for PHP" Off
+OPTIONS_DEFINE= APACHE PROD MSSQL MYSQL MYSQLI ODBC PGSQL SQLITE
+
+APACHE_DESC= Configure for Apache-2.x
+PROD_DESC= Install for production server (see: make confighelp)
+MSSQL_DESC= Install MSSQL support for PHP
+MYSQL_DESC= Install MySQL support for PHP
+MYSQLI_DESC= Install MySQLi support for PHP
+ODBC= Install ODBC support for PHP
+PGSQL_DESC= Install PostgreSQL support for PHP
+SQLITE_DESC= Install SQLite support for PHP
.include <bsd.port.pre.mk>
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE= 20+
PLIST_SUB+= NOAPACHE="" CONFDIR=${CONFDIR_REL}
@@ -105,37 +107,37 @@ DEFAULT_PHP_VER=5
SUB_LIST+= PHPCGI=${WITH_PHP_CGI}
-.if defined(WITH_PROD)
+.if ${PORT_OPTIONS:MPROD}
PROD= production
.else
PROD= development
.endif
-.if defined(WITH_MSSQL)
+.if ${PORT_OPTIONS:MMSSQL}
USE_PHP+= mssql
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
.endif
-.if defined(WITH_MYSQLI)
+.if ${PORT_OPTIONS:MMYSQLI}
USE_PHP+= mysqli
.endif
-.if defined(WITH_ODBC)
+.if ${PORT_OPTIONS:MODBC}
USE_PHP+= odbc
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
USE_PHP+= sqlite
.endif
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
SUB_LIST+= HASHMARK=\#
.else
SUB_LIST+= HASHMARK=
@@ -185,7 +187,7 @@ post-install:
fi; \
fi; \
done
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
@if [ -d "${CONFDIR}" ]; then \
${CP} ${WRKDIR}/${CONF} ${CONFDIR}/codeigniter.conf; \
else \
@@ -197,7 +199,7 @@ post-install:
${FALSE} ; \
fi
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC}/user_guide && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
diff --git a/www/codeigniter/distinfo b/www/codeigniter/distinfo
index 82d35bcfd06d..b94d5b69d37a 100644
--- a/www/codeigniter/distinfo
+++ b/www/codeigniter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CodeIgniter_2.1.0.zip) = 95b5d9afe2711bcc2a10aef8e1208cfc9fdc448bba0b0fbbf5e865141525b2ca
-SIZE (CodeIgniter_2.1.0.zip) = 2308804
+SHA256 (CodeIgniter_2.1.1.zip) = ae57494d7659837cc4aa33f7532d6c8373a984acc9c087f69fc96724f582a789
+SIZE (CodeIgniter_2.1.1.zip) = 2318153
diff --git a/www/codeigniter/pkg-plist b/www/codeigniter/pkg-plist
index 45e0ce3db126..3a585193737d 100644
--- a/www/codeigniter/pkg-plist
+++ b/www/codeigniter/pkg-plist
@@ -116,7 +116,11 @@
%%WWWDIR%%/system/database/drivers/odbc/odbc_forge.php
%%WWWDIR%%/system/database/drivers/odbc/odbc_result.php
%%WWWDIR%%/system/database/drivers/odbc/odbc_utility.php
+%%WWWDIR%%/system/database/drivers/pdo/index.html
%%WWWDIR%%/system/database/drivers/pdo/pdo_driver.php
+%%WWWDIR%%/system/database/drivers/pdo/pdo_forge.php
+%%WWWDIR%%/system/database/drivers/pdo/pdo_result.php
+%%WWWDIR%%/system/database/drivers/pdo/pdo_utility.php
%%WWWDIR%%/system/database/drivers/postgre/index.html
%%WWWDIR%%/system/database/drivers/postgre/postgre_driver.php
%%WWWDIR%%/system/database/drivers/postgre/postgre_forge.php
@@ -214,8 +218,8 @@
@dirrm %%WWWDIR%%/system/database/drivers/sqlsrv
@dirrm %%WWWDIR%%/system/database/drivers/sqlite
@dirrm %%WWWDIR%%/system/database/drivers/postgre
-@dirrm %%WWWDIR%%/system/database/drivers/pdo
@dirrm %%WWWDIR%%/system/database/drivers/odbc
+@dirrm %%WWWDIR%%/system/database/drivers/pdo
@dirrm %%WWWDIR%%/system/database/drivers/oci8
@dirrm %%WWWDIR%%/system/database/drivers/mysqli
@dirrm %%WWWDIR%%/system/database/drivers/mysql