aboutsummaryrefslogtreecommitdiff
path: root/www/codeigniter
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 12:46:40 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:36:44 +0000
commitf90874e91d76f947ed934b92c58ace6e7e86e0df (patch)
tree8c52da32279738504330acfd3680c28d80dcd067 /www/codeigniter
parentbe8f8827da3ac542bc3c1c9db40e63b66fff8b95 (diff)
Diffstat (limited to 'www/codeigniter')
-rw-r--r--www/codeigniter/Makefile18
-rw-r--r--www/codeigniter/distinfo6
-rw-r--r--www/codeigniter/files/codeigniter-development-cgi.conf.in6
-rw-r--r--www/codeigniter/files/codeigniter-development.conf.in6
-rw-r--r--www/codeigniter/files/codeigniter-production-cgi.conf.in6
-rw-r--r--www/codeigniter/files/codeigniter-production.conf.in6
-rw-r--r--www/codeigniter/files/codeigniter.conf.in6
-rw-r--r--www/codeigniter/pkg-plist217
8 files changed, 11 insertions, 260 deletions
diff --git a/www/codeigniter/Makefile b/www/codeigniter/Makefile
index 576ea9777179..dbc938dca248 100644
--- a/www/codeigniter/Makefile
+++ b/www/codeigniter/Makefile
@@ -1,7 +1,7 @@
# Created by: Greg Larkin <glarkin@FreeBSD.org>
PORTNAME= codeigniter
-PORTVERSION= 3.1.11
+PORTVERSION= 3.1.13
CATEGORIES= www
MAINTAINER= sunpoet@FreeBSD.org
@@ -17,12 +17,11 @@ USE_GITHUB= yes
GH_ACCOUNT= bcit-ci
GH_PROJECT= CodeIgniter
-CONFLICTS= codeigniter-1.[0-9]* codeigniter22-2.[0-9]*
-
NO_ARCH= yes
NO_BUILD= yes
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+SUB_FILES= pkg-message
# These are all user-configurable files that we'll install
CI_CONF_FILES= application/config/autoload.php \
@@ -41,11 +40,9 @@ CI_CONF_FILES= application/config/autoload.php \
application/config/user_agents.php \
index.php
-OPTIONS_DEFINE= APACHE DOCS MSSQL MYSQLI ODBC PGSQL SQLITE
+OPTIONS_DEFINE= APACHE MSSQL MYSQLI ODBC PGSQL SQLITE
OPTIONS_SUB= yes
-SUB_FILES= pkg-message
-
APACHE_DESC= Configure for Apache-2.x
MSSQL_DESC= Install MSSQL support for PHP
MYSQLI_DESC= Install MySQLi support for PHP
@@ -55,18 +52,12 @@ SQLITE_DESC= Install SQLite support for PHP
APACHE_SUB_FILES= codeigniter.conf
APACHE_USES= apache:run
-DOCS_VARS= SUB_LIST+=HASHMARK=
-DOCS_VARS_OFF= SUB_LIST+=HASHMARK=\#
MSSQL_USE= PHP=mssql
MYSQLI_USE= PHP=mysqli
ODBC_USE= PHP=odbc
PGSQL_USE= PHP=pgsql
SQLITE_USE= PHP=sqlite3
-post-patch:
- @${RM} ${WRKSRC}/user_guide/.buildinfo
- @${MV} ${WRKSRC}/readme.rst ${WRKSRC}/user_guide/readme.rst
-
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} "application index.php system" ${STAGEDIR}${WWWDIR}
.for ci_conf_file in ${CI_CONF_FILES}
@@ -77,7 +68,4 @@ do-install-APACHE-on:
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes
${INSTALL_DATA} ${WRKDIR}/codeigniter.conf ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes/codeigniter.conf
-do-install-DOCS-on:
- cd ${WRKSRC}/user_guide && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>
diff --git a/www/codeigniter/distinfo b/www/codeigniter/distinfo
index 79c6f10fd2b9..530f790cff67 100644
--- a/www/codeigniter/distinfo
+++ b/www/codeigniter/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1569511355
-SHA256 (bcit-ci-CodeIgniter-3.1.11_GH0.tar.gz) = 4d2df1835f5abc792a9ad0c5532577b3b94d20c358f326191f6b50e0dba4160f
-SIZE (bcit-ci-CodeIgniter-3.1.11_GH0.tar.gz) = 2221699
+TIMESTAMP = 1647264450
+SHA256 (bcit-ci-CodeIgniter-3.1.13_GH0.tar.gz) = 8cb7bea9db3aa6aaa028ec9793e65b21540ec21890505d8ef03addcba46f9d23
+SIZE (bcit-ci-CodeIgniter-3.1.13_GH0.tar.gz) = 411079
diff --git a/www/codeigniter/files/codeigniter-development-cgi.conf.in b/www/codeigniter/files/codeigniter-development-cgi.conf.in
index ec28ab4ab179..820ef5f2a8af 100644
--- a/www/codeigniter/files/codeigniter-development-cgi.conf.in
+++ b/www/codeigniter/files/codeigniter-development-cgi.conf.in
@@ -5,14 +5,8 @@ DirectoryIndex index.php index.html
Action php-script %%PHPCGI%%
AddHandler php-script .php
-%%HASHMARK%%Alias /codeigniter/user_guide %%DOCSDIR%%
Alias /codeigniter %%WWWDIR%%
-%%HASHMARK%%<Directory %%DOCSDIR%%>
-%%HASHMARK%% Order deny,allow
-%%HASHMARK%% Allow from all
-%%HASHMARK%%</Directory>
-
<Location /codeigniter>
Order deny,allow
Allow from all
diff --git a/www/codeigniter/files/codeigniter-development.conf.in b/www/codeigniter/files/codeigniter-development.conf.in
index b339faae05b5..469aa50c187f 100644
--- a/www/codeigniter/files/codeigniter-development.conf.in
+++ b/www/codeigniter/files/codeigniter-development.conf.in
@@ -2,14 +2,8 @@ AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
DirectoryIndex index.php index.html
-%%HASHMARK%%Alias /codeigniter/user_guide %%DOCSDIR%%
Alias /codeigniter %%WWWDIR%%
-%%HASHMARK%%<Directory %%DOCSDIR%%>
-%%HASHMARK%% Order deny,allow
-%%HASHMARK%% Allow from all
-%%HASHMARK%%</Directory>
-
<Location /codeigniter>
Order deny,allow
Allow from all
diff --git a/www/codeigniter/files/codeigniter-production-cgi.conf.in b/www/codeigniter/files/codeigniter-production-cgi.conf.in
index 7cfee81db010..d89689e06f3d 100644
--- a/www/codeigniter/files/codeigniter-production-cgi.conf.in
+++ b/www/codeigniter/files/codeigniter-production-cgi.conf.in
@@ -6,12 +6,6 @@ Action php-script %%PHPCGI%%
AddHandler php-script .php
DocumentRoot %%WWWDIR%%
-%%HASHMARK%%Alias /user_guide %%DOCSDIR%%
-
-%%HASHMARK%%<Location /user_guide>
-%%HASHMARK%% Order deny,allow
-%%HASHMARK%% Allow from all
-%%HASHMARK%%</Location>
<Location />
Order deny,allow
diff --git a/www/codeigniter/files/codeigniter-production.conf.in b/www/codeigniter/files/codeigniter-production.conf.in
index 2b9b97863ccc..f52a024eb338 100644
--- a/www/codeigniter/files/codeigniter-production.conf.in
+++ b/www/codeigniter/files/codeigniter-production.conf.in
@@ -3,12 +3,6 @@ AddType application/x-httpd-php-source .phps
DirectoryIndex index.php index.html
DocumentRoot %%WWWDIR%%
-%%HASHMARK%%Alias /user_guide %%DOCSDIR%%
-
-%%HASHMARK%%<Location /user_guide>
-%%HASHMARK%% Order deny,allow
-%%HASHMARK%% Allow from all
-%%HASHMARK%%</Location>
<Location />
Order deny,allow
diff --git a/www/codeigniter/files/codeigniter.conf.in b/www/codeigniter/files/codeigniter.conf.in
index b339faae05b5..469aa50c187f 100644
--- a/www/codeigniter/files/codeigniter.conf.in
+++ b/www/codeigniter/files/codeigniter.conf.in
@@ -2,14 +2,8 @@ AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
DirectoryIndex index.php index.html
-%%HASHMARK%%Alias /codeigniter/user_guide %%DOCSDIR%%
Alias /codeigniter %%WWWDIR%%
-%%HASHMARK%%<Directory %%DOCSDIR%%>
-%%HASHMARK%% Order deny,allow
-%%HASHMARK%% Allow from all
-%%HASHMARK%%</Directory>
-
<Location /codeigniter>
Order deny,allow
Allow from all
diff --git a/www/codeigniter/pkg-plist b/www/codeigniter/pkg-plist
index 5a73629161cd..8b30e7307622 100644
--- a/www/codeigniter/pkg-plist
+++ b/www/codeigniter/pkg-plist
@@ -1,215 +1,4 @@
%%APACHE%%%%APACHEETCDIR%%/Includes/codeigniter.conf
-%%PORTDOCS%%%%DOCSDIR%%/DCO.html
-%%PORTDOCS%%%%DOCSDIR%%/_downloads/ELDocs.tmbundle.zip
-%%PORTDOCS%%%%DOCSDIR%%/_images/appflowchart.gif
-%%PORTDOCS%%%%DOCSDIR%%/_images/smile.gif
-%%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
-%%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/ci-icon.ico
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment-close.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/css/badge_only.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/css/citheme.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/css/theme.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/doctools.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/down-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/down.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/file.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/FontAwesome.otf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.eot
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.svg
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.woff
-%%PORTDOCS%%%%DOCSDIR%%/_static/images/ci-icon.ico
-%%PORTDOCS%%%%DOCSDIR%%/_static/jquery-3.1.0.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/jquery.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/js/oldtheme.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/js/theme.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/minus.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/plus.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/pygments.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/searchtools.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/underscore-1.3.1.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/underscore.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
-%%PORTDOCS%%%%DOCSDIR%%/changelog.html
-%%PORTDOCS%%%%DOCSDIR%%/contributing/index.html
-%%PORTDOCS%%%%DOCSDIR%%/database/caching.html
-%%PORTDOCS%%%%DOCSDIR%%/database/call_function.html
-%%PORTDOCS%%%%DOCSDIR%%/database/configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/database/connecting.html
-%%PORTDOCS%%%%DOCSDIR%%/database/db_driver_reference.html
-%%PORTDOCS%%%%DOCSDIR%%/database/examples.html
-%%PORTDOCS%%%%DOCSDIR%%/database/forge.html
-%%PORTDOCS%%%%DOCSDIR%%/database/helpers.html
-%%PORTDOCS%%%%DOCSDIR%%/database/index.html
-%%PORTDOCS%%%%DOCSDIR%%/database/metadata.html
-%%PORTDOCS%%%%DOCSDIR%%/database/queries.html
-%%PORTDOCS%%%%DOCSDIR%%/database/query_builder.html
-%%PORTDOCS%%%%DOCSDIR%%/database/results.html
-%%PORTDOCS%%%%DOCSDIR%%/database/transactions.html
-%%PORTDOCS%%%%DOCSDIR%%/database/utilities.html
-%%PORTDOCS%%%%DOCSDIR%%/documentation/index.html
-%%PORTDOCS%%%%DOCSDIR%%/general/alternative_php.html
-%%PORTDOCS%%%%DOCSDIR%%/general/ancillary_classes.html
-%%PORTDOCS%%%%DOCSDIR%%/general/autoloader.html
-%%PORTDOCS%%%%DOCSDIR%%/general/caching.html
-%%PORTDOCS%%%%DOCSDIR%%/general/cli.html
-%%PORTDOCS%%%%DOCSDIR%%/general/common_functions.html
-%%PORTDOCS%%%%DOCSDIR%%/general/compatibility_functions.html
-%%PORTDOCS%%%%DOCSDIR%%/general/controllers.html
-%%PORTDOCS%%%%DOCSDIR%%/general/core_classes.html
-%%PORTDOCS%%%%DOCSDIR%%/general/creating_drivers.html
-%%PORTDOCS%%%%DOCSDIR%%/general/creating_libraries.html
-%%PORTDOCS%%%%DOCSDIR%%/general/credits.html
-%%PORTDOCS%%%%DOCSDIR%%/general/drivers.html
-%%PORTDOCS%%%%DOCSDIR%%/general/environments.html
-%%PORTDOCS%%%%DOCSDIR%%/general/errors.html
-%%PORTDOCS%%%%DOCSDIR%%/general/helpers.html
-%%PORTDOCS%%%%DOCSDIR%%/general/hooks.html
-%%PORTDOCS%%%%DOCSDIR%%/general/index.html
-%%PORTDOCS%%%%DOCSDIR%%/general/libraries.html
-%%PORTDOCS%%%%DOCSDIR%%/general/managing_apps.html
-%%PORTDOCS%%%%DOCSDIR%%/general/models.html
-%%PORTDOCS%%%%DOCSDIR%%/general/profiling.html
-%%PORTDOCS%%%%DOCSDIR%%/general/requirements.html
-%%PORTDOCS%%%%DOCSDIR%%/general/reserved_names.html
-%%PORTDOCS%%%%DOCSDIR%%/general/routing.html
-%%PORTDOCS%%%%DOCSDIR%%/general/security.html
-%%PORTDOCS%%%%DOCSDIR%%/general/styleguide.html
-%%PORTDOCS%%%%DOCSDIR%%/general/urls.html
-%%PORTDOCS%%%%DOCSDIR%%/general/views.html
-%%PORTDOCS%%%%DOCSDIR%%/general/welcome.html
-%%PORTDOCS%%%%DOCSDIR%%/genindex.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/array_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/captcha_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/cookie_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/date_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/directory_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/download_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/email_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/file_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/form_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/html_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/index.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/inflector_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/language_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/number_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/path_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/security_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/smiley_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/string_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/text_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/typography_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/url_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/helpers/xml_helper.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/downloads.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/index.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/troubleshooting.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_120.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_130.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_131.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_132.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_133.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_140.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_141.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_150.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_152.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_153.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_154.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_160.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_161.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_162.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_163.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_170.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_171.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_172.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_200.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_201.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_202.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_203.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_210.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_211.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_212.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_213.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_214.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_220.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_221.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_222.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_223.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_300.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_301.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_302.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_303.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_304.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_305.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_306.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_310.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_311.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_3110.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_3111.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_312.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_313.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_314.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_315.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_316.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_317.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_318.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_319.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrade_b11.html
-%%PORTDOCS%%%%DOCSDIR%%/installation/upgrading.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/benchmark.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/caching.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/calendar.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/cart.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/config.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/email.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/encrypt.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/encryption.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/file_uploading.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/form_validation.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/ftp.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/image_lib.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/index.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/input.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/javascript.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/language.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/loader.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/migration.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/output.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/pagination.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/parser.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/security.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/sessions.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/table.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/trackback.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/typography.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/unit_testing.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/uri.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/user_agent.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/xmlrpc.html
-%%PORTDOCS%%%%DOCSDIR%%/libraries/zip.html
-%%PORTDOCS%%%%DOCSDIR%%/license.html
-%%PORTDOCS%%%%DOCSDIR%%/objects.inv
-%%PORTDOCS%%%%DOCSDIR%%/overview/appflow.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/at_a_glance.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/features.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/getting_started.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/goals.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/index.html
-%%PORTDOCS%%%%DOCSDIR%%/overview/mvc.html
-%%PORTDOCS%%%%DOCSDIR%%/readme.rst
-%%PORTDOCS%%%%DOCSDIR%%/search.html
-%%PORTDOCS%%%%DOCSDIR%%/searchindex.js
-%%PORTDOCS%%%%DOCSDIR%%/tutorial/conclusion.html
-%%PORTDOCS%%%%DOCSDIR%%/tutorial/create_news_items.html
-%%PORTDOCS%%%%DOCSDIR%%/tutorial/index.html
-%%PORTDOCS%%%%DOCSDIR%%/tutorial/news_section.html
-%%PORTDOCS%%%%DOCSDIR%%/tutorial/static_pages.html
@dir(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/application/cache
%%WWWDIR%%/application/.htaccess
%%WWWDIR%%/application/cache/index.html
@@ -432,15 +221,19 @@
%%WWWDIR%%/system/libraries/Form_validation.php
%%WWWDIR%%/system/libraries/Ftp.php
%%WWWDIR%%/system/libraries/Image_lib.php
+%%WWWDIR%%/system/libraries/Javascript.php
%%WWWDIR%%/system/libraries/Javascript/Jquery.php
%%WWWDIR%%/system/libraries/Javascript/index.html
-%%WWWDIR%%/system/libraries/Javascript.php
%%WWWDIR%%/system/libraries/Migration.php
%%WWWDIR%%/system/libraries/Pagination.php
%%WWWDIR%%/system/libraries/Parser.php
%%WWWDIR%%/system/libraries/Profiler.php
+%%WWWDIR%%/system/libraries/Session/CI_Session_driver_interface.php
+%%WWWDIR%%/system/libraries/Session/OldSessionWrapper.php
+%%WWWDIR%%/system/libraries/Session/PHP8SessionWrapper.php
%%WWWDIR%%/system/libraries/Session/Session.php
%%WWWDIR%%/system/libraries/Session/SessionHandlerInterface.php
+%%WWWDIR%%/system/libraries/Session/SessionUpdateTimestampHandlerInterface.php
%%WWWDIR%%/system/libraries/Session/Session_driver.php
%%WWWDIR%%/system/libraries/Session/drivers/Session_database_driver.php
%%WWWDIR%%/system/libraries/Session/drivers/Session_files_driver.php