aboutsummaryrefslogtreecommitdiff
path: root/www/cplanet
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-22 20:43:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-22 20:43:11 +0000
commitf7615de88bcf9e06b47fee49eda4f8a9409ce0d3 (patch)
tree83cf02694fd28f1c3311a4f71b5cd0a64c78541f /www/cplanet
parent33b6c10c308d4a72337b2f1cb6452839f6e96dfd (diff)
downloadports-f7615de88bcf9e06b47fee49eda4f8a9409ce0d3.tar.gz
ports-f7615de88bcf9e06b47fee49eda4f8a9409ce0d3.zip
cplanet is a RSS/ATOM feed aggregator written in C that generate static
html files. WWW: http://brokk.etoilebsd.net/projects/show/cplanet PR: ports/144207 Submitted by: Bapt <baptiste.daroussin at gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=250189
Diffstat (limited to 'www/cplanet')
-rw-r--r--www/cplanet/Makefile36
-rw-r--r--www/cplanet/distinfo3
-rw-r--r--www/cplanet/pkg-descr4
-rw-r--r--www/cplanet/pkg-plist6
4 files changed, 49 insertions, 0 deletions
diff --git a/www/cplanet/Makefile b/www/cplanet/Makefile
new file mode 100644
index 000000000000..80588ed1fc51
--- /dev/null
+++ b/www/cplanet/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: cplanet
+# Date created: 2010-02-22
+# Whom: Bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cplanet
+PORTVERSION= 0.3
+CATEGORIES= www textproc
+MASTER_SITES= http://baptux.free.fr/distfiles/
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= RSS Feed Aggregator that generate static html
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libneo_cs.a:${PORTSDIR}/www/clearsilver
+LIB_DEPENDS= mrss.19:${PORTSDIR}/textproc/libmrss
+
+USE_BZIP2= yes
+
+USE_ICONV= yes
+
+MAN1= cplanet.1
+
+.include <bsd.port.pre.mk>
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-atom.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-opml.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-rss.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet.hdf ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/cplanet/distinfo b/www/cplanet/distinfo
new file mode 100644
index 000000000000..4e509bed0173
--- /dev/null
+++ b/www/cplanet/distinfo
@@ -0,0 +1,3 @@
+MD5 (cplanet-0.3.tar.bz2) = 9114f951726bb7df4e66770df0315ca5
+SHA256 (cplanet-0.3.tar.bz2) = 9aba913ba364757efb092c9cfa2c4c7bb946a71cb777522704039f553753bb3f
+SIZE (cplanet-0.3.tar.bz2) = 7618
diff --git a/www/cplanet/pkg-descr b/www/cplanet/pkg-descr
new file mode 100644
index 000000000000..393236334ac0
--- /dev/null
+++ b/www/cplanet/pkg-descr
@@ -0,0 +1,4 @@
+cplanet is a RSS/ATOM feed aggregator written in C that generate static
+html files.
+
+WWW: http://brokk.etoilebsd.net/projects/show/cplanet
diff --git a/www/cplanet/pkg-plist b/www/cplanet/pkg-plist
new file mode 100644
index 000000000000..4299ae2d559d
--- /dev/null
+++ b/www/cplanet/pkg-plist
@@ -0,0 +1,6 @@
+bin/cplanet
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-atom.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-opml.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-rss.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet.hdf