aboutsummaryrefslogtreecommitdiff
path: root/www/crawl
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-03-12 13:43:32 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-03-12 13:43:32 +0000
commit8e66449afe286da6573349869dcd69a376a041f6 (patch)
tree814eef107862076389e0f9093b7a299dcfd6f1ad /www/crawl
parent51378f7b19d9cc02804b39a47c85691c0588a4f4 (diff)
downloadports-8e66449afe286da6573349869dcd69a376a041f6.tar.gz
ports-8e66449afe286da6573349869dcd69a376a041f6.zip
Unbreak on -current.
Notes
Notes: svn path=/head/; revision=103780
Diffstat (limited to 'www/crawl')
-rw-r--r--www/crawl/Makefile8
-rw-r--r--www/crawl/files/patch-compat::gai-errnos.h12
-rw-r--r--www/crawl/files/patch-dns.c12
3 files changed, 25 insertions, 7 deletions
diff --git a/www/crawl/Makefile b/www/crawl/Makefile
index c1d93e626ee7..1a4bdb161f08 100644
--- a/www/crawl/Makefile
+++ b/www/crawl/Makefile
@@ -22,12 +22,6 @@ CONFIGURE_ARGS+= --with-libevent=${LOCALBASE} --program-transform-name=''
MAN1= crawl.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/include/db2,${LOCALBASE}/include/db3,g' \
-e 's,db2,db3,g' ${WRKSRC}/configure.in
@@ -38,4 +32,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/crawl.conf ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/crawl/files/patch-compat::gai-errnos.h b/www/crawl/files/patch-compat::gai-errnos.h
new file mode 100644
index 000000000000..517c9ca5d38b
--- /dev/null
+++ b/www/crawl/files/patch-compat::gai-errnos.h
@@ -0,0 +1,12 @@
+$FreeBSD$
+
+--- compat/gai-errnos.h.orig Fri Mar 12 07:29:36 2004
++++ compat/gai-errnos.h Fri Mar 12 07:29:52 2004
+@@ -10,5 +10,7 @@
+ /* for old netdb.h */
+ #ifndef EAI_NODATA
+ #define EAI_NODATA 1
++#endif
++#ifndef EAI_MEMORY
+ #define EAI_MEMORY 2
+ #endif
diff --git a/www/crawl/files/patch-dns.c b/www/crawl/files/patch-dns.c
new file mode 100644
index 000000000000..c061817985fa
--- /dev/null
+++ b/www/crawl/files/patch-dns.c
@@ -0,0 +1,12 @@
+$FreeBSD$
+
+--- dns.c.orig Fri Mar 12 07:29:07 2004
++++ dns.c Fri Mar 12 07:29:19 2004
+@@ -46,6 +46,7 @@
+ #include "tree.h"
+ #include "http.h"
+ #include "dns.h"
++#include "getaddrinfo.h"
+
+ ssize_t atomicio(ssize_t (*f)(), int, void *, size_t);
+