aboutsummaryrefslogtreecommitdiff
path: root/www/davical
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-09-30 11:21:07 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-09-30 11:21:07 +0000
commit684a3ff8bacef31d1948428355b6023007d10bb9 (patch)
tree391d904b759a4fa6b47a2eaa0f6d96399f67ffaf /www/davical
parent04319b41762be21e35910407b1ee7a6e14deb824 (diff)
downloadports-684a3ff8bacef31d1948428355b6023007d10bb9.tar.gz
ports-684a3ff8bacef31d1948428355b6023007d10bb9.zip
www/davical: add php-curl as dependency
* Davical does need "ftp/phpXX-curl" for external binding work properly. Its self check also fail if it is not present. https://wiki.davical.org/index.php/Setup_Failure_Codes/PHP_curl_support * While here, do some minor alphabetizing of the various lists. PR: 222652 Submitted by: Le Baron d'Merde <lbdm@privacychain.ch>
Notes
Notes: svn path=/head/; revision=450976
Diffstat (limited to 'www/davical')
-rw-r--r--www/davical/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/davical/Makefile b/www/davical/Makefile
index 42103b5c5acc..6125e93837c1 100644
--- a/www/davical/Makefile
+++ b/www/davical/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= davical
-PORTVERSION= 1.1.5
DISTVERSIONPREFIX= r
+DISTVERSION= 1.1.5
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= https://gitlab.com/${PORTNAME}-project/${PORTNAME}/repository/archive.tar.gz?ref=${DISTVERSIONPREFIX}${PORTVERSION}&dummy=/
@@ -23,12 +24,12 @@ RUN_DEPENDS= p5-DBI>=0:databases/p5-DBI \
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSIONPREFIX}${PORTVERSION}-7ccc7c449176475891ec50d5524928628df6f8d1
NO_BUILD= yes
-USES= shebangfix pgsql php
-USE_PHP= gettext iconv pcre pdo pdo_pgsql pgsql xml calendar
+USES= pgsql php shebangfix
+USE_PHP= calendar curl gettext iconv pcre pdo pdo_pgsql pgsql xml
SHEBANG_FILES= scripts/sync-remote-caldav.php
SUB_FILES= pkg-message httpd-davical.conf
-PORTDOCS= README INSTALL davical_en_user_guide.odt translation.rst \
- phpdoc.ini
+PORTDOCS= README INSTALL davical_en_user_guide.odt phpdoc.ini \
+ translation.rst
PORTEXAMPLES= config
OPTIONS_DEFINE= DOCS EXAMPLES