aboutsummaryrefslogtreecommitdiff
path: root/www/dddbl/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-08 15:33:03 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-08 15:33:03 +0000
commit68d029b0656beb36b2d8575fca4c4fa66db49c69 (patch)
treef655495df22b75deaca3262ecaba3d2ab0956f58 /www/dddbl/Makefile
parent618fe421a6319a11ac51e8e19cbda9e51d143c8d (diff)
Add new port www/dddbl
PR: 190575 Submitted by: Torsten Zuehlsdorff ================================================================ DDDBL is a Definition Driven DataBase Layer written in PHP. It uses PDO to support the work on all supported database systems and eases the handling of the query-results.
Notes
Notes: svn path=/head/; revision=364367
Diffstat (limited to 'www/dddbl/Makefile')
-rw-r--r--www/dddbl/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/dddbl/Makefile b/www/dddbl/Makefile
new file mode 100644
index 000000000000..3c84f55b7aa0
--- /dev/null
+++ b/www/dddbl/Makefile
@@ -0,0 +1,26 @@
+# Created by: Torsten Zühlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= dddbl
+PORTVERSION= 2.0.1
+CATEGORIES= www
+MASTER_SITES= http://www.dddbl.de/dddbl-versions/
+
+MAINTAINER= ports@toco-domains.de
+COMMENT= Definition Driven Database Layer for PHP
+
+USES= tar:bzip2
+
+.include <bsd.port.options.mk>
+
+NO_BUILD= yes
+
+USE_PHP= yes
+
+WRKSRC= ${WRKDIR}/dddbl2
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>