aboutsummaryrefslogtreecommitdiff
path: root/www/deno/Makefile
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2021-01-05 10:56:27 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-01-05 10:56:27 +0000
commit72c264f1b7ae50f822544c67fe3139349bea6f6a (patch)
tree8ef0a0996e12c16e307045ed3c829b0efced59e7 /www/deno/Makefile
parent0197863e8016dfabdbebcd4df8355a7bb26e18b8 (diff)
downloadports-72c264f1b7ae50f822544c67fe3139349bea6f6a.tar.gz
ports-72c264f1b7ae50f822544c67fe3139349bea6f6a.zip
www/deno: Update to v1.6.3
Notes
Notes: svn path=/head/; revision=560378
Diffstat (limited to 'www/deno/Makefile')
-rw-r--r--www/deno/Makefile57
1 files changed, 15 insertions, 42 deletions
diff --git a/www/deno/Makefile b/www/deno/Makefile
index 40325c731fd4..afbcc3fb7d68 100644
--- a/www/deno/Makefile
+++ b/www/deno/Makefile
@@ -2,7 +2,7 @@
PORTNAME= deno
DISTVERSIONPREFIX= v
-DISTVERSION= 1.6.2
+DISTVERSION= 1.6.3
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org
@@ -33,7 +33,7 @@ USE_GNOME= glib20
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-RUSTY_VERS= 0.14.0
+RUSTY_VERS= 0.15.0
CARGO_ENV+= CLANG_BASE_PATH=/usr \
GN=${PREFIX}/bin/gn \
@@ -61,20 +61,15 @@ CARGO_CRATES= Inflector-0.11.4 \
async-trait-0.1.42 \
atty-0.2.14 \
auto_impl-0.4.1 \
- autocfg-0.1.7 \
autocfg-1.0.1 \
base64-0.11.0 \
base64-0.12.3 \
bitflags-1.2.1 \
- block-buffer-0.7.3 \
block-buffer-0.9.0 \
- block-padding-0.1.5 \
brotli-3.3.0 \
brotli-decompressor-2.3.1 \
- buf_redux-0.8.4 \
build_const-0.2.1 \
bumpalo-3.4.0 \
- byte-tools-0.3.1 \
byteorder-1.3.4 \
bytes-0.5.6 \
bytes-0.6.0 \
@@ -84,7 +79,6 @@ CARGO_CRATES= Inflector-0.11.4 \
cfg-if-1.0.0 \
chrono-0.4.15 \
clap-2.33.3 \
- cloudabi-0.0.3 \
cloudabi-0.1.0 \
const-random-0.1.8 \
const-random-macro-0.1.8 \
@@ -100,13 +94,13 @@ CARGO_CRATES= Inflector-0.11.4 \
deno_doc-0.1.19 \
deno_lint-0.2.14 \
derive_more-0.99.11 \
- digest-0.8.1 \
digest-0.9.0 \
dissimilar-1.0.2 \
dlopen-0.1.8 \
dlopen_derive-0.1.4 \
- dprint-core-0.33.1 \
- dprint-plugin-typescript-0.36.0 \
+ dprint-core-0.34.0 \
+ dprint-plugin-typescript-0.37.0 \
+ dprint-swc-ecma-ast-view-0.3.1 \
dtoa-0.4.6 \
either-1.6.0 \
encoding_rs-0.8.24 \
@@ -116,16 +110,16 @@ CARGO_CRATES= Inflector-0.11.4 \
errno-0.2.7 \
errno-dragonfly-0.1.1 \
exec-0.3.1 \
- fake-simd-0.1.2 \
filetime-0.2.12 \
fixedbitset-0.2.0 \
flate2-1.0.17 \
fnv-1.0.7 \
+ form_urlencoded-1.0.0 \
from_variant-0.1.2 \
fs2-0.4.3 \
fsevent-2.0.2 \
fsevent-sys-3.0.2 \
- fuchsia-cprng-0.1.1 \
+ fslock-0.1.6 \
fuchsia-zircon-0.3.3 \
fuchsia-zircon-sys-0.3.3 \
futures-0.3.8 \
@@ -140,13 +134,10 @@ CARGO_CRATES= Inflector-0.11.4 \
fwdansi-1.1.0 \
fxhash-0.2.1 \
gcc-0.3.55 \
- generic-array-0.12.3 \
generic-array-0.14.4 \
getrandom-0.1.15 \
h2-0.2.6 \
hashbrown-0.9.0 \
- headers-0.3.2 \
- headers-core-0.2.0 \
heck-0.3.1 \
hermit-abi-0.1.15 \
http-0.2.1 \
@@ -194,7 +185,6 @@ CARGO_CRATES= Inflector-0.11.4 \
mio-uds-0.6.8 \
miow-0.2.1 \
miow-0.3.6 \
- multipart-0.17.0 \
net2-0.2.35 \
new_debug_unreachable-1.0.4 \
nix-0.19.0 \
@@ -206,7 +196,6 @@ CARGO_CRATES= Inflector-0.11.4 \
num-traits-0.2.12 \
num_cpus-1.13.0 \
once_cell-1.5.2 \
- opaque-debug-0.2.3 \
opaque-debug-0.3.0 \
ordered-float-1.1.0 \
os_pipe-0.9.2 \
@@ -240,22 +229,11 @@ CARGO_CRATES= Inflector-0.11.4 \
quote-0.6.13 \
quote-1.0.7 \
radix_fmt-1.0.0 \
- rand-0.6.5 \
rand-0.7.3 \
- rand_chacha-0.1.1 \
rand_chacha-0.2.2 \
- rand_core-0.3.1 \
- rand_core-0.4.2 \
rand_core-0.5.1 \
- rand_hc-0.1.0 \
rand_hc-0.2.0 \
- rand_isaac-0.1.1 \
- rand_jitter-0.1.4 \
- rand_os-0.1.3 \
- rand_pcg-0.1.2 \
rand_pcg-0.2.1 \
- rand_xorshift-0.1.1 \
- rdrand-0.4.0 \
redox_syscall-0.1.57 \
regex-1.4.2 \
regex-syntax-0.6.21 \
@@ -266,11 +244,10 @@ CARGO_CRATES= Inflector-0.11.4 \
ring-0.16.19 \
rustc_version-0.2.3 \
rustls-0.18.1 \
- rusty_v8-0.14.0 \
+ rusty_v8-0.15.0 \
rustyline-7.1.0 \
rustyline-derive-0.4.0 \
ryu-1.0.5 \
- safemem-0.3.3 \
same-file-1.0.6 \
scoped-tls-1.0.0 \
scopeguard-1.1.0 \
@@ -283,7 +260,6 @@ CARGO_CRATES= Inflector-0.11.4 \
serde_json-1.0.60 \
serde_repr-0.1.6 \
serde_urlencoded-0.6.1 \
- sha-1-0.8.2 \
sha-1-0.9.1 \
shell-escape-0.1.5 \
signal-hook-registry-1.2.1 \
@@ -295,14 +271,14 @@ CARGO_CRATES= Inflector-0.11.4 \
spin-0.5.2 \
stable_deref_trait-1.2.0 \
static_assertions-1.1.0 \
- string_cache-0.8.0 \
+ string_cache-0.8.1 \
string_cache_codegen-0.5.1 \
string_enum-0.3.0 \
strsim-0.8.0 \
strsim-0.9.3 \
swc_atoms-0.2.5 \
- swc_bundler-0.18.0 \
- swc_common-0.10.7 \
+ swc_bundler-0.18.2 \
+ swc_common-0.10.8 \
swc_ecma_ast-0.36.0 \
swc_ecma_codegen-0.42.0 \
swc_ecma_codegen_macros-0.5.0 \
@@ -313,12 +289,13 @@ CARGO_CRATES= Inflector-0.11.4 \
swc_ecma_transforms_macros-0.1.1 \
swc_ecma_utils-0.26.0 \
swc_ecma_visit-0.22.0 \
- swc_ecmascript-0.16.0 \
+ swc_ecmascript-0.16.1 \
+ swc_eq_ignore_macros-0.1.0 \
swc_macros_common-0.3.1 \
swc_visit-0.2.2 \
swc_visit_macros-0.2.1 \
syn-0.15.44 \
- syn-1.0.48 \
+ syn-1.0.56 \
sys-info-0.7.0 \
tempfile-3.1.0 \
termcolor-1.1.2 \
@@ -342,10 +319,8 @@ CARGO_CRATES= Inflector-0.11.4 \
tower-test-0.3.0 \
tracing-0.1.19 \
tracing-core-0.1.16 \
- tracing-futures-0.2.4 \
try-lock-0.2.3 \
tungstenite-0.11.1 \
- twoway-0.1.8 \
typenum-1.12.0 \
unicase-2.6.0 \
unicode-bidi-0.3.4 \
@@ -355,8 +330,7 @@ CARGO_CRATES= Inflector-0.11.4 \
unicode-xid-0.1.0 \
unicode-xid-0.2.1 \
untrusted-0.7.1 \
- url-2.1.1 \
- urlencoding-1.1.1 \
+ url-2.2.0 \
utf-8-0.7.5 \
utf8parse-0.2.0 \
uuid-0.8.1 \
@@ -364,7 +338,6 @@ CARGO_CRATES= Inflector-0.11.4 \
version_check-0.9.2 \
walkdir-2.3.1 \
want-0.3.0 \
- warp-0.2.5 \
wasi-0.9.0+wasi-snapshot-preview1 \
wasi-0.10.0+wasi-snapshot-preview1 \
wasm-bindgen-0.2.68 \