aboutsummaryrefslogtreecommitdiff
path: root/www/drush
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2013-12-09 10:30:04 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2013-12-09 10:30:04 +0000
commit344e18e7c564bdf5da91183f9b59720581c34c15 (patch)
treee6f22d30f437f631d777163370df46c3258e0cb7 /www/drush
parentefaeacdd63b9ce38f484d35165c674376ed6c0da (diff)
downloadports-344e18e7c564bdf5da91183f9b59720581c34c15.tar.gz
ports-344e18e7c564bdf5da91183f9b59720581c34c15.zip
- Update to 6.1.0
- Migrate to Github - enable STAGEing PR: ports/184040 Submitted by: Geoffroy Desvernay <dgeo@centrale-marseille.fr>
Notes
Notes: svn path=/head/; revision=335962
Diffstat (limited to 'www/drush')
-rw-r--r--www/drush/Makefile46
-rw-r--r--www/drush/distinfo4
-rw-r--r--www/drush/pkg-plist385
3 files changed, 254 insertions, 181 deletions
diff --git a/www/drush/Makefile b/www/drush/Makefile
index 97295ca8f1e6..86cf61e7d0aa 100644
--- a/www/drush/Makefile
+++ b/www/drush/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= drush
-PORTVERSION= 5.9
+PORTVERSION= 6.1.0
CATEGORIES= www
-MASTER_SITES= http://ftp.drupal.org/files/projects/
-DISTNAME= drush-7.x-${PORTVERSION}
MAINTAINER= dgeo@centrale-marseille.fr
COMMENT= Drupal command line and scripting interface
@@ -16,23 +14,43 @@ RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Table.php:${PORTSDIR}/devel/pear-Co
NO_BUILD= yes
+GH_ACCOUNT= ${PORTNAME}-ops
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= d948558
+USE_GITHUB= yes
+
# set php requirements same as drupal itself
-USE_PHP= gd pcre session xml mbstring ctype json hash simplexml dom pdo pdo_mysql
+USE_PHP= gd pcre session xml mbstring ctype json hash simplexml dom pdo filter
IGNORE_WITH_PHP=4
WANT_PHP_CLI= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+PORTDOCS= *
+
+PORTEXAMPLES= *
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
do-configure:
- @${REINPLACE_CMD} -e 's|XXXDATADIRXXX|${DATADIR}|g' ${WRKSRC}/drush
+ @${REINPLACE_CMD} -e 's|XXXDATADIRXXX|${STAGEDIR}${DATADIR}|g' ${WRKSRC}/drush
do-install:
- ${MKDIR} ${DATADIR}
- ( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR} '! ( -name drush.bat -or -name *.orig -or -name *.bak -or -name .gitignore -or -name LICENSE.txt )' )
- ${CHMOD} 755 ${DATADIR}/drush
- ${LN} -s ${DATADIR}/drush ${PREFIX}/bin/drush
-
-.include <bsd.port.post.mk>
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ( cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} "classes commands includes lib misc tests drush_logo-black.png drush.php drush.info" ${STAGEDIR}${DATADIR} && \
+ ${INSTALL_DATA} drush_logo-black.png drush.php ${STAGEDIR}${DATADIR} && \
+ ${INSTALL_SCRIPT} drush drush.complete.sh ${STAGEDIR}${DATADIR} )
+ ${LN} -s ${DATADIR}/drush ${STAGEDIR}${PREFIX}/bin/drush
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ( cd ${WRKSRC} && ${INSTALL_MAN} *.md docs/* ${STAGEDIR}${DOCSDIR} )
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ( cd ${WRKSRC} && ${INSTALL_MAN} examples/* ${STAGEDIR}${EXAMPLESDIR} )
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/drush/distinfo b/www/drush/distinfo
index 1399be1838c0..c117d5bee8fc 100644
--- a/www/drush/distinfo
+++ b/www/drush/distinfo
@@ -1,2 +1,2 @@
-SHA256 (drush-7.x-5.9.tar.gz) = 3acc2a2491fef987c17e85122f7d3cd0bc99cefd1bc70891ec3a1c4fd51dccee
-SIZE (drush-7.x-5.9.tar.gz) = 414897
+SHA256 (drush-6.1.0.tar.gz) = d13505bb5020e2773c23760aa0a93ec46c04865f4e11bb08029b21ab1b960b3c
+SIZE (drush-6.1.0.tar.gz) = 503450
diff --git a/www/drush/pkg-plist b/www/drush/pkg-plist
index 7ddd0d3c1d39..14178ec336af 100644
--- a/www/drush/pkg-plist
+++ b/www/drush/pkg-plist
@@ -1,192 +1,247 @@
bin/drush
-%%DATADIR%%/README.txt
-%%DATADIR%%/commands/core/core.drush.inc
-%%DATADIR%%/commands/core/docs.drush.inc
-%%DATADIR%%/commands/core/drupal/batch_6.inc
-%%DATADIR%%/commands/core/drupal/batch.inc
-%%DATADIR%%/commands/core/drupal/environment_6.inc
-%%DATADIR%%/commands/core/drupal/environment.inc
-%%DATADIR%%/commands/core/drupal/site_install_6.inc
-%%DATADIR%%/commands/core/drupal/site_install.inc
-%%DATADIR%%/commands/core/drupal/update_6.inc
-%%DATADIR%%/commands/core/drupal/update.inc
-%%DATADIR%%/commands/core/field.drush.inc
-%%DATADIR%%/commands/core/help.drush.inc
-%%DATADIR%%/commands/core/image.drush.inc
-%%DATADIR%%/commands/core/rsync.core.inc
-%%DATADIR%%/commands/core/scratch.php
-%%DATADIR%%/commands/core/search.drush.inc
-%%DATADIR%%/commands/core/site_install.drush.inc
-%%DATADIR%%/commands/core/sitealias.drush.inc
-%%DATADIR%%/commands/core/test.drush.inc
-%%DATADIR%%/commands/core/topic.drush.inc
-%%DATADIR%%/commands/core/variable.drush.inc
-%%DATADIR%%/commands/core/watchdog.drush.inc
-%%DATADIR%%/commands/core/drupal/update_7.inc
-%%DATADIR%%/commands/core/usage.drush.inc
-%%DATADIR%%/commands/core/queue.drush.inc
-%%DATADIR%%/commands/core/ssh.drush.inc
-%%DATADIR%%/commands/core/shellalias.drush.inc
-%%DATADIR%%/commands/core/cache.drush.inc
-%%DATADIR%%/commands/core/archive.drush.inc
-%%DATADIR%%/commands/pm/release_info/updatexml.inc
-%%DATADIR%%/commands/pm/download.pm.inc
-%%DATADIR%%/commands/pm/info.pm.inc
-%%DATADIR%%/commands/pm/package_handler/git_drupalorg.inc
-%%DATADIR%%/commands/pm/package_handler/wget.inc
-%%DATADIR%%/commands/pm/pm.drush.inc
-%%DATADIR%%/commands/pm/update_info/drupal_6.inc
-%%DATADIR%%/commands/pm/update_info/drupal.inc
-%%DATADIR%%/commands/pm/updatecode.pm.inc
-%%DATADIR%%/commands/pm/version_control/backup.inc
-%%DATADIR%%/commands/pm/version_control/bzr.inc
-%%DATADIR%%/commands/pm/version_control/svn.inc
-%%DATADIR%%/commands/runserver/runserver-prepend.php
-%%DATADIR%%/commands/runserver/runserver-drupal.inc
-%%DATADIR%%/commands/runserver/runserver.drush.inc
-%%DATADIR%%/commands/make/make.download.inc
-%%DATADIR%%/commands/make/make.drush.inc
-%%DATADIR%%/commands/make/generate.make.inc
-%%DATADIR%%/commands/make/make.utilities.inc
-%%DATADIR%%/commands/make/make.project.inc
-%%DATADIR%%/commands/sql/sql.drush.inc
-%%DATADIR%%/commands/sql/sync.sql.inc
-%%DATADIR%%/commands/user/user.drush.inc
-%%DATADIR%%/docs/strict-options.html
-%%DATADIR%%/docs/shellaliases.html
-%%DATADIR%%/docs/bastion.html
-%%DATADIR%%/docs/cron.html
-%%DATADIR%%/docs/bootstrap.html
-%%DATADIR%%/docs/commands.html
-%%DATADIR%%/docs/context.html
-%%DATADIR%%/docs/drush.api.php
-%%DATADIR%%/docs/shellscripts.html
-%%DATADIR%%/docs/make.txt
-%%DATADIR%%/drush.complete.sh
-%%DATADIR%%/drush.info
-%%DATADIR%%/drush.php
-%%DATADIR%%/drush
-%%DATADIR%%/drush_logo-black.png
-%%DATADIR%%/examples/example.aliases.drushrc.php
-%%DATADIR%%/examples/example.bashrc
-%%DATADIR%%/examples/example.make
-%%DATADIR%%/examples/example.drush.ini
-%%DATADIR%%/examples/example.drushrc.php
-%%DATADIR%%/examples/helloworld.script
-%%DATADIR%%/examples/policy.drush.inc
-%%DATADIR%%/examples/sandwich-topic.txt
-%%DATADIR%%/examples/sandwich.drush.inc
-%%DATADIR%%/examples/sandwich.txt
-%%DATADIR%%/examples/xkcd.drush.inc
-%%DATADIR%%/examples/sync_enable.drush.inc
-%%DATADIR%%/examples/sync_via_http.drush.inc
-%%DATADIR%%/examples/sandwich-nocolor.txt
-%%DATADIR%%/includes/backend.inc
-%%DATADIR%%/includes/batch.inc
-%%DATADIR%%/includes/command.inc
-%%DATADIR%%/includes/context.inc
-%%DATADIR%%/includes/drush.inc
-%%DATADIR%%/includes/environment.inc
-%%DATADIR%%/includes/sitealias.inc
-%%DATADIR%%/includes/bootstrap.inc
-%%DATADIR%%/includes/cache.inc
-%%DATADIR%%/includes/dbtng.inc
-%%DATADIR%%/includes/complete.inc
-%%DATADIR%%/includes/drupal.inc
-%%DATADIR%%/includes/filesystem.inc
-%%DATADIR%%/includes/exec.inc
-%%DATADIR%%/includes/output.inc
-%%DATADIR%%/lib/README.txt
+%%DATADIR%%/tests/watchdogTest.php
+%%DATADIR%%/tests/variableTest.php
+%%DATADIR%%/tests/userTest.php
+%%DATADIR%%/tests/unit.drush.inc
+%%DATADIR%%/tests/tablesUnitTest.php
+%%DATADIR%%/tests/sqlSyncTest.php
+%%DATADIR%%/tests/sqlDumpTest.php
+%%DATADIR%%/tests/sqlConnectTest.php
+%%DATADIR%%/tests/siteSshTest.php
+%%DATADIR%%/tests/siteSetUnitTest.php
+%%DATADIR%%/tests/siteSetTest.php
%%DATADIR%%/tests/siteIntallD6Test.php
-%%DATADIR%%/tests/completeTest.php
-%%DATADIR%%/tests/filesystemTest.php
-%%DATADIR%%/tests/makefiles/bz2-singlefile.make
-%%DATADIR%%/tests/makefiles/gzip.make
-%%DATADIR%%/tests/makefiles/bz2.make
-%%DATADIR%%/tests/makefiles/defaults.make
-%%DATADIR%%/tests/makefiles/contrib-destination.make
-%%DATADIR%%/tests/makefiles/svn.make
-%%DATADIR%%/tests/makefiles/qd-devel.make
-%%DATADIR%%/tests/makefiles/translations-inside7.make
-%%DATADIR%%/tests/makefiles/recursion.make
-%%DATADIR%%/tests/makefiles/included2.make
+%%DATADIR%%/tests/siteAliasUnitTest.php
+%%DATADIR%%/tests/siteAliasTest.php
+%%DATADIR%%/tests/shellAliasTest.php
+%%DATADIR%%/tests/roleTest.php
+%%DATADIR%%/tests/resources/queue_script.php
+%%DATADIR%%/tests/resources/example.profile
+%%DATADIR%%/tests/resources/create_node_types.php
+%%DATADIR%%/tests/releaseInfoTest.php
+%%DATADIR%%/tests/quickDrupalTest.php
+%%DATADIR%%/tests/queueTest.php
+%%DATADIR%%/tests/pmUpdateCodeTest.php
+%%DATADIR%%/tests/pmEnDisUnListTest.php
+%%DATADIR%%/tests/pmDownloadTest.php
+%%DATADIR%%/tests/phpunit.xml.dist
+%%DATADIR%%/tests/outputFormatUnitTest.php
+%%DATADIR%%/tests/outputFormatTest.php
+%%DATADIR%%/tests/makefiles/use-distribution-as-core.make
%%DATADIR%%/tests/makefiles/translations.make
-%%DATADIR%%/tests/makefiles/git.make
+%%DATADIR%%/tests/makefiles/translations-inside7.make
%%DATADIR%%/tests/makefiles/translations-inside.make
+%%DATADIR%%/tests/makefiles/svn.make
%%DATADIR%%/tests/makefiles/subtree.make
-%%DATADIR%%/tests/makefiles/included.make
-%%DATADIR%%/tests/makefiles/limited-projects-libraries.make
+%%DATADIR%%/tests/makefiles/recursion.make
+%%DATADIR%%/tests/makefiles/recursion-override.make
+%%DATADIR%%/tests/makefiles/qd-devel.make
+%%DATADIR%%/tests/makefiles/patches.make
+%%DATADIR%%/tests/makefiles/patches-local-test-wysiwyg.patch
+%%DATADIR%%/tests/makefiles/options-project.make
+%%DATADIR%%/tests/makefiles/options-array.make
+%%DATADIR%%/tests/makefiles/md5-succeed.make
%%DATADIR%%/tests/makefiles/md5-fail.make
+%%DATADIR%%/tests/makefiles/limited-projects-libraries.make
+%%DATADIR%%/tests/makefiles/included2.make
+%%DATADIR%%/tests/makefiles/included.make
+%%DATADIR%%/tests/makefiles/include.make
+%%DATADIR%%/tests/makefiles/gzip.make
+%%DATADIR%%/tests/makefiles/git.make
%%DATADIR%%/tests/makefiles/git-simple.make
+%%DATADIR%%/tests/makefiles/get.make
+%%DATADIR%%/tests/makefiles/file.make
%%DATADIR%%/tests/makefiles/file-extract.make
-%%DATADIR%%/tests/makefiles/include.make
+%%DATADIR%%/tests/makefiles/defaults.make
+%%DATADIR%%/tests/makefiles/contrib-destination.make
%%DATADIR%%/tests/makefiles/bzr.make
-%%DATADIR%%/tests/makefiles/file.make
-%%DATADIR%%/tests/makefiles/get.make
-%%DATADIR%%/tests/makefiles/patches.make
-%%DATADIR%%/tests/makefiles/md5-succeed.make
+%%DATADIR%%/tests/makefiles/bz2.make
+%%DATADIR%%/tests/makefiles/bz2-singlefile.make
+%%DATADIR%%/tests/makeTest.php
+%%DATADIR%%/tests/imageTest.php
+%%DATADIR%%/tests/hooks/magic_help_alter/magic.drush.inc
+%%DATADIR%%/tests/generateMakeTest.php
+%%DATADIR%%/tests/filesystemTest.php
+%%DATADIR%%/tests/fieldTest.php
+%%DATADIR%%/tests/expandWildcardTablesUnitTest.php
+%%DATADIR%%/tests/drush_testcase.inc
%%DATADIR%%/tests/drushScriptTest.php
-%%DATADIR%%/tests/quickDrupalTest.php
-%%DATADIR%%/tests/completetest.drush.inc
+%%DATADIR%%/tests/devel.xml
+%%DATADIR%%/tests/coreTest.php
+%%DATADIR%%/tests/contextTest.php
%%DATADIR%%/tests/completetestsite.drush.inc
-%%DATADIR%%/tests/queueTest.php
-%%DATADIR%%/tests/siteSetTest.php
+%%DATADIR%%/tests/completetest.drush.inc
+%%DATADIR%%/tests/completeTest.php
%%DATADIR%%/tests/commandUnitTest.php
-%%DATADIR%%/tests/hooks/magic_help_alter/magic.drush.inc
-%%DATADIR%%/tests/resources/example.profile
-%%DATADIR%%/tests/resources/create_node_types.php
-%%DATADIR%%/tests/resources/queue_script.php
-%%DATADIR%%/tests/siteSetUnitTest.php
-%%DATADIR%%/tests/watchdogTest.php
+%%DATADIR%%/tests/commandTest.php
%%DATADIR%%/tests/commandSpecificTest.php
-%%DATADIR%%/tests/generateMakeTest.php
-%%DATADIR%%/tests/imageTest.php
-%%DATADIR%%/tests/makeTest.php
%%DATADIR%%/tests/cacheCommandTest.php
-%%DATADIR%%/tests/shellAliasTest.php
%%DATADIR%%/tests/batchTest.php
-%%DATADIR%%/tests/siteSshTest.php
-%%DATADIR%%/tests/sqlConnectTest.php
-%%DATADIR%%/tests/releaseInfoTest.php
-%%DATADIR%%/tests/sqlSyncTest.php
-%%DATADIR%%/tests/variableTest.php
-%%DATADIR%%/tests/siteAliasTest.php
-%%DATADIR%%/tests/COVERAGE.txt
-%%DATADIR%%/tests/drush_testcase.inc
-%%DATADIR%%/tests/phpunit.xml.dist
-%%DATADIR%%/tests/userTest.php
-%%DATADIR%%/tests/README.txt
-%%DATADIR%%/tests/runner.php
-%%DATADIR%%/tests/archiveDumpTest.php
-%%DATADIR%%/tests/pmDownloadTest.php
-%%DATADIR%%/tests/contextTest.php
%%DATADIR%%/tests/backendTest.php
-%%DATADIR%%/tests/commandTest.php
-%%DATADIR%%/tests/pmUpdateCodeTest.php
-%%DATADIR%%/tests/pmEnDisUnListTest.php
-%%DATADIR%%/tests/coreTest.php
-%%DATADIR%%/tests/devel.xml
-%%DATADIR%%/tests/fieldTest.php
-%%DATADIR%%/tests/unit.drush.inc
-@dirrm %%DATADIR%%/includes
-@dirrm %%DATADIR%%/examples
-@dirrm %%DATADIR%%/docs
+%%DATADIR%%/tests/archiveDumpTest.php
+%%DATADIR%%/tests/README.txt
+%%DATADIR%%/tests/COVERAGE.txt
+%%DATADIR%%/misc/druplicon-no_color.txt
+%%DATADIR%%/misc/druplicon-color.txt
+%%DATADIR%%/lib/Yaml-2.2.1/.gitignore
+%%DATADIR%%/lib/Yaml-2.2.1/phpunit.xml.dist
+%%DATADIR%%/lib/Yaml-2.2.1/composer.json
+%%DATADIR%%/lib/Yaml-2.2.1/Yaml.php
+%%DATADIR%%/lib/Yaml-2.2.1/Unescaper.php
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/YamlTest.php
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/ParserTest.php
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/InlineTest.php
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/unindentedCollections.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/sfTests.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/sfQuotes.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/sfObjects.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/sfMergeKey.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/sfCompact.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/sfComments.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/index.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/escapedCharacters.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/embededPhp.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsTypeTransfers.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsSpecificationExamples.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsNullsAndEmpties.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsFoldedScalars.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsFlowCollections.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsErrorTests.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsDocumentSeparator.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsBlockMapping.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsBasicTests.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures/YtsAnchorAlias.yml
+%%DATADIR%%/lib/Yaml-2.2.1/Tests/DumperTest.php
+%%DATADIR%%/lib/Yaml-2.2.1/README.md
+%%DATADIR%%/lib/Yaml-2.2.1/Parser.php
+%%DATADIR%%/lib/Yaml-2.2.1/LICENSE
+%%DATADIR%%/lib/Yaml-2.2.1/Inline.php
+%%DATADIR%%/lib/Yaml-2.2.1/Exception/RuntimeException.php
+%%DATADIR%%/lib/Yaml-2.2.1/Exception/ParseException.php
+%%DATADIR%%/lib/Yaml-2.2.1/Exception/ExceptionInterface.php
+%%DATADIR%%/lib/Yaml-2.2.1/Exception/DumpException.php
+%%DATADIR%%/lib/Yaml-2.2.1/Escaper.php
+%%DATADIR%%/lib/Yaml-2.2.1/Dumper.php
+%%DATADIR%%/lib/Yaml-2.2.1/CHANGELOG.md
+%%DATADIR%%/lib/README.txt
+%%DATADIR%%/includes/sitealias.inc
+%%DATADIR%%/includes/output.inc
+%%DATADIR%%/includes/filesystem.inc
+%%DATADIR%%/includes/exec.inc
+%%DATADIR%%/includes/environment.inc
+%%DATADIR%%/includes/engines.inc
+%%DATADIR%%/includes/drush.inc
+%%DATADIR%%/includes/drupal.inc
+%%DATADIR%%/includes/dbtng.inc
+%%DATADIR%%/includes/context.inc
+%%DATADIR%%/includes/complete.inc
+%%DATADIR%%/includes/command.inc
+%%DATADIR%%/includes/cache.inc
+%%DATADIR%%/includes/bootstrap.inc
+%%DATADIR%%/includes/batch.inc
+%%DATADIR%%/includes/backend.inc
+%%DATADIR%%/drush_logo-black.png
+%%DATADIR%%/drush.php
+%%DATADIR%%/drush.info
+%%DATADIR%%/drush.complete.sh
+%%DATADIR%%/drush
+%%DATADIR%%/commands/user/user.drush.inc
+%%DATADIR%%/commands/sql/sync.sql.inc
+%%DATADIR%%/commands/sql/sql.drush.inc
+%%DATADIR%%/commands/runserver/runserver.drush.inc
+%%DATADIR%%/commands/runserver/runserver-prepend.php
+%%DATADIR%%/commands/runserver/runserver-drupal.inc
+%%DATADIR%%/commands/pm/version_control/svn.inc
+%%DATADIR%%/commands/pm/version_control/bzr.inc
+%%DATADIR%%/commands/pm/version_control/backup.inc
+%%DATADIR%%/commands/pm/updatestatus.pm.inc
+%%DATADIR%%/commands/pm/updatecode.pm.inc
+%%DATADIR%%/commands/pm/update_info/drupal_6.inc
+%%DATADIR%%/commands/pm/update_info/drupal.inc
+%%DATADIR%%/commands/pm/release_info/updatexml.inc
+%%DATADIR%%/commands/pm/pm.drush.inc
+%%DATADIR%%/commands/pm/package_handler/wget.inc
+%%DATADIR%%/commands/pm/package_handler/git_drupalorg.inc
+%%DATADIR%%/commands/pm/info.pm.inc
+%%DATADIR%%/commands/pm/download.pm.inc
+%%DATADIR%%/commands/make/make.utilities.inc
+%%DATADIR%%/commands/make/make.project.inc
+%%DATADIR%%/commands/make/make.drush.inc
+%%DATADIR%%/commands/make/make.download.inc
+%%DATADIR%%/commands/make/generate.make.inc
+%%DATADIR%%/commands/core/watchdog.drush.inc
+%%DATADIR%%/commands/core/variable.drush.inc
+%%DATADIR%%/commands/core/usage.drush.inc
+%%DATADIR%%/commands/core/topic.drush.inc
+%%DATADIR%%/commands/core/test.drush.inc
+%%DATADIR%%/commands/core/ssh.drush.inc
+%%DATADIR%%/commands/core/sitealias.drush.inc
+%%DATADIR%%/commands/core/site_install.drush.inc
+%%DATADIR%%/commands/core/shellalias.drush.inc
+%%DATADIR%%/commands/core/search.drush.inc
+%%DATADIR%%/commands/core/scratch.php
+%%DATADIR%%/commands/core/rsync.core.inc
+%%DATADIR%%/commands/core/role.drush.inc
+%%DATADIR%%/commands/core/queue.drush.inc
+%%DATADIR%%/commands/core/outputformat/yaml.inc
+%%DATADIR%%/commands/core/outputformat/variables.inc
+%%DATADIR%%/commands/core/outputformat/var_export.inc
+%%DATADIR%%/commands/core/outputformat/topics/table.html
+%%DATADIR%%/commands/core/outputformat/table.inc
+%%DATADIR%%/commands/core/outputformat/string.inc
+%%DATADIR%%/commands/core/outputformat/print_r.inc
+%%DATADIR%%/commands/core/outputformat/php.inc
+%%DATADIR%%/commands/core/outputformat/message.inc
+%%DATADIR%%/commands/core/outputformat/list.inc
+%%DATADIR%%/commands/core/outputformat/key_value.inc
+%%DATADIR%%/commands/core/outputformat/json.inc
+%%DATADIR%%/commands/core/outputformat/csv_or_string.inc
+%%DATADIR%%/commands/core/outputformat.drush.inc
+%%DATADIR%%/commands/core/notify.drush.inc
+%%DATADIR%%/commands/core/image.drush.inc
+%%DATADIR%%/commands/core/help.drush.inc
+%%DATADIR%%/commands/core/field.drush.inc
+%%DATADIR%%/commands/core/druplicon.drush.inc
+%%DATADIR%%/commands/core/drupal/update_7.inc
+%%DATADIR%%/commands/core/drupal/update_6.inc
+%%DATADIR%%/commands/core/drupal/update.inc
+%%DATADIR%%/commands/core/drupal/site_install_6.inc
+%%DATADIR%%/commands/core/drupal/site_install.inc
+%%DATADIR%%/commands/core/drupal/environment_7.inc
+%%DATADIR%%/commands/core/drupal/environment_6.inc
+%%DATADIR%%/commands/core/drupal/environment.inc
+%%DATADIR%%/commands/core/drupal/batch_6.inc
+%%DATADIR%%/commands/core/drupal/batch.inc
+%%DATADIR%%/commands/core/docs.drush.inc
+%%DATADIR%%/commands/core/core.drush.inc
+%%DATADIR%%/commands/core/cache.drush.inc
+%%DATADIR%%/commands/core/archive.drush.inc
+%%DATADIR%%/classes/DrushRole.php
+@dirrm %%DATADIR%%/tests/resources
+@dirrm %%DATADIR%%/tests/makefiles
+@dirrm %%DATADIR%%/tests/hooks/magic_help_alter
+@dirrm %%DATADIR%%/tests/hooks
+@dirrm %%DATADIR%%/tests
+@dirrm %%DATADIR%%/misc
+@dirrm %%DATADIR%%/lib/Yaml-2.2.1/Tests/Fixtures
+@dirrm %%DATADIR%%/lib/Yaml-2.2.1/Tests
+@dirrm %%DATADIR%%/lib/Yaml-2.2.1/Exception
+@dirrm %%DATADIR%%/lib/Yaml-2.2.1
@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/includes
@dirrm %%DATADIR%%/commands/user
@dirrm %%DATADIR%%/commands/sql
+@dirrm %%DATADIR%%/commands/runserver
@dirrm %%DATADIR%%/commands/pm/version_control
@dirrm %%DATADIR%%/commands/pm/update_info
-@dirrm %%DATADIR%%/commands/pm/package_handler
@dirrm %%DATADIR%%/commands/pm/release_info
+@dirrm %%DATADIR%%/commands/pm/package_handler
@dirrm %%DATADIR%%/commands/pm
+@dirrm %%DATADIR%%/commands/make
+@dirrm %%DATADIR%%/commands/core/outputformat/topics
+@dirrm %%DATADIR%%/commands/core/outputformat
@dirrm %%DATADIR%%/commands/core/drupal
@dirrm %%DATADIR%%/commands/core
-@dirrm %%DATADIR%%/commands/make
-@dirrm %%DATADIR%%/commands/runserver
@dirrm %%DATADIR%%/commands
-@dirrm %%DATADIR%%/tests/resources
-@dirrm %%DATADIR%%/tests/makefiles
-@dirrm %%DATADIR%%/tests/hooks/magic_help_alter
-@dirrm %%DATADIR%%/tests/hooks
-@dirrm %%DATADIR%%/tests
+@dirrm %%DATADIR%%/classes
@dirrm %%DATADIR%%