aboutsummaryrefslogtreecommitdiff
path: root/www/edbrowse
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2019-12-07 12:19:06 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2019-12-07 12:19:06 +0000
commit0130594fba2d4acb5ed3d1389025c2c11c660976 (patch)
tree8fc73ce416af7a47f0260af180472d09708aac8c /www/edbrowse
parentbb9ba2e4da5a68728469b827687cc44e0f0d9504 (diff)
downloadports-0130594fba2d4acb5ed3d1389025c2c11c660976.tar.gz
ports-0130594fba2d4acb5ed3d1389025c2c11c660976.zip
* delete: LIB_DEPENDS libtidy.so:www/tidy-lib
* delete: files/patch-src_html-tidy.c * add: post-patch to link the right library version PR: 242499 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=519204
Diffstat (limited to 'www/edbrowse')
-rw-r--r--www/edbrowse/Makefile6
-rw-r--r--www/edbrowse/files/patch-src_html-tidy.c11
2 files changed, 4 insertions, 13 deletions
diff --git a/www/edbrowse/Makefile b/www/edbrowse/Makefile
index 94582eeb8fc1..b853b607d43f 100644
--- a/www/edbrowse/Makefile
+++ b/www/edbrowse/Makefile
@@ -3,7 +3,7 @@
PORTNAME= edbrowse
DISTVERSIONPREFIX= v
DISTVERSION= 3.7.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www editors
MAINTAINER= alfix86@gmail.com
@@ -13,7 +13,6 @@ LICENSE= GPLv2
LIB_DEPENDS= libpcre.so:devel/pcre \
libcurl.so:ftp/curl \
- libtidy.so:www/tidy-lib \
libtidy5.so:www/tidy-html5 \
libduktape.so:lang/duktape-lib
@@ -30,6 +29,9 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} -e 's|set(TIDY_NAMES tidy)|set(TIDY_NAMES tidy5)|g' ${WRKSRC}/CMakeModules/FindTidy.cmake
+
do-install:
${INSTALL_MAN} ${WRKSRC}/doc/man-edbrowse-freebsd.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
${INSTALL_PROGRAM} ${WRKSRC}/edbrowse ${STAGEDIR}${PREFIX}/bin
diff --git a/www/edbrowse/files/patch-src_html-tidy.c b/www/edbrowse/files/patch-src_html-tidy.c
deleted file mode 100644
index e4d183a0eefb..000000000000
--- a/www/edbrowse/files/patch-src_html-tidy.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/html-tidy.c.orig 2019-12-06 06:26:39 UTC
-+++ src/html-tidy.c
-@@ -126,7 +126,7 @@ void html2nodes(const char *htmltext, bool startpage)
- tidyOptSetBool(tdoc, TidyDropEmptyElems, no);
- tidyOptSetBool(tdoc, TidyDropEmptyParas, no);
- tidyOptSetBool(tdoc, TidyLiteralAttribs, yes);
-- tidyOptSetBool(tdoc, TidyStyleTags, no);
-+ //tidyOptSetBool(tdoc, TidyStyleTags, no);
-
- tidySetCharEncoding(tdoc, (cons_utf8 ? "utf8" : "latin1"));
-