aboutsummaryrefslogtreecommitdiff
path: root/www/edbrowse
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-11-29 19:35:08 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-11-29 19:35:08 +0000
commit3a49c11641b3d570a6950208b1bf31f90d1482af (patch)
treeb0341624542dc5eacf240f042fca484c7a6c6312 /www/edbrowse
parentaef20687fcdc0d161a73030190809a7eaa40bd8a (diff)
downloadports-3a49c11641b3d570a6950208b1bf31f90d1482af.tar.gz
ports-3a49c11641b3d570a6950208b1bf31f90d1482af.zip
- Update to upstream version 3.5.1
- Use lang/spidermonkey24 instead of lang/spidermonkey17 - Use curl for mail handling PR: 195058 Submitted by: david.vionnet@vmailbox.org Reviewed by: riggs
Notes
Notes: svn path=/head/; revision=373639
Diffstat (limited to 'www/edbrowse')
-rw-r--r--www/edbrowse/Makefile6
-rw-r--r--www/edbrowse/distinfo4
-rw-r--r--www/edbrowse/files/patch-src-makefile.bsd25
-rw-r--r--www/edbrowse/pkg-plist1
4 files changed, 21 insertions, 15 deletions
diff --git a/www/edbrowse/Makefile b/www/edbrowse/Makefile
index 4f7ac07cd82c..e8383a974d42 100644
--- a/www/edbrowse/Makefile
+++ b/www/edbrowse/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= edbrowse
-PORTVERSION= 3.4.10
+PORTVERSION= 3.5.1
CATEGORIES= www editors
MASTER_SITES= http://the-brannons.com/edbrowse/ \
http://rithmomachia.org/edbrowse/
@@ -13,11 +13,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
- libmozjs185.so:${PORTSDIR}/lang/spidermonkey185 \
+ libmozjs-24.so:${PORTSDIR}/lang/spidermonkey24 \
libcurl.so:${PORTSDIR}/ftp/curl
USE_OPENSSL= yes
-USES= readline zip
+USES= compiler:c11 readline zip
OPTIONS_DEFINE= DOCS
diff --git a/www/edbrowse/distinfo b/www/edbrowse/distinfo
index 59da1ef49c96..90ac4c9369f9 100644
--- a/www/edbrowse/distinfo
+++ b/www/edbrowse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (edbrowse-3.4.10.zip) = 58089879c31b571792f76fc53c41374fcbe8386ea82fe451737ae72e8a78e826
-SIZE (edbrowse-3.4.10.zip) = 737798
+SHA256 (edbrowse-3.5.1.zip) = e379cffb1098cfedf56ceedaaa7e20064551a0737ad6cd8ad5124fdfb18d9a5f
+SIZE (edbrowse-3.5.1.zip) = 745277
diff --git a/www/edbrowse/files/patch-src-makefile.bsd b/www/edbrowse/files/patch-src-makefile.bsd
index 6b5b73661fa8..4c083ed16987 100644
--- a/www/edbrowse/files/patch-src-makefile.bsd
+++ b/www/edbrowse/files/patch-src-makefile.bsd
@@ -1,18 +1,25 @@
---- makefile.bsd.orig 2014-01-08 00:47:50.667199813 +0100
-+++ makefile.bsd 2014-01-08 00:50:43.955208907 +0100
-@@ -2,13 +2,13 @@
+--- makefile.bsd.orig 2014-09-24 06:50:37.000000000 +0200
++++ makefile.bsd 2014-11-15 21:16:45.051156527 +0100
+@@ -1,10 +1,11 @@
+ # This is the makefile for edbrowse under BSD Unix.
- # Flags for compilation.
- # I know - I set the Linux flag here, but it seems to work.
--CFLAGS = -I/usr/local/include -I/usr/local/include/js -DSYSBSD -DXP_UNIX
-+CFLAGS = -I${LOCALBASE}/include -I${LOCALBASE}/include/js -DSYSBSD -DXP_UNIX
+ # Flags for gcc compilation.
+-JS_CXXFLAGS =-I/usr/include/mozjs-24
++JS_CXXFLAGS = -I${LOCALBASE}/include/mozjs-24
+
+ # we need to only use the js flags when building with c++, so use CXXFLAGS
+-CXXFLAGS += $(JS_CXXFLAGS)
++CFLAGS += -I${LOCALBASE}/include
++CXXFLAGS += $(CFLAGS) $(JS_CXXFLAGS)
# Tell the dynamic linker to look in the pkg area.
LFLAGS = -s -Wl,--rpath -Wl,/usr/pkg/lib
+@@ -14,7 +15,7 @@
+ JSLIB = -lmozjs-24
# Libraries for edbrowse.
--LIBS = -L /usr/local/lib -lpcre -lm -lssl -ljs -lcrypto -lpthread -lcurl
-+LIBS = -L ${LOCALBASE}/lib -lpcre -lm -lssl -lmozjs185 -lcrypto -pthread -lcurl -lreadline
+-LDLIBS = -lpcre -lm -lssl $(JSLIB) -lcurl -lreadline -lncurses -lcrypto -lstdc++
++LIBS = -L${LOCALBASE}/lib -lpcre -lm -lssl $(JSLIB) -lcurl -lreadline -lncurses -lcrypto -lstdc++
# Make the dynamically linked executable program by default.
# Edbrowse executable.
diff --git a/www/edbrowse/pkg-plist b/www/edbrowse/pkg-plist
index b6f49b60c52b..d1997b9d2141 100644
--- a/www/edbrowse/pkg-plist
+++ b/www/edbrowse/pkg-plist
@@ -10,4 +10,3 @@ man/man1/edbrowse.1.gz
%%PORTDOCS%%%%DOCSDIR%%/ssl-certs
%%PORTDOCS%%%%DOCSDIR%%/usersguide.html
%%PORTDOCS%%%%DOCSDIR%%/usersguide_fr.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%