aboutsummaryrefslogtreecommitdiff
path: root/www/edbrowse
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2019-12-06 14:10:28 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2019-12-06 14:10:28 +0000
commitd70c70c2b96ef3f7ecb67688849abee243aac453 (patch)
treed30807e9dbefb89385aa15b4b9888aa23cf69f45 /www/edbrowse
parent4a7de8b9a9439f417278e6f39ed218dc6ac9c4d0 (diff)
downloadports-d70c70c2b96ef3f7ecb67688849abee243aac453.tar.gz
ports-d70c70c2b96ef3f7ecb67688849abee243aac453.zip
Fix crash issue, and bump version.
PR: 242471 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=519145
Diffstat (limited to 'www/edbrowse')
-rw-r--r--www/edbrowse/Makefile2
-rw-r--r--www/edbrowse/files/patch-src_html-tidy.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/edbrowse/Makefile b/www/edbrowse/Makefile
index bcc337676564..94582eeb8fc1 100644
--- a/www/edbrowse/Makefile
+++ b/www/edbrowse/Makefile
@@ -3,7 +3,7 @@
PORTNAME= edbrowse
DISTVERSIONPREFIX= v
DISTVERSION= 3.7.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www editors
MAINTAINER= alfix86@gmail.com
diff --git a/www/edbrowse/files/patch-src_html-tidy.c b/www/edbrowse/files/patch-src_html-tidy.c
new file mode 100644
index 000000000000..e4d183a0eefb
--- /dev/null
+++ b/www/edbrowse/files/patch-src_html-tidy.c
@@ -0,0 +1,11 @@
+--- src/html-tidy.c.orig 2019-12-06 06:26:39 UTC
++++ src/html-tidy.c
+@@ -126,7 +126,7 @@ void html2nodes(const char *htmltext, bool startpage)
+ tidyOptSetBool(tdoc, TidyDropEmptyElems, no);
+ tidyOptSetBool(tdoc, TidyDropEmptyParas, no);
+ tidyOptSetBool(tdoc, TidyLiteralAttribs, yes);
+- tidyOptSetBool(tdoc, TidyStyleTags, no);
++ //tidyOptSetBool(tdoc, TidyStyleTags, no);
+
+ tidySetCharEncoding(tdoc, (cons_utf8 ? "utf8" : "latin1"));
+