aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /www/epiphany/Makefile
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
Presenting GNOME 2.8 for FreeBSD (2.8.1 to be exact).
This release notes detailing all of the new goodies in GNOME 2.8 can be found at http://www.gnome.org/start/2.8/notes/, and the list of what was fixed in GNOME 2.8.1 can be found at http://lists.gnome.org/archives/gnome-announce-list/2004-October/msg00056.html. This release, as well as all of our others, would not have been possible without the great efforts of our FreeBSD GNOME Team. The list of current members can be found at http://www.freebsd.org/gnome/contact.html (including our newest member, Michael Johnson <ahze@FreeBSD.org>). Special thanks also goes out to all of the loyal FreeBSD GNOME users that put up with crashes and hangs to test and debug GNOME on FreeBSD. We would especially like to thank those users that provided patches for GNOME 2.7 and 2.8: Franz Klammer <klammer@webonaut.com> Piotr Smyrak <piotr.smyrak@heron.pl> Radek Kozlowski <radek@raadradd.com> Khairil Yusof <kaeru@pd.jaring.my> Yasuda Keisuke <kysd@po.harenet.ne.jp> Tom McLaughlin <tmclaugh@sdf.lonestar.org> Vladimir Grebenschikov <vova@fbsd.ru> GNOME 2.8 also features a new, FreeBSD-specific splashscreen that was designed by jimmac for GNOME 2.8, then daemonized by Franz Klammer <klammer@webonaut.com> and Radek Kozlowski <radek@raadradd.com>. As with GNOME 2.6, you cannot just "portupgrade" to GNOME 2.8. There is a script provided at http://www.marcuscom.com/downloads/gnome_upgrade28.sh that will aid in the upgrade process. Full documentation on the GNOME 2.8 upgrade is coming following this commit. From all of us at FreeBSD GNOME, ENJOY!
Notes
Notes: svn path=/head/; revision=121068
Diffstat (limited to 'www/epiphany/Makefile')
-rw-r--r--www/epiphany/Makefile40
1 files changed, 17 insertions, 23 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index cebc7e3d8fe4..76797e5c5255 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= epiphany
-PORTVERSION= 1.2.8
+PORTVERSION= 1.4.4
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.4
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -36,8 +36,7 @@ HEADERS_SUFX=
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
-WANT_GNOME= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui desktopfileutils
USE_LIBTOOL_VER=15
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -46,26 +45,13 @@ CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUF
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+GCONF_SCHEMAS= epiphany-lockdown.schemas epiphany.schemas
+
FLASHPLAYER= ${LOCALBASE}/lib/libflashplayer.so.1
PLIST_SUB+= EPHY_VERSION="${PORTVERSION:C/\.[0-9]+$//}"
-.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
-.undef WITHOUT_GNOME
-.undef WITHOUT_ALL
-WITH_GNOME= yes
-.endif
-
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mnautilus2}!=""
-USE_GNOME+= nautilus2
-CONFIGURE_ARGS+= --enable-nautilus-view
-PLIST_SUB+= NAUTILUS=""
-.else
-CONFIGURE_ARGS+= --enable-nautilus-view=no
-PLIST_SUB+= NAUTILUS="@comment "
-.endif
-
.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.
@@ -85,21 +71,29 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g; \
- s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g ; \
+ s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g ; \
+ s|$$MOZILLA-gtkmozembed|$$MOZILLA-gtkmozembed${HEADERS_SUFX}|g ; \
+ s|$$MOZILLA-xpcom|$$MOZILLA-xpcom${HEADERS_SUFX}|g' \
+ ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
post-configure:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g ; \
s|%%MOZILLA%%|${MOZILLA}|g ; \
- s|%%FLASHPLAYER%%|${FLASHPLAYER}|g' ${WRKSRC}/src/epiphany
+ s|%%FLASHPLAYER%%|${FLASHPLAYER}|g' <${FILESDIR}/epiphany \
+ > ${WRKDIR}/epiphany
pre-install:
@-${X11BASE}/bin/gconftool-2 --shutdown
+post-install:
+ @${MV} -f ${PREFIX}/bin/epiphany ${PREFIX}/bin/epiphany-bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/epiphany ${PREFIX}/bin
+
.include <bsd.port.post.mk>