aboutsummaryrefslogtreecommitdiff
path: root/www/falkon
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2018-12-30 14:15:54 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2018-12-30 14:15:54 +0000
commit618f3dd0792126ac83bb5930ba62b99d7931b062 (patch)
tree8015b15002c74c925a18f0385510aa0aadb2544b /www/falkon
parent0065c7d4abe540d859e1177ad5483b47ac869fc6 (diff)
downloadports-618f3dd0792126ac83bb5930ba62b99d7931b062.tar.gz
ports-618f3dd0792126ac83bb5930ba62b99d7931b062.zip
Add OPTIONS to some kde@ ports.
For best runtime performance (e.g. a fully functional desktop), users will need a pinentry application -- pinentry-qt fits best into the KDE desktop, but it could be a different one -- and sound output. Pick a default backend and some OSS plugins to make that happen. These are OPTIONS so the users interested in a minimal desktop or one with different audio needs can build suitable packages themselves. Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D18680
Notes
Notes: svn path=/head/; revision=488719
Diffstat (limited to 'www/falkon')
-rw-r--r--www/falkon/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/falkon/Makefile b/www/falkon/Makefile
index b8464b353a0b..173c6a0373cd 100644
--- a/www/falkon/Makefile
+++ b/www/falkon/Makefile
@@ -2,7 +2,7 @@
PORTNAME= falkon
DISTVERSION= 3.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= KDE/stable/falkon/${DISTVERSION:R}/src/
@@ -21,11 +21,16 @@ USE_XORG= xcb
USE_LDCONFIG= yes
-OPTIONS_DEFINE= GNOMEKEYRING
+OPTIONS_DEFINE= GNOMEKEYRING ALSA
+OPTIONS_DEFAULT= ALSA
OPTIONS_SUB= YES
GNOMEKEYRING_CMAKE_BOOL= BUILD_KEYRING
GNOMEKEYRING_USE= GNOME=glib20
GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
+# Need the plugins to get sound, otherwise messages that the
+# pcm_oss plugin can't be opened.
+ALSA_RUN_DEPENDS= alsa-plugins>=0:audio/alsa-plugins
+
.include <bsd.port.mk>