aboutsummaryrefslogtreecommitdiff
path: root/www/fcgiwrap
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2020-03-28 17:49:36 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2020-03-28 17:49:36 +0000
commit04edbf430464083f4bb5c3055602836e3744a666 (patch)
tree1b595b365651c8b87f789054d58d36e3c3d92f17 /www/fcgiwrap
parenteecabe3e4a58e55d1899644d19c2e7772de3272e (diff)
downloadports-04edbf430464083f4bb5c3055602836e3744a666.tar.gz
ports-04edbf430464083f4bb5c3055602836e3744a666.zip
www/fcgiwrap: fix IPv6 support
Extend existing patch to fix IPv6 support. Bump PORTREVISION The fix zero-out the sockaddr structure before using it as a sockaddr_in6 structure as explained by IEEE Std 1003.1. The patch was upstremed : https://github.com/gnosek/fcgiwrap/pull/51 PR: 243721 Reported by: <olaf@zaplinski.de>
Notes
Notes: svn path=/head/; revision=529749
Diffstat (limited to 'www/fcgiwrap')
-rw-r--r--www/fcgiwrap/Makefile2
-rw-r--r--www/fcgiwrap/files/fcgiwrap.in2
-rw-r--r--www/fcgiwrap/files/patch-fcgiwrap.c18
3 files changed, 15 insertions, 7 deletions
diff --git a/www/fcgiwrap/Makefile b/www/fcgiwrap/Makefile
index aa2d6f887365..24e7876028c6 100644
--- a/www/fcgiwrap/Makefile
+++ b/www/fcgiwrap/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fcgiwrap
PORTVERSION= 1.1.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= www
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/www/fcgiwrap/files/fcgiwrap.in b/www/fcgiwrap/files/fcgiwrap.in
index a0306721c703..9ea821d3f418 100644
--- a/www/fcgiwrap/files/fcgiwrap.in
+++ b/www/fcgiwrap/files/fcgiwrap.in
@@ -39,7 +39,7 @@
# fcgiwrap_myserver_group="mygroup"
# fcgiwrap_myotherserver_socket="unix:/var/run/fcgiwrap.myotherserver.socket"
# fcgiwrap_myotherserver_user="myotheruser"
-# fcgiwrap_myotherserver_grup="myothergroup"
+# fcgiwrap_myotherserver_group="myothergroup"
# fcgiwrap_myserver_socket_mode="0775"
# fcgiwrap_myotherserver_flags="" # No flags for this profile.
diff --git a/www/fcgiwrap/files/patch-fcgiwrap.c b/www/fcgiwrap/files/patch-fcgiwrap.c
index f4d280093de0..88e6605502b0 100644
--- a/www/fcgiwrap/files/patch-fcgiwrap.c
+++ b/www/fcgiwrap/files/patch-fcgiwrap.c
@@ -87,7 +87,15 @@
char *p = url;
char *q;
int fd;
-@@ -751,6 +785,7 @@ invalid_url:
+@@ -685,6 +719,7 @@ static int setup_socket(char *url) {
+ struct sockaddr_in6 sa_in6;
+ } sa;
+
++ memset(&sa, 0, sizeof(sa));
+ if (!strncmp(p, "unix:", sizeof("unix:") - 1)) {
+ p += sizeof("unix:") - 1;
+
+@@ -751,6 +786,7 @@ invalid_url:
return -1;
}
@@ -95,7 +103,7 @@
return listen_on_fd(fd);
}
-@@ -758,9 +793,10 @@ int main(int argc, char **argv)
+@@ -758,9 +794,10 @@ int main(int argc, char **argv)
{
int nchildren = 1;
char *socket_url = NULL;
@@ -107,7 +115,7 @@
switch (c) {
case 'f':
stderr_to_fastcgi++;
-@@ -773,6 +809,7 @@ int main(int argc, char **argv)
+@@ -773,6 +810,7 @@ int main(int argc, char **argv)
" -c <number>\t\tNumber of processes to prefork\n"
" -s <socket_url>\tSocket to bind to (say -s help for help)\n"
" -h\t\t\tShow this help message and exit\n"
@@ -115,7 +123,7 @@
"\nReport bugs to Grzegorz Nosek <"PACKAGE_BUGREPORT">.\n"
PACKAGE_NAME" home page: <http://nginx.localdomain.pl/wiki/FcgiWrap>\n",
argv[0]
-@@ -784,8 +821,14 @@ int main(int argc, char **argv)
+@@ -784,8 +822,14 @@ int main(int argc, char **argv)
case 's':
socket_url = strdup(optarg);
break;
@@ -131,7 +139,7 @@
fprintf(stderr, "Option -%c requires an argument.\n", optopt);
else if (isprint(optopt))
fprintf(stderr, "Unknown option `-%c'.\n", optopt);
-@@ -808,13 +851,24 @@ int main(int argc, char **argv)
+@@ -808,13 +852,24 @@ int main(int argc, char **argv)
} else
#endif
if (socket_url) {