aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
commitf92079c61ea2516fd5b1514bae10c743ba63b699 (patch)
tree1e9acf477fa72cf7c888cc484c96bd4f207a487a /www/firefox-esr
parent397fa72062e7ed8fab7c8a395a1f9475d9723709 (diff)
downloadports-f92079c61ea2516fd5b1514bae10c743ba63b699.tar.gz
ports-f92079c61ea2516fd5b1514bae10c743ba63b699.zip
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile6
-rw-r--r--www/firefox-esr/distinfo4
-rw-r--r--www/firefox-esr/files/patch-bug102649968
-rw-r--r--www/firefox-esr/files/patch-bug104179570
-rw-r--r--www/firefox-esr/files/patch-bug70217935
-rw-r--r--www/firefox-esr/files/patch-bug77971372
-rw-r--r--www/firefox-esr/files/patch-bug93873035
-rw-r--r--www/firefox-esr/files/patch-ipc-chromium-Makefile.in13
-rw-r--r--www/firefox-esr/files/patch-ipc-chromium-src-base-message_pump_libevent.cc11
-rw-r--r--www/firefox-esr/files/patch-z-bug102682813
10 files changed, 298 insertions, 29 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 74e3e8a3e01f..a920ef61b548 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 24.6.0
-PORTREVISION= 2
+DISTVERSION= 24.7.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source
@@ -32,6 +31,7 @@ USE_AUTOTOOLS= autoconf213:env
USE_PYTHON_BUILD=2
OBJDIR_BUILD= # in-tree build broken after bug 789837
USE_GECKO= gecko
+CPE_PRODUCT= ${PORTNAME}_esr
CONFLICTS= firefox-2[0-35-9].* firefox-1[1-689].*
MOZ_PKGCONFIG_FILES= # empty
USE_MOZILLA= # empty
@@ -59,7 +59,7 @@ MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
WRKSRC:= ${WRKDIR}/mozilla-esr24
.if ${PORT_OPTIONS:MALSA}
-BUILD_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
+RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
.endif
post-extract:
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index 8137a3cde37b..ff44c811e43b 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-24.6.0esr.source.tar.bz2) = 02ee0424ddefd912768a3ae700a4581053ef68f9dea46c34e43e833c119289e4
-SIZE (firefox-24.6.0esr.source.tar.bz2) = 119465935
+SHA256 (firefox-24.7.0esr.source.tar.bz2) = 079b6021f153ba11658cefe41d467e25357cd78e84d3d66c6abcfecb5a00121f
+SIZE (firefox-24.7.0esr.source.tar.bz2) = 119967111
diff --git a/www/firefox-esr/files/patch-bug1026499 b/www/firefox-esr/files/patch-bug1026499
new file mode 100644
index 000000000000..e446f22c64cf
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1026499
@@ -0,0 +1,68 @@
+commit 8d0efe4
+Author: Martin Husemann <martin@NetBSD.org>
+Date: Wed Jun 18 18:12:22 2014 +0200
+
+ Bug 1026499 - Use MOZ_ALIGNED_DECL to declare union members in ipdl value declarations. r=bsmedberg
+---
+ ipc/ipdl/ipdl/cxx/ast.py | 7 ++++---
+ ipc/ipdl/ipdl/cxx/cgen.py | 5 ++++-
+ ipc/ipdl/ipdl/lower.py | 2 +-
+ 4 files changed, 10 insertions(+), 5 deletions(-)
+
+diff --git ipc/ipdl/ipdl/cxx/ast.py ipc/ipdl/ipdl/cxx/ast.py
+index 3180a65..c2d945b 100644
+--- ipc/ipdl/ipdl/cxx/ast.py
++++ ipc/ipdl/ipdl/cxx/ast.py
+@@ -336,12 +336,13 @@ Type.VOID = Type('void')
+ Type.VOIDPTR = Type('void', ptr=1)
+
+ class TypeArray(Node):
+- def __init__(self, basetype, nmemb):
+- '''the type |basetype DECLNAME[nmemb]|. |nmemb| is an Expr'''
++ def __init__(self, basetype, nmemb, alignType):
++ '''the type |basetype DECLNAME[nmemb]|. |nmemb| is an Expr, |alignType| is a type'''
+ self.basetype = basetype
+ self.nmemb = nmemb
++ self.alignType = alignType
+ def __deepcopy__(self, memo):
+- return TypeArray(deepcopy(self.basetype, memo), nmemb)
++ return TypeArray(deepcopy(self.basetype, memo), nmemb, alignType)
+
+ class TypeEnum(Node):
+ def __init__(self, name=None):
+diff --git ipc/ipdl/ipdl/cxx/cgen.py ipc/ipdl/ipdl/cxx/cgen.py
+index 48b0988..bc914cf 100644
+--- ipc/ipdl/ipdl/cxx/cgen.py
++++ ipc/ipdl/ipdl/cxx/cgen.py
+@@ -101,6 +101,7 @@ class CxxCodeGen(CodePrinter, Visitor):
+ def visitDecl(self, d):
+ # C-syntax arrays make code generation much more annoying
+ if isinstance(d.type, TypeArray):
++ self.write('MOZ_ALIGNED_DECL(')
+ d.type.basetype.accept(self)
+ else:
+ d.type.accept(self)
+@@ -111,7 +112,9 @@ class CxxCodeGen(CodePrinter, Visitor):
+ if isinstance(d.type, TypeArray):
+ self.write('[')
+ d.type.nmemb.accept(self)
+- self.write(']')
++ self.write('], MOZ_ALIGNOF(')
++ d.type.alignType.accept(self)
++ self.write('))')
+
+ def visitParam(self, p):
+ self.visitDecl(p)
+diff --git ipc/ipdl/ipdl/lower.py ipc/ipdl/ipdl/lower.py
+index e97a34c..9360f3c 100644
+--- ipc/ipdl/ipdl/lower.py
++++ ipc/ipdl/ipdl/lower.py
+@@ -768,7 +768,7 @@ IPDL union type."""
+ if self.recursive:
+ return self.ptrToType()
+ else:
+- return TypeArray(Type('char'), ExprSizeof(self.internalType()))
++ return TypeArray(Type('char'), ExprSizeof(self.internalType()), self.internalType())
+
+ def unionValue(self):
+ # NB: knows that Union's storage C union is named |mValue|
diff --git a/www/firefox-esr/files/patch-bug1041795 b/www/firefox-esr/files/patch-bug1041795
new file mode 100644
index 000000000000..ba567f83dcac
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1041795
@@ -0,0 +1,70 @@
+diff --git config/rules.mk config/rules.mk
+index 4d67eda..783942f 100644
+--- config/rules.mk
++++ config/rules.mk
+@@ -858,7 +858,7 @@ ifdef DTRACE_PROBE_OBJ
+ ifndef DTRACE_LIB_DEPENDENT
+ NON_DTRACE_OBJS := $(filter-out $(DTRACE_PROBE_OBJ),$(OBJS))
+ $(DTRACE_PROBE_OBJ): $(NON_DTRACE_OBJS)
+- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
++ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
+ endif
+ endif
+ endif
+@@ -876,7 +876,7 @@ ifndef INCREMENTAL_LINKER
+ endif
+ ifdef DTRACE_LIB_DEPENDENT
+ ifndef XP_MACOSX
+- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
++ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
+ endif
+ $(EXPAND_MKSHLIB) $(SHLIB_LDSTARTFILE) $(OBJS) $(SUB_SHLOBJS) $(DTRACE_PROBE_OBJ) $(MOZILLA_PROBE_LIBS) $(RESFILE) $(LDFLAGS) $(WRAP_LDFLAGS) $(SHARED_LIBRARY_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS) $(EXTRA_LIBS) $(DEF_FILE) $(SHLIB_LDENDFILE) $(if $(LIB_IS_C_ONLY),,$(STLPORT_LIBS))
+ @$(RM) $(DTRACE_PROBE_OBJ)
+diff --git js/src/config/rules.mk js/src/config/rules.mk
+index 4d67eda..783942f 100644
+--- js/src/config/rules.mk
++++ js/src/config/rules.mk
+@@ -858,7 +858,7 @@ ifdef DTRACE_PROBE_OBJ
+ ifndef DTRACE_LIB_DEPENDENT
+ NON_DTRACE_OBJS := $(filter-out $(DTRACE_PROBE_OBJ),$(OBJS))
+ $(DTRACE_PROBE_OBJ): $(NON_DTRACE_OBJS)
+- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
++ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
+ endif
+ endif
+ endif
+@@ -876,7 +876,7 @@ ifndef INCREMENTAL_LINKER
+ endif
+ ifdef DTRACE_LIB_DEPENDENT
+ ifndef XP_MACOSX
+- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
++ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
+ endif
+ $(EXPAND_MKSHLIB) $(SHLIB_LDSTARTFILE) $(OBJS) $(SUB_SHLOBJS) $(DTRACE_PROBE_OBJ) $(MOZILLA_PROBE_LIBS) $(RESFILE) $(LDFLAGS) $(WRAP_LDFLAGS) $(SHARED_LIBRARY_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS) $(EXTRA_LIBS) $(DEF_FILE) $(SHLIB_LDENDFILE) $(if $(LIB_IS_C_ONLY),,$(STLPORT_LIBS))
+ @$(RM) $(DTRACE_PROBE_OBJ)
+diff --git js/src/Makefile.in js/src/Makefile.in
+index 28ca5e8..96793d7 100644
+--- js/src/Makefile.in
++++ js/src/Makefile.in
+@@ -342,7 +342,7 @@ endif
+
+ ifdef HAVE_DTRACE
+ $(CURDIR)/javascript-trace.h: $(srcdir)/devtools/javascript-trace.d
+- dtrace -h -s $(srcdir)/devtools/javascript-trace.d -o javascript-trace.h.in
++ dtrace -x nolibs -h -s $(srcdir)/devtools/javascript-trace.d -o javascript-trace.h.in
+ sed -e 's/if _DTRACE_VERSION/ifdef INCLUDE_MOZILLA_DTRACE/' \
+ -e '/const/!s/char \*/const char */g' \
+ javascript-trace.h.in > javascript-trace.h
+diff --git probes/Makefile.in probes/Makefile.in
+index 6d18f34..deec83f 100644
+--- probes/Makefile.in
++++ probes/Makefile.in
+@@ -7,7 +7,7 @@ export:: $(DIST)/include/mozilla-trace.h
+
+ # Replace _DTRACE_VERSION with INCLUDE_MOZILLA_DTRACE
+ $(DIST)/include/mozilla-trace.h: mozilla-trace.d Makefile
+- dtrace -h -s $(srcdir)/mozilla-trace.d -o mozilla-trace.h.tmp
++ dtrace -x nolibs -h -s $(srcdir)/mozilla-trace.d -o mozilla-trace.h.tmp
+ sed -e 's/if _DTRACE_VERSION/ifdef INCLUDE_MOZILLA_DTRACE/' \
+ mozilla-trace.h.tmp > $(DIST)/include/mozilla-trace.h
+ rm mozilla-trace.h.tmp
diff --git a/www/firefox-esr/files/patch-bug702179 b/www/firefox-esr/files/patch-bug702179
new file mode 100644
index 000000000000..5754b607ad57
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug702179
@@ -0,0 +1,35 @@
+commit 6ddaacd
+Author: Ginn Chen <ginn.chen@oracle.com>
+Date: Wed Nov 30 07:23:46 2011 +0800
+
+ Bug 702179 dtrace probes are not installed on Solaris with static js lib r=glandium
+---
+ configure.in | 2 +-
+ js/src/Makefile.in | 2 --
+ 2 files changed, 1 insertion(+), 3 deletions(-)
+
+diff --git configure.in configure.in
+index 66549c1..75b848d 100644
+--- configure.in
++++ configure.in
+@@ -966,7 +966,7 @@ MOZ_BZ2_LIBS='$(call EXPAND_LIBNAME_PATH,bz2,$(DEPTH)/modules/libbz2/src)'
+ MOZ_PNG_CFLAGS="-I$_objdir/dist/include" # needed for freetype compilation
+ MOZ_PNG_LIBS='$(call EXPAND_LIBNAME_PATH,mozpng,$(DEPTH)/media/libpng)'
+
+-MOZ_JS_STATIC_LIBS='$(call EXPAND_LIBNAME_PATH,js_static,$(LIBXUL_DIST)/lib)'
++MOZ_JS_STATIC_LIBS='$(call EXPAND_LIBNAME_PATH,js_static,$(DEPTH)/js/src)'
+ MOZ_JS_SHARED_LIBS='$(call EXPAND_LIBNAME_PATH,mozjs,$(LIBXUL_DIST)/lib)'
+ MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin -Wl,-rpath-link,$(prefix)/lib'
+ XPCOM_FROZEN_LDOPTS='$(call EXPAND_LIBNAME_PATH,xul mozalloc,$(LIBXUL_DIST)/bin)'
+diff --git js/src/Makefile.in js/src/Makefile.in
+index e28160a..28ca5e8 100644
+--- js/src/Makefile.in
++++ js/src/Makefile.in
+@@ -35,7 +35,6 @@ ifdef JS_SHARED_LIBRARY
+ FORCE_SHARED_LIB = 1
+ endif
+ FORCE_STATIC_LIB = 1
+-DIST_INSTALL = 1
+
+ ###############################################
+ # BEGIN include sources for low-level code shared with mfbt
diff --git a/www/firefox-esr/files/patch-bug779713 b/www/firefox-esr/files/patch-bug779713
new file mode 100644
index 000000000000..1398d36f6a15
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug779713
@@ -0,0 +1,72 @@
+diff --git mfbt/Util.h mfbt/Util.h
+index e0843ca..353ec36 100644
+--- mfbt/Util.h
++++ mfbt/Util.h
+@@ -19,6 +19,13 @@
+
+ namespace mozilla {
+
++#if defined(MOZ_HAVE_CXX11_ALIGNAS)
++#define MOZ_ALIGNOF(T) alignof(T)
++#elif defined(__GNUC__)
++#define MOZ_ALIGNOF(T) __alignof__(T)
++#elif defined(_MSC_VER)
++#define MOZ_ALIGNOF(T) __alignof(T)
++#else
+ /*
+ * This class, and the corresponding macro MOZ_ALIGNOF, figure out how many
+ * bytes of alignment a given type needs.
+@@ -37,6 +44,7 @@ class AlignmentFinder
+ };
+
+ #define MOZ_ALIGNOF(T) mozilla::AlignmentFinder<T>::alignment
++#endif
+
+ /*
+ * Declare the MOZ_ALIGNED_DECL macro for declaring aligned types.
+@@ -48,7 +56,10 @@ class AlignmentFinder
+ * will declare a two-character array |arr| aligned to 8 bytes.
+ */
+
+-#if defined(__GNUC__)
++#if defined(MOZ_HAVE_CXX11_ALIGNAS)
++# define MOZ_ALIGNED_DECL(_type, _align) \
++ alignas(_align) _type
++#elif defined(__GNUC__)
+ # define MOZ_ALIGNED_DECL(_type, _align) \
+ _type __attribute__((aligned(_align)))
+ #elif defined(_MSC_VER)
+diff --git mfbt/Attributes.h mfbt/Attributes.h
+index d317766..ddb13da 100644
+--- mfbt/Attributes.h
++++ mfbt/Attributes.h
+@@ -67,6 +67,9 @@
+ # ifndef __has_extension
+ # define __has_extension __has_feature /* compatibility, for older versions of clang */
+ # endif
++# if __has_extension(cxx_alignas)
++# define MOZ_HAVE_CXX11_ALIGNAS
++# endif
+ # if __has_extension(cxx_constexpr)
+ # define MOZ_HAVE_CXX11_CONSTEXPR
+ # endif
+@@ -85,6 +88,9 @@
+ # endif
+ #elif defined(__GNUC__)
+ # if defined(__GXX_EXPERIMENTAL_CXX0X__) || __cplusplus >= 201103L
++# if MOZ_GCC_VERSION_AT_LEAST(4, 8, 0)
++# define MOZ_HAVE_CXX11_ALIGNAS
++# endif
+ # if MOZ_GCC_VERSION_AT_LEAST(4, 7, 0)
+ # define MOZ_HAVE_CXX11_OVERRIDE
+ # define MOZ_HAVE_CXX11_FINAL final
+@@ -102,6 +108,9 @@
+ # define MOZ_HAVE_NEVER_INLINE __attribute__((noinline))
+ # define MOZ_HAVE_NORETURN __attribute__((noreturn))
+ #elif defined(_MSC_VER)
++# if _MSC_VER >= 1800
++# define MOZ_HAVE_CXX11_ALIGNAS
++# endif
+ # if _MSC_VER >= 1700
+ # define MOZ_HAVE_CXX11_FINAL final
+ # else
diff --git a/www/firefox-esr/files/patch-bug938730 b/www/firefox-esr/files/patch-bug938730
new file mode 100644
index 000000000000..ac444b228ae6
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug938730
@@ -0,0 +1,35 @@
+commit 1961aa2
+Author: Kai Engert <kaie@kuix.de>
+Date: Wed Nov 20 20:25:12 2013 +0100
+
+ Bug 938730 - avoid mix of memory allocators (crashes) when using system sqlite, r=asuth
+---
+ storage/src/Makefile.in | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git storage/src/Makefile.in storage/src/Makefile.in
+index 9418640..c7391ed 100644
+--- storage/src/Makefile.in
++++ storage/src/Makefile.in
+@@ -6,14 +6,21 @@
+ # Don't use the jemalloc allocator on Android, because we can't guarantee
+ # that Gecko will configure sqlite before it is first used (bug 730495).
+ #
++# Don't use the jemalloc allocator when using system sqlite. Linked in libraries
++# (such as NSS) might trigger an initialization of sqlite and allocation
++# of memory using the default allocator, prior to the storage service
++# registering its allocator, causing memory management failures (bug 938730).
++#
+ # Note: On Windows our sqlite build assumes we use jemalloc. If you disable
+ # MOZ_STORAGE_MEMORY on Windows, you will also need to change the "ifdef
+ # MOZ_MEMORY" options in db/sqlite3/src/Makefile.in.
+ ifdef MOZ_MEMORY
++ifndef MOZ_NATIVE_SQLITE
+ ifneq ($(OS_TARGET), Android)
+ DEFINES += -DMOZ_STORAGE_MEMORY
+ endif
+ endif
++endif
+
+ # For nsDependentJSString
+ LOCAL_INCLUDES = \
diff --git a/www/firefox-esr/files/patch-ipc-chromium-Makefile.in b/www/firefox-esr/files/patch-ipc-chromium-Makefile.in
deleted file mode 100644
index 0e20edf2ee37..000000000000
--- a/www/firefox-esr/files/patch-ipc-chromium-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- ipc/chromium/Makefile.in~
-+++ ipc/chromium/Makefile.in
-@@ -55,9 +60,7 @@ vpath %.c \
- $(srcdir)/src/third_party/libevent \
- $(NULL)
- else # } else {
--# message_pump_libevent.cc includes third_party/libevent/event.h,
--# which we put in $(DIST), see export rule below
--LOCAL_INCLUDES += -I$(DIST)
-+LOCAL_INCLUDES += $(filter %/compat, $(MOZ_LIBEVENT_CFLAGS))
- endif # }
-
- vpath %.cc \
diff --git a/www/firefox-esr/files/patch-ipc-chromium-src-base-message_pump_libevent.cc b/www/firefox-esr/files/patch-ipc-chromium-src-base-message_pump_libevent.cc
deleted file mode 100644
index 02b6a5e90eca..000000000000
--- a/www/firefox-esr/files/patch-ipc-chromium-src-base-message_pump_libevent.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- ipc/chromium/src/base/message_pump_libevent.cc~
-+++ ipc/chromium/src/base/message_pump_libevent.cc
-@@ -16,7 +16,7 @@
- #include "base/scoped_ptr.h"
- #include "base/time.h"
- #include "nsDependentSubstring.h"
--#include "third_party/libevent/event.h"
-+#include "event.h"
-
- // Lifecycle of struct event
- // Libevent uses two main data structures:
diff --git a/www/firefox-esr/files/patch-z-bug1026828 b/www/firefox-esr/files/patch-z-bug1026828
new file mode 100644
index 000000000000..5d2020cd091f
--- /dev/null
+++ b/www/firefox-esr/files/patch-z-bug1026828
@@ -0,0 +1,13 @@
+diff --git storage/src/Makefile.in storage/src/Makefile.in
+index 4cd2551..5c40536 100644
+--- storage/src/Makefile.in
++++ storage/src/Makefile.in
+@@ -31,7 +31,7 @@ endif
+ # MOZ_STORAGE_MEMORY on Windows, you will also need to change the "ifdef
+ # MOZ_MEMORY" options in db/sqlite3/src/Makefile.in.
+ ifdef MOZ_MEMORY
+-ifndef MOZ_NATIVE_SQLITE
++ifneq (,$(not $(MOZ_NATIVE_SQLITE))$(MOZ_NATIVE_JEMALLOC))
+ ifneq ($(OS_TARGET), Android)
+ DEFINES += -DMOZ_STORAGE_MEMORY
+ endif