aboutsummaryrefslogtreecommitdiff
path: root/www/firefox15/files/patch-gfx-src-gtk-Makefile.in
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-08-28 07:59:05 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-08-28 07:59:05 +0000
commit0083ef4403a5409b575af728a51b7caf9603b374 (patch)
tree3c67b88f3dedcf171bb748da660c469946a2706f /www/firefox15/files/patch-gfx-src-gtk-Makefile.in
parent9e389814c321a23b61eb0beb65d8994791245073 (diff)
- Make portlint happier.
- Add Java 5 plugins support. [1] - Use system's libm (/usr/src/lib/msun), nss, nspr and etc. Also, do not extract those. Better explain, use external dependencies. [1] - Teach firefox-config and *.pc files for nspr that will making other third apps to buildable like epiphany, vlc-devel's mozilla plugins and etc. Have been tested with full GNOME 2.11.x build too. - Add four patches: [1] patch-bugzilla243151: https://bugzilla.mozilla.org/show_bug.cgi?id=243151 patch-jsosdep: Fix the FreeBSD define patch-oji-threads: 64-bit wide pthread_t patch-xptcinvoke_x86_64_linux: Setting a possibly uninitialized variable (value). - Fix a crash that can occur using gtk+-2.7 and possibly 2.6.10 when closing windows. https://bugzilla.mozilla.org/show_bug.cgi?id=3002 [2] - Get rid of FIREFOX and FF_VER, best to use PORTNAME and PORTVERSION varibles that are arleady exist and lesser complicate. - Change all hardcore of 'firefox' to PORTNAME. - Change a manual loop for patch all.js to find(1), so we can sleep on it. Submitted by: mi [1], marcus [2] Reviewed by: my team, FreeBSD GNOME Team. Tested by: many
Notes
Notes: svn path=/head/; revision=141034
Diffstat (limited to 'www/firefox15/files/patch-gfx-src-gtk-Makefile.in')
-rw-r--r--www/firefox15/files/patch-gfx-src-gtk-Makefile.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/www/firefox15/files/patch-gfx-src-gtk-Makefile.in b/www/firefox15/files/patch-gfx-src-gtk-Makefile.in
new file mode 100644
index 000000000000..ff8b699841a3
--- /dev/null
+++ b/www/firefox15/files/patch-gfx-src-gtk-Makefile.in
@@ -0,0 +1,15 @@
+When using ``--with-system-nspr'' option, MOZ_COMPONENT_LIBS does not
+contain the ``-L../../../dist/lib'' -- only ``-L../../../dist/bin''.
+
+This causes an error, because libgfxshared_s is only under dist/lib.
+
+ -mi
+
+--- gfx/src/gtk/Makefile.in Mon Nov 10 07:24:51 2003
++++ gfx/src/gtk/Makefile.in Thu Jul 21 23:58:26 2005
+@@ -165,4 +165,5 @@
+ ifdef MOZ_ENABLE_GTK2
+ EXTRA_DSO_LDOPTS += $(MOZ_COMPONENT_LIBS) \
++ $(LIBS_DIR) \
+ -lgkgfx \
+ -lgfxshared_s \