aboutsummaryrefslogtreecommitdiff
path: root/www/firefox36
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-11-29 01:37:39 +0000
committerXin LI <delphij@FreeBSD.org>2007-11-29 01:37:39 +0000
commit438f72539d1ede401be31bd2b37976f4058b3074 (patch)
treec1e8629df0a95409d1222b114115f7efc9956386 /www/firefox36
parentd2f763a900ce8f187e3fcfb5252ea736d39d8a92 (diff)
downloadports-438f72539d1ede401be31bd2b37976f4058b3074.tar.gz
ports-438f72539d1ede401be31bd2b37976f4058b3074.zip
Notes
Diffstat (limited to 'www/firefox36')
-rw-r--r--www/firefox36/Makefile1
-rw-r--r--www/firefox36/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp26
2 files changed, 27 insertions, 0 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index aac7df1ee3fc..bfa0a1396acb 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -8,6 +8,7 @@
PORTNAME= firefox
DISTVERSION= 2.0.0.10
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
diff --git a/www/firefox36/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp b/www/firefox36/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp
new file mode 100644
index 000000000000..cf50f57e3288
--- /dev/null
+++ b/www/firefox36/files/patch-content__canvas__src__nsCanvasRenderingContext2D.cpp
@@ -0,0 +1,26 @@
+Index: content/canvas/src/nsCanvasRenderingContext2D.cpp
+===================================================================
+RCS file: /cvsroot/mozilla/content/canvas/src/nsCanvasRenderingContext2D.cpp,v
+retrieving revision 1.102
+diff -u -8 -p -r1.102 nsCanvasRenderingContext2D.cpp
+--- content/canvas/src/nsCanvasRenderingContext2D.cpp 10 Oct 2007 20:31:45 -0000 1.102
++++ content/canvas/src/nsCanvasRenderingContext2D.cpp 11 Oct 2007 23:31:32 -0000
+@@ -2140,17 +2140,17 @@ nsCanvasRenderingContext2D::CairoSurface
+ getter_AddRefs(imgRequest));
+ NS_ENSURE_SUCCESS(rv, rv);
+ if (!imgRequest)
+ // XXX ERRMSG we need to report an error to developers here! (bug 329026)
+ return NS_ERROR_NOT_AVAILABLE;
+
+ PRUint32 status;
+ imgRequest->GetImageStatus(&status);
+- if (status != imgIRequest::STATUS_LOAD_COMPLETE)
++ if ((status & imgIRequest::STATUS_LOAD_COMPLETE) == 0)
+ return NS_ERROR_NOT_AVAILABLE;
+
+ nsCOMPtr<nsIURI> uri;
+ rv = imageLoader->GetCurrentURI(uriOut);
+ NS_ENSURE_SUCCESS(rv, rv);
+
+ *forceWriteOnlyOut = PR_FALSE;
+