aboutsummaryrefslogtreecommitdiff
path: root/www/firefox36
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-11 07:31:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-11 07:31:45 +0000
commit5b6aacf2462798eb21ffc0521ee5676d9905a5a7 (patch)
treed8a618fdf58429da38b6e6f6714476bb66aaf0e2 /www/firefox36
parent0b7fbb0a21a049e4362ba597aba0417f13a24c99 (diff)
downloadports-5b6aacf2462798eb21ffc0521ee5676d9905a5a7.tar.gz
ports-5b6aacf2462798eb21ffc0521ee5676d9905a5a7.zip
Notes
Diffstat (limited to 'www/firefox36')
-rw-r--r--www/firefox36/Makefile19
-rw-r--r--www/firefox36/pkg-message2
2 files changed, 15 insertions, 6 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index b53bed5c40ed..fa30a6eb63a5 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -28,7 +28,6 @@ CONFIGURE_ENV= WITH_GTK2=yes
FAKEDIR= ${WRKDIR}/fake
FAKESUBDIR= ${FAKEDIR}/lib/${PORTNAME}
HAS_CONFIGURE= yes
-JREDIR= ${LOCALBASE}/jdk1.3.1/jre
ESD_LIB= libesd.so.2
LOCAL_PREFIX= ${PREFIX}/lib/${PORTNAME}
NO_MTREE= yes
@@ -43,6 +42,12 @@ USE_REINPLACE= yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
+JPI_LIST?=\
+ ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
+
OPTIONS= DEBUG "Build a debugging image" off \
HEADERS "Install headers and IDL files" off \
LOGGING "Enable additional log messages" off \
@@ -149,8 +154,14 @@ post-install:
${LN} -sf ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/firefox-config
${RM} -f ${PLUGINSDIR}/libjavaplugin_oji.so
- -${LN} -sf \
- ${JREDIR}/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
- ${PLUGINSDIR}/libjavaplugin_oji.so
+ if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
+ for jpi in ${JPI_LIST}; do \
+ if [ -f $${jpi} ]; then \
+ -${LN} -sf $${jpi} \
+ ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ; \
+ break; \
+ fi; \
+ done; \
+ fi
.include <bsd.port.post.mk>
diff --git a/www/firefox36/pkg-message b/www/firefox36/pkg-message
index 507a61e48136..ed9bc51041fc 100644
--- a/www/firefox36/pkg-message
+++ b/www/firefox36/pkg-message
@@ -7,8 +7,6 @@ bug reports to any other addresses.
Please include the following information with any bug report:
* Output from 'uname -a'.
* Date/time stamp from www/firefox/Makefile.
-* Perl version used (/usr/bin/perl --version or
- /usr/local/bin/perl --version for -current).
* Where/when did the problem occur: configuring, building, or
running firefox
* How can you reproduce the problem?