aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-06-26 11:01:34 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-06-26 11:01:34 +0000
commitd24ed7a7b663f5e7f243706e0f25e7b044c02f28 (patch)
tree95f37f9850e84f6918dba03cead478194c444dc5 /www/firefox
parent8c39c78e7c30bcac33fdc4104e347ea1ca1fd899 (diff)
downloadports-d24ed7a7b663f5e7f243706e0f25e7b044c02f28.tar.gz
ports-d24ed7a7b663f5e7f243706e0f25e7b044c02f28.zip
Notes
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile9
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/extra-bug78053123
-rw-r--r--www/firefox/files/patch-bug68525817
-rw-r--r--www/firefox/files/patch-bug78043217
-rw-r--r--www/firefox/files/patch-bug807492246
-rw-r--r--www/firefox/files/patch-bug82431717
-rw-r--r--www/firefox/files/patch-bug8269858
-rw-r--r--www/firefox/files/patch-bug83682433
-rw-r--r--www/firefox/files/patch-bug85493622
-rw-r--r--www/firefox/files/patch-clang3395
-rw-r--r--www/firefox/files/patch-duckduckgo10
-rw-r--r--www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c13
13 files changed, 60 insertions, 454 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 951d1b6e8f93..79ba698589fa 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 21.0
-PORTREVISION= 2
+DISTVERSION= 22.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source
@@ -12,7 +11,7 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}.source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
-BUILD_DEPENDS= nspr>=4.9.4:${PORTSDIR}/devel/nspr \
+BUILD_DEPENDS= nspr>=4.9.6:${PORTSDIR}/devel/nspr \
nss>=3.14.3:${PORTSDIR}/security/nss \
sqlite3>=3.7.14.1:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
@@ -50,6 +49,10 @@ OPTIONS_DEFINE= PGO WEBRTC
OPTIONS_DEFAULT=WEBRTC
.include "${.CURDIR}/../../www/firefox/Makefile.options"
+
+# OSS is gone after bug 852401
+OPTIONS_SINGLE_AUDIO:=${OPTIONS_SINGLE_AUDIO:S/OSS//}
+
.include <bsd.port.pre.mk>
WRKSRC:= ${WRKDIR}/mozilla-release
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 851d8ec02cd7..ac6d99fc0121 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-21.0.source.tar.bz2) = 3909031cb5d403b12c796afb7775b4950f0347786ffd06028761852a1074d91c
-SIZE (firefox-21.0.source.tar.bz2) = 105558931
+SHA256 (firefox-22.0.source.tar.bz2) = 040d4e7fb5076b6aa25f0d3851f8d98c2a2e72ef1599f4387f09f47f6096515e
+SIZE (firefox-22.0.source.tar.bz2) = 111109062
diff --git a/www/firefox/files/extra-bug780531 b/www/firefox/files/extra-bug780531
index f8ca253d7c9d..26859a9bde10 100644
--- a/www/firefox/files/extra-bug780531
+++ b/www/firefox/files/extra-bug780531
@@ -1,13 +1,24 @@
--- configure.in~
+++ configure.in
-@@ -5151,8 +5148,8 @@ fi
+@@ -5364,15 +5364,18 @@ AC_SUBST(MOZ_SRTP)
- AC_SUBST(MOZ_WEBRTC)
-
--case "$target_cpu" in
--arm*)
+ dnl Use integers over floats for audio on B2G and Android, because audio
+ dnl backends for those platforms don't support floats.
+-if test "$OS_TARGET" = "Android"; then
+case "$target" in
-+arm-*-linux*|*-dragonfly*|*-freebsd*|*-netbsd*|*-openbsd*)
++*-android*|*-linuxandroid*|*-dragonfly*|*-freebsd*|*-netbsd*|*-openbsd*)
MOZ_SAMPLE_TYPE_S16=1
AC_DEFINE(MOZ_SAMPLE_TYPE_S16)
AC_SUBST(MOZ_SAMPLE_TYPE_S16)
+-else
++;;
++*)
+ MOZ_SAMPLE_TYPE_FLOAT32=1
+ AC_DEFINE(MOZ_SAMPLE_TYPE_FLOAT32)
+ AC_SUBST(MOZ_SAMPLE_TYPE_FLOAT32)
+-fi
++;;
++esac
+
+ dnl ========================================================
+ dnl = Disable Speech API code
diff --git a/www/firefox/files/patch-bug685258 b/www/firefox/files/patch-bug685258
deleted file mode 100644
index cf0cb056d144..000000000000
--- a/www/firefox/files/patch-bug685258
+++ /dev/null
@@ -1,17 +0,0 @@
-# HG changeset patch
-# User Oleg Romashin <romaxa@gmail.com>
-# Parent a2291c212856ad27622416e83c8311b6a33b52f1
-Bug 685258 - Pulse audio backend does not check provided playback and crashes r=derf
-
-diff --git a/content/media/AudioStream.cpp b/content/media/AudioStream.cpp
---- content/media/AudioStream.cpp
-+++ content/media/AudioStream.cpp
-@@ -429,7 +429,7 @@ nsresult nsNativeAudioStream::Init(PRInt32 aNumChannels, PRInt32 aRate, SampleFo
- mFormat = aFormat;
-
- if (sa_stream_create_pcm(reinterpret_cast<sa_stream_t**>(&mAudioHandle),
-- NULL,
-+ "Mozilla",
- SA_MODE_WRONLY,
- SA_PCM_FORMAT_S16_NE,
- aRate,
diff --git a/www/firefox/files/patch-bug780432 b/www/firefox/files/patch-bug780432
deleted file mode 100644
index 076903cdeebc..000000000000
--- a/www/firefox/files/patch-bug780432
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git media/libsydneyaudio/src/Makefile.in media/libsydneyaudio/src/Makefile.in
-index 8dda8ce..b19641d 100644
---- media/libsydneyaudio/src/Makefile.in
-+++ media/libsydneyaudio/src/Makefile.in
-@@ -68,6 +68,12 @@ ifdef MOZ_ALSA
- $(NULL)
- endif
-
-+ifdef MOZ_PULSEAUDIO
-+CSRCS = \
-+ sydney_audio_pulseaudio.c \
-+ $(NULL)
-+endif
-+
- ifeq ($(OS_ARCH),WINNT)
- OS_LIBS += winmm.lib
- endif
diff --git a/www/firefox/files/patch-bug807492 b/www/firefox/files/patch-bug807492
index 21415b55ace1..f9e5de6739ac 100644
--- a/www/firefox/files/patch-bug807492
+++ b/www/firefox/files/patch-bug807492
@@ -17,42 +17,14 @@ diff --git configure.in configure.in
index c167461..8346c11 100644
--- configure.in
+++ configure.in
-@@ -1413,16 +1413,27 @@ if test "$GNU_CC"; then
- _SAVE_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -mssse3"
- AC_TRY_COMPILE([asm ("pmaddubsw %xmm2,%xmm3");],,AC_MSG_RESULT([yes])
- [HAVE_TOOLCHAIN_SUPPORT_MSSSE3=1],
- AC_MSG_RESULT([no]))
- CFLAGS=$_SAVE_CFLAGS
- AC_SUBST(HAVE_TOOLCHAIN_SUPPORT_MSSSE3)
-
-+ # Check for -msse4.1 on $CC
-+ AC_MSG_CHECKING([if toolchain supports -msse4.1 option])
-+ HAVE_TOOLCHAIN_SUPPORT_MSSE4_1=
-+ _SAVE_CFLAGS=$CFLAGS
-+ CFLAGS="$CFLAGS -msse4.1"
-+ AC_TRY_COMPILE([asm ("pmulld %xmm6,%xmm0");],,AC_MSG_RESULT([yes])
-+ [HAVE_TOOLCHAIN_SUPPORT_MSSE4_1=1],
-+ AC_MSG_RESULT([no]))
-+ CFLAGS=$_SAVE_CFLAGS
-+ AC_SUBST(HAVE_TOOLCHAIN_SUPPORT_MSSE4_1)
-+
- # Turn on GNU-specific warnings:
- # -Wall - turn on a lot of warnings
- # -Wpointer-arith - good to have
- # -Wdeclaration-after-statement - MSVC doesn't like these
- # -Werror=return-type - catches missing returns, zero false positives
- # -Wtype-limits - catches overflow bugs, few false positives
- # -Wempty-body - catches bugs, e.g. "if (c); foo();", few false positives
- #
-@@ -5203,17 +5214,17 @@ dnl Turn off webrtc for OS's we don't ha
- dnl --enable-webrtc to override. Can disable for everything in
- dnl the master list above.
- if test -n "$MOZ_WEBRTC"; then
- case "$target" in
+@@ -5258,17 +5258,17 @@ if test -n "$MOZ_WEBRTC"; then
*-android*|*-linuxandroid*)
- dnl Make sure doesn't get matched by *-linux*
- MOZ_WEBRTC=
+ if test -n "$MOZ_B2G"; then
+ MOZ_WEBRTC=1
+ else
+ dnl Make sure doesn't get matched by *-linux*
+ MOZ_WEBRTC=
+ fi
;;
- *-linux*|*-mingw*|*-darwin*)
+ *-linux*|*-mingw*|*-darwin*|*-dragonfly*|*-freebsd*|*-netbsd*|*-openbsd*)
@@ -64,28 +36,6 @@ index c167461..8346c11 100644
;;
esac
fi
-@@ -8997,16 +9008,21 @@ elif test "${OS_TARGET}" = "Android"; th
- EXTRA_GYP_DEFINES="-D gtest_target_type=executable -D android_toolchain=${android_toolchain} -G os=android "
- if test -n "$ARM_ARCH" && test "$ARM_ARCH" -lt 7; then
- EXTRA_GYP_DEFINES+=" -D armv7=0 "
- else
- EXTRA_GYP_DEFINES+=" -D armv7=1 "
- fi
- fi
-
-+# Don't try to compile sse4.1 code if toolchain doesn't support
-+if test -z "$HAVE_TOOLCHAIN_SUPPORT_MSSE4_1"; then
-+ EXTRA_GYP_DEFINES="$EXTRA_GYP_DEFINES -D yuv_disable_asm=1"
-+fi
-+
- if test -n "$MOZ_WEBRTC"; then
- AC_MSG_RESULT("generating WebRTC Makefiles...")
-
- dnl Any --include files must also appear in -D FORCED_INCLUDE_FILE= entries
- dnl so that regeneration via dependencies works correctly
- WEBRTC_CONFIG="-D build_with_mozilla=1 -D build_with_chromium=0 --include ${srcdir}/media/webrtc/webrtc_config.gypi -D FORCED_INCLUDE_FILE=${srcdir}/media/webrtc/webrtc_config.gypi"
-
- GYP_WEBRTC_OPTIONS="--format=mozmake ${WEBRTC_CONFIG} -D target_arch=${WEBRTC_TARGET_ARCH} ${EXTRA_GYP_DEFINES} --depth=${srcdir}/media/webrtc/trunk --toplevel-dir=${srcdir} -G OBJDIR=${_objdir}"
diff --git js/src/config/system-headers js/src/config/system-headers
index 9bd1efa..1095a01 100644
--- js/src/config/system-headers
@@ -367,12 +317,12 @@ index cc260b7..66af2d7 100644
if (!(my_locale = r_strdup(setlocale(LC_CTYPE, 0))))
ABORT(R_NO_MEMORY);
-@@ -93,28 +101,28 @@ mbslen(const char *s, size_t *ncharsp)
- #else
+@@ -94,28 +102,28 @@ mbslen(const char *s, size_t *ncharsp)
/* can't count UTF-8 characters with mbrlen if the locale isn't UTF-8 */
/* null-checking setlocale is required because Android */
char *locale = setlocale(LC_CTYPE, 0);
- if (!locale || !strcasestr(locale, "UTF-8"))
+ /* some systems use "utf8" instead of "UTF-8" like Fedora 17 */
+ if (!locale || (!strcasestr(locale, "UTF-8") && !strcasestr(locale, "UTF8")))
ABORT(R_NOT_FOUND);
#endif
@@ -394,12 +344,12 @@ index cc260b7..66af2d7 100644
+#endif /* HAVE_XLOCALE */
{
if (nbytes == (size_t)-1) /* should never happen */ {
- assert(0);
ABORT(R_INTERNAL);
}
if (nbytes == (size_t)-2) /* encoding error */ {
- assert(0);
ABORT(R_BAD_DATA);
+ }
+
diff --git media/mtransport/third_party/nrappkit/nrappkit.gyp media/mtransport/third_party/nrappkit/nrappkit.gyp
index 3cc8e1c..74016c6 100644
--- media/mtransport/third_party/nrappkit/nrappkit.gyp
@@ -631,106 +581,6 @@ index a30e330..cfbd8a3 100644
ifeq ($(OS_TARGET),Darwin)
LIBS += \
-framework AudioToolbox \
-diff --git media/webrtc/trunk/build/common.gypi media/webrtc/trunk/build/common.gypi
-index 6ca2f70..5d261cb 100644
---- media/webrtc/trunk/build/common.gypi
-+++ media/webrtc/trunk/build/common.gypi
-@@ -75,22 +75,31 @@
- # ash. This rule should be removed for the future when Windows is
- # using the aura windows without the ash interface.
- ['use_aura==1 and OS=="win"', {
- 'use_ash%': 1,
- }],
- ['use_ash==1', {
- 'use_aura%': 1,
- }],
-+
-+ # A flag for BSD platforms
-+ ['OS=="dragonfly" or OS=="freebsd" or OS=="netbsd" or \
-+ OS=="openbsd"', {
-+ 'os_bsd%': 1,
-+ }, {
-+ 'os_bsd%': 0,
-+ }],
- ],
- },
- # Copy conditionally-set variables out one scope.
- 'chromeos%': '<(chromeos)',
- 'use_aura%': '<(use_aura)',
- 'use_ash%': '<(use_ash)',
-+ 'os_bsd%': '<(os_bsd)',
- 'use_openssl%': '<(use_openssl)',
- 'use_ibus%': '<(use_ibus)',
- 'enable_viewport%': '<(enable_viewport)',
- 'enable_hidpi%': '<(enable_hidpi)',
- 'enable_touch_ui%': '<(enable_touch_ui)',
- 'android_upstream_bringup%': '<(android_upstream_bringup)',
- 'buildtype%': '<(buildtype)',
-
-@@ -114,17 +123,17 @@
- # Set default value of toolkit_views based on OS.
- ['OS=="win" or chromeos==1 or use_aura==1', {
- 'toolkit_views%': 1,
- }, {
- 'toolkit_views%': 0,
- }],
-
- # Set toolkit_uses_gtk for the Chromium browser on Linux.
-- ['(OS=="linux" or OS=="freebsd" or OS=="openbsd" or OS=="solaris") and use_aura==0', {
-+ ['(OS=="linux" or OS=="solaris" or os_bsd==1) and use_aura==0', {
- 'toolkit_uses_gtk%': 1,
- }, {
- 'toolkit_uses_gtk%': 0,
- }],
-
- # Enable HiDPI on Mac OS and Chrome OS.
- ['OS=="mac" or chromeos==1', {
- 'enable_hidpi%': 1,
-@@ -139,16 +148,17 @@
-
- # Copy conditionally-set variables out one scope.
- 'chromeos%': '<(chromeos)',
- 'host_arch%': '<(host_arch)',
- 'toolkit_views%': '<(toolkit_views)',
- 'toolkit_uses_gtk%': '<(toolkit_uses_gtk)',
- 'use_aura%': '<(use_aura)',
- 'use_ash%': '<(use_ash)',
-+ 'os_bsd%': '<(os_bsd)',
- 'use_openssl%': '<(use_openssl)',
- 'use_ibus%': '<(use_ibus)',
- 'enable_viewport%': '<(enable_viewport)',
- 'enable_hidpi%': '<(enable_hidpi)',
- 'enable_touch_ui%': '<(enable_touch_ui)',
- 'android_upstream_bringup%': '<(android_upstream_bringup)',
- 'android_build_type%': '<(android_build_type)',
-
-@@ -397,25 +407,18 @@
-
- # A flag for POSIX platforms
- ['OS=="win"', {
- 'os_posix%': 0,
- }, {
- 'os_posix%': 1,
- }],
-
-- # A flag for BSD platforms
-- ['OS=="freebsd" or OS=="openbsd"', {
-- 'os_bsd%': 1,
-- }, {
-- 'os_bsd%': 0,
-- }],
--
- # NSS usage.
-- ['(OS=="linux" or OS=="freebsd" or OS=="openbsd" or OS=="solaris") and use_openssl==0', {
-+ ['(OS=="linux" or OS=="solaris" or os_bsd==1) and use_openssl==0', {
- 'use_nss%': 1,
- }, {
- 'use_nss%': 0,
- }],
-
- # Flags to use X11 on non-Mac POSIX platforms
- ['OS=="win" or OS=="mac" or OS=="ios" or OS=="android"', {
- 'use_glib%': 0,
diff --git media/webrtc/trunk/webrtc/build/common.gypi media/webrtc/trunk/webrtc/build/common.gypi
index 9ca9f7c..d5c4ab9 100644
--- media/webrtc/trunk/webrtc/build/common.gypi
@@ -758,9 +608,9 @@ index 9ca9f7c..d5c4ab9 100644
'include_tests%': 0,
}],
@@ -205,16 +210,28 @@
- 'defines': ['WEBRTC_ARCH_ARM_NEON',],
- }, {
- 'defines': ['WEBRTC_DETECT_ARM_NEON',],
+ 'defines': ['WEBRTC_ARCH_ARM_NEON',
+ 'WEBRTC_BUILD_NEON_LIBS',
+ 'WEBRTC_DETECT_ARM_NEON'],
}],
],
}],
@@ -1636,7 +1486,7 @@ index e367abf..e14d7af 100644
WEBRTC_TRACE(kTraceStateInfo, kTraceUtility, -1,
"Available number of cores:%d", number_of_cores_);
- #elif defined(WEBRTC_LINUX) && !defined(WEBRTC_ANDROID)
+ #elif defined(WEBRTC_LINUX) && !defined(WEBRTC_ANDROID) && !defined(WEBRTC_GONK)
number_of_cores_ = get_nprocs();
WEBRTC_TRACE(kTraceStateInfo, kTraceUtility, -1,
"Available number of cores:%d", number_of_cores_);
@@ -1710,7 +1560,7 @@ index 6334490..852ebaa 100644
}
uint32_t ThreadWrapper::GetThreadId() {
- #if defined(WEBRTC_ANDROID) || defined(WEBRTC_LINUX)
+ #if defined(WEBRTC_ANDROID) || defined(WEBRTC_LINUX) || defined(WEBRTC_GONK)
return static_cast<uint32_t>(syscall(__NR_gettid));
#elif defined(WEBRTC_MAC) || defined(WEBRTC_IOS)
return pthread_mach_thread_np(pthread_self());
@@ -1735,7 +1585,7 @@ index 6334490..852ebaa 100644
int ThreadPosix::Construct() {
int result = 0;
- #if !defined(WEBRTC_ANDROID)
+ #if !defined(WEBRTC_ANDROID) && !defined(WEBRTC_GONK)
@@ -167,17 +192,17 @@ int ThreadPosix::Construct() {
}
@@ -1764,9 +1614,9 @@ index 6334490..852ebaa 100644
// CPU_ZERO and CPU_SET are not available in NDK r7, so disable
// SetAffinity on Android for now.
--#if (defined(WEBRTC_LINUX) && (!defined(WEBRTC_ANDROID)))
+-#if (defined(WEBRTC_LINUX) && (!defined(WEBRTC_ANDROID)) && (!defined(WEBRTC_GONK)))
+#if defined(__FreeBSD__) || (defined(WEBRTC_LINUX) && \
-+ (!defined(WEBRTC_ANDROID)))
++ (!defined(WEBRTC_ANDROID)) && (!defined(WEBRTC_GONK)))
bool ThreadPosix::SetAffinity(const int* processor_numbers,
const unsigned int amount_of_processors) {
if (!processor_numbers || (amount_of_processors == 0)) {
@@ -1784,12 +1634,12 @@ index 6334490..852ebaa 100644
++processor) {
CPU_SET(processor_numbers[processor], &mask);
}
--#if defined(WEBRTC_ANDROID)
+-#if defined(WEBRTC_ANDROID) || defined(WEBRTC_GONK)
+#if defined(__FreeBSD__)
+ const int result = pthread_setaffinity_np(thread_,
+ sizeof(mask),
+ &mask);
-+#elif defined(WEBRTC_ANDROID)
++#elif defined(WEBRTC_ANDROID) || defined(WEBRTC_GONK)
// Android.
const int result = syscall(__NR_sched_setaffinity,
pid_,
@@ -2013,58 +1863,14 @@ index 7d4c729..4104719 100644
#endif // WEBRTC_VOICE_ENGINE_VOICE_ENGINE_DEFINES_H
-diff --git media/webrtc/trunk/third_party/libyuv/libyuv.gyp media/webrtc/trunk/third_party/libyuv/libyuv.gyp
-index 6f4eb9e..5f044ad 100644
---- media/webrtc/trunk/third_party/libyuv/libyuv.gyp
-+++ media/webrtc/trunk/third_party/libyuv/libyuv.gyp
-@@ -4,16 +4,17 @@
- # that can be found in the LICENSE file in the root of the source
- # tree. An additional intellectual property rights grant can be found
- # in the file PATENTS. All contributing project authors may
- # be found in the AUTHORS file in the root of the source tree.
-
- {
- 'variables': {
- 'use_system_libjpeg%': 0,
-+ 'yuv_disable_asm%': 0,
- },
- 'targets': [
- {
- 'target_name': 'libyuv',
- 'type': 'static_library',
- # 'type': 'shared_library',
- 'conditions': [
- ['use_system_libjpeg==0', {
-@@ -45,16 +46,21 @@
- ],
- 'direct_dependent_settings': {
- 'include_dirs': [
- 'include',
- '.',
- ],
- },
- 'conditions': [
-+ ['yuv_disable_asm==1', {
-+ 'defines': [
-+ 'YUV_DISABLE_ASM',
-+ ],
-+ }],
- ['build_with_mozilla==1', {
- 'include_dirs': [
- '$(DEPTH)/dist/include',
- ],
- 'direct_dependent_settings': {
- 'include_dirs': [
- '$(DEPTH)/dist/include',
- ],
diff --git media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py
index 338d0b7..2241d41 100644
--- media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py
+++ media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py
-@@ -4,16 +4,17 @@
-
- # Python 2.5 needs this for the with statement.
- from __future__ import with_statement
+@@ -1,16 +1,17 @@
+ # Copyright (c) 2012 Mozilla Foundation. All rights reserved.
+ # Use of this source code is governed by a BSD-style license that can be
+ # found in the LICENSE file.
import collections
import gyp
diff --git a/www/firefox/files/patch-bug824317 b/www/firefox/files/patch-bug824317
deleted file mode 100644
index ebd8ad4e5946..000000000000
--- a/www/firefox/files/patch-bug824317
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/xpcom/string/public/nsAlgorithm.h b/xpcom/string/public/nsAlgorithm.h
-index fa50194a..c5f5737 100644
---- xpcom/string/public/nsAlgorithm.h
-+++ xpcom/string/public/nsAlgorithm.h
-@@ -42,7 +42,11 @@ NS_MAX( const T& a, const T& b )
- return a > b ? a : b;
- }
-
--#if defined(_MSC_VER) && (_MSC_VER < 1600)
-+#if (defined(_MSC_VER) && (_MSC_VER < 1600)) || \
-+ (((defined(__GNUC_MINOR__) && __GNUC_MINOR__ < 8) || \
-+ (defined(__GLIBCXX__) && __GLIBCXX__ < 20121005)) && \
-+ (defined(_GLIBCXX_USE_LONG_LONG) && \
-+ (!_GLIBCXX_USE_C99 || _GLIBCXX_USE_C99_LONG_LONG_DYNAMIC)))
- namespace std {
- inline
- long long
diff --git a/www/firefox/files/patch-bug826985 b/www/firefox/files/patch-bug826985
index d15ab05562d1..217655c0b81a 100644
--- a/www/firefox/files/patch-bug826985
+++ b/www/firefox/files/patch-bug826985
@@ -16,16 +16,16 @@ diff --git configure.in configure.in
index 55e4cd1..76567b3 100644
--- configure.in
+++ configure.in
-@@ -5250,6 +5250,9 @@ if test -n "$MOZ_WEBRTC"; then
+@@ -5294,6 +5294,9 @@ if test -n "$MOZ_WEBRTC"; then
MOZ_VP8_ENCODER=1
MOZ_VP8_ERROR_CONCEALMENT=1
+ dnl with libv4l2 we can support more cameras
+ PKG_CHECK_MODULES(MOZ_LIBV4L2, libv4l2)
+
- dnl OpenSLES is only available in Android 2.3 and later; we'll change this
- dnl hard dependency to a dynamic load with graceful runtime failure before
- dnl we make --enable-webrtc on by default in Android (bug 815905)
+ if test "$MOZ_WIDGET_TOOLKIT" != "gonk"; then
+ dnl OpenSLES is only available in Android 2.3 and later; we'll change this
+ dnl hard dependency to a dynamic load with graceful runtime failure before
@@ -8981,6 +8984,10 @@ elif test "${OS_TARGET}" = "Android"; then
fi
fi
diff --git a/www/firefox/files/patch-bug836824 b/www/firefox/files/patch-bug836824
deleted file mode 100644
index 807015baa616..000000000000
--- a/www/firefox/files/patch-bug836824
+++ /dev/null
@@ -1,33 +0,0 @@
-commit 35107a0 (HEAD)
-Author: Paul Adenot <paul@paul.cx>
-Date: Mon Feb 4 20:21:19 2013 +0100
-
- Bug 836824 - libsoundtouch fails to build due to __get_cpuid() invocation, if you don't have xcode command line tools. r=
----
- media/libsoundtouch/moz-libsoundtouch.patch | 24 ++++++++++++++++++++++++
- media/libsoundtouch/src/cpu_detect_x86.cpp | 5 ++++-
- 2 files changed, 28 insertions(+), 1 deletion(-)
-
-diff --git media/libsoundtouch/src/cpu_detect_x86.cpp media/libsoundtouch/src/cpu_detect_x86.cpp
-index a42008e..7a31aa9 100644
---- media/libsoundtouch/src/cpu_detect_x86.cpp
-+++ media/libsoundtouch/src/cpu_detect_x86.cpp
-@@ -101,7 +101,7 @@ uint detectCPUextensions(void)
-
- uint res = 0;
-
--#if defined(__GNUC__)
-+#if defined(__GNUC__) && defined(HAVE_CPUID_H)
- // GCC version of cpuid. Requires GCC 4.3.0 or later for __cpuid intrinsic support.
- uint eax, ebx, ecx, edx; // unsigned int is the standard type. uint is defined by the compiler and not guaranteed to be portable.
-
-@@ -112,6 +112,9 @@ uint detectCPUextensions(void)
- if (edx & bit_SSE) res = res | SUPPORT_SSE;
- if (edx & bit_SSE2) res = res | SUPPORT_SSE2;
-
-+#elif defined(__GNUC__)
-+ // No cpuid.h --> no cpuid support
-+ return 0;
- #else
- // Window / VS version of cpuid. Notice that Visual Studio 2005 or later required
- // for __cpuid intrinsic support.
diff --git a/www/firefox/files/patch-bug854936 b/www/firefox/files/patch-bug854936
deleted file mode 100644
index a8ac9ffb98e5..000000000000
--- a/www/firefox/files/patch-bug854936
+++ /dev/null
@@ -1,22 +0,0 @@
---- xpcom/reflect/xptcall/src/md/unix/xptcinvoke_gcc_x86_unix.cpp~
-+++ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_gcc_x86_unix.cpp
-@@ -9,7 +9,7 @@
- #include "xptc_gcc_x86_unix.h"
-
- extern "C" {
--static void ATTRIBUTE_USED __attribute__ ((regparm(3)))
-+void ATTRIBUTE_USED __attribute__ ((regparm(3)))
- invoke_copy_to_stack(uint32_t paramCount, nsXPTCVariant* s, uint32_t* d)
- {
- for(uint32_t i = paramCount; i >0; i--, d++, s++)
---- xpcom/reflect/xptcall/src/md/unix/xptcstubs_gcc_x86_unix.cpp~
-+++ xpcom/reflect/xptcall/src/md/unix/xptcstubs_gcc_x86_unix.cpp
-@@ -10,7 +10,7 @@
- #include "xptc_gcc_x86_unix.h"
-
- extern "C" {
--static nsresult ATTRIBUTE_USED
-+nsresult ATTRIBUTE_USED
- __attribute__ ((regparm (3)))
- PrepareAndDispatch(uint32_t methodIndex, nsXPTCStubBase* self, uint32_t* args)
- {
diff --git a/www/firefox/files/patch-clang33 b/www/firefox/files/patch-clang33
deleted file mode 100644
index 596312db5b4b..000000000000
--- a/www/firefox/files/patch-clang33
+++ /dev/null
@@ -1,95 +0,0 @@
---- js/src/Makefile.in~
-+++ js/src/Makefile.in
-@@ -791,6 +791,13 @@ EXTRA_LIBS += -lposix4 -ldl -lnsl -lsock
- endif
- endif
-
-+# clang 3.3 + -O2 makes jaeger crash in FixupArity
-+ifdef CLANG_CXX
-+ifndef MOZ_DEBUG
-+Compiler.$(OBJ_SUFFIX): CXXFLAGS += -fno-inline-functions
-+endif
-+endif
-+
- # An AIX Optimization bug causes PR_dtoa() & JS_dtoa to produce wrong result.
- # This suppresses optimization for this single compilation unit.
- ifeq ($(OS_ARCH),AIX)
---- js/src/jscompartment.h~
-+++ js/src/jscompartment.h
-@@ -596,12 +596,12 @@ class js::AutoDebugModeGC
- // The DEBUG_MODE_GC reason forces the collector to always throw
- // everything away, as required for debug mode transitions.
- if (needGC)
-- GC(rt, GC_NORMAL, gcreason::DEBUG_MODE_GC);
-+ GC(rt, GC_NORMAL, js::gcreason::DEBUG_MODE_GC);
- }
-
-- void scheduleGC(Zone *zone) {
-+ void scheduleGC(JS::Zone *zone) {
- JS_ASSERT(!rt->isHeapBusy());
-- PrepareZoneForGC(zone);
-+ js::PrepareZoneForGC(zone);
- needGC = true;
- }
- };
---- js/src/jspropertycacheinlines.h~
-+++ js/src/jspropertycacheinlines.h
-@@ -32,7 +32,7 @@ JS_ALWAYS_INLINE void
- js::PropertyCache::test(JSContext *cx, jsbytecode *pc, JSObject **obj,
- JSObject **pobj, PropertyCacheEntry **entry, PropertyName **name)
- {
-- AutoAssertNoGC nogc;
-+ js::AutoAssertNoGC nogc;
-
- JS_ASSERT(this == &cx->propertyCache());
-
-@@ -65,7 +65,7 @@ JS_ALWAYS_INLINE bool
- js::PropertyCache::testForSet(JSContext *cx, jsbytecode *pc, JSObject *obj,
- PropertyCacheEntry **entryp, JSObject **obj2p, PropertyName **namep)
- {
-- AutoAssertNoGC nogc;
-+ js::AutoAssertNoGC nogc;
-
- JS_ASSERT(this == &cx->propertyCache());
-
---- js/src/vm/ObjectImpl-inl.h~
-+++ js/src/vm/ObjectImpl-inl.h
-@@ -164,9 +164,9 @@ js::ObjectImpl::initializeSlotRange(uint
- JSRuntime *rt = runtime();
- uint32_t offset = start;
- for (HeapSlot *sp = fixedStart; sp < fixedEnd; sp++)
-- sp->init(rt, this->asObjectPtr(), HeapSlot::Slot, offset++, UndefinedValue());
-+ sp->init(rt, this->asObjectPtr(), HeapSlot::Slot, offset++, js::UndefinedValue());
- for (HeapSlot *sp = slotsStart; sp < slotsEnd; sp++)
-- sp->init(rt, this->asObjectPtr(), HeapSlot::Slot, offset++, UndefinedValue());
-+ sp->init(rt, this->asObjectPtr(), HeapSlot::Slot, offset++, js::UndefinedValue());
- }
-
- inline bool
-@@ -321,7 +321,7 @@ js::ObjectImpl::sizeOfThis() const
- js::ObjectImpl::readBarrier(ObjectImpl *obj)
- {
- #ifdef JSGC_INCREMENTAL
-- Zone *zone = obj->zone();
-+ JS::Zone *zone = obj->zone();
- if (zone->needsBarrier()) {
- MOZ_ASSERT(!zone->rt->isHeapBusy());
- JSObject *tmp = obj->asObjectPtr();
-@@ -335,7 +335,7 @@ inline void
- js::ObjectImpl::privateWriteBarrierPre(void **old)
- {
- #ifdef JSGC_INCREMENTAL
-- Zone *zone = this->zone();
-+ JS::Zone *zone = this->zone();
- if (zone->needsBarrier()) {
- if (*old && getClass()->trace)
- getClass()->trace(zone->barrierTracer(), this->asObjectPtr());
-@@ -362,7 +362,7 @@ js::ObjectImpl::writeBarrierPre(ObjectIm
- if (uintptr_t(obj) < 32)
- return;
-
-- Zone *zone = obj->zone();
-+ JS::Zone *zone = obj->zone();
- if (zone->needsBarrier()) {
- MOZ_ASSERT(!zone->rt->isHeapBusy());
- JSObject *tmp = obj->asObjectPtr();
diff --git a/www/firefox/files/patch-duckduckgo b/www/firefox/files/patch-duckduckgo
index 7481cabc99ca..de6b18f3afc0 100644
--- a/www/firefox/files/patch-duckduckgo
+++ b/www/firefox/files/patch-duckduckgo
@@ -1,7 +1,7 @@
diff -r f2fa4ae74ee1 browser/locales/en-US/chrome/browser-region/region.properties
--- browser/locales/en-US/chrome/browser-region/region.properties Mon Oct 24 22:54:18 2011 +0300
+++ browser/locales/en-US/chrome/browser-region/region.properties Tue Oct 25 21:13:40 2011 -0400
-@@ -1,15 +1,16 @@
+@@ -4,15 +4,16 @@
# Default search engine
browser.search.defaultenginename=Google
@@ -13,11 +13,11 @@ diff -r f2fa4ae74ee1 browser/locales/en-US/chrome/browser-region/region.properti
# This is the default set of web based feed handlers shown in the reader
# selection UI
- browser.contentHandlers.types.0.title=Google
- browser.contentHandlers.types.0.uri=http://fusion.google.com/add?feedurl=%s
- browser.contentHandlers.types.1.title=My Yahoo!
- browser.contentHandlers.types.1.uri=http://add.my.yahoo.com/rss?url=%s
+ browser.contentHandlers.types.0.title=My Yahoo!
+ browser.contentHandlers.types.0.uri=http://add.my.yahoo.com/rss?url=%s
+ # increment this number when anything gets changed in the list below. This will
+ # cause Firefox to re-read these prefs and inject any new handlers into the
--- /dev/null 2013-02-09 00:33:00.000000000 +0100
+++ browser/locales/en-US/searchplugins/duckduckgo.xml 2013-02-09 00:40:19.000000000 +0100
@@ -0,0 +1,11 @@
diff --git a/www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c b/www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
deleted file mode 100644
index a7fd5f1ffd09..000000000000
--- a/www/firefox/files/patch-media-libsydneyaudio-src-sydney_audio_oss.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- media/libsydneyaudio/src/sydney_audio_oss.c~
-+++ media/libsydneyaudio/src/sydney_audio_oss.c
-@@ -446,6 +446,10 @@ static void audio_callback(void* data)
- printf("!"); /* not enough audio data */
- #endif
- bytes = bytes-bytes_to_copy;
-+ struct timespec ts = {0, 1000000};
-+ pthread_mutex_unlock(&s->mutex);
-+ nanosleep(&ts, NULL);
-+ pthread_mutex_lock(&s->mutex);
- break;
- }
- free(s->bl_head);