aboutsummaryrefslogtreecommitdiff
path: root/www/fpc-fastcgi
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 17:46:57 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 17:46:57 +0000
commit22bbe5b9cb7b4a385942960e2bcb014dc985bbc7 (patch)
treef2eb2dba2faa91eed411811a69a17a02922d8cbd /www/fpc-fastcgi
parent7bcde27b942b55999699e240530dc4119a428ba7 (diff)
downloadports-22bbe5b9cb7b4a385942960e2bcb014dc985bbc7.tar.gz
ports-22bbe5b9cb7b4a385942960e2bcb014dc985bbc7.zip
Notes
Diffstat (limited to 'www/fpc-fastcgi')
-rw-r--r--www/fpc-fastcgi/Makefile21
-rw-r--r--www/fpc-fastcgi/pkg-plist9
2 files changed, 30 insertions, 0 deletions
diff --git a/www/fpc-fastcgi/Makefile b/www/fpc-fastcgi/Makefile
new file mode 100644
index 000000000000..a13e9602b2dc
--- /dev/null
+++ b/www/fpc-fastcgi/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: fpc-fastcgi
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= www lang
+PKGNAMESUFFIX= -fastcgi
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal fastcgi unit
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/fpc-fastcgi/pkg-plist b/www/fpc-fastcgi/pkg-plist
new file mode 100644
index 000000000000..5f60619dd30b
--- /dev/null
+++ b/www/fpc-fastcgi/pkg-plist
@@ -0,0 +1,9 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fastcgi/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fastcgi/fastcgi.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fastcgi/fastcgi.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fastcgi/libpfastcgi.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fastcgi
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc