aboutsummaryrefslogtreecommitdiff
path: root/www/gallery2/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-01 08:28:25 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-01 08:28:25 +0000
commite2f31d33ffe35b65e4e4f181dda70e739a60d924 (patch)
tree76feeb652e2ddb58880afb42e498eb715c040070 /www/gallery2/Makefile
parentda1f86c33f7837cf9e9ec41e92c21960e1372c15 (diff)
Notes
Diffstat (limited to 'www/gallery2/Makefile')
-rw-r--r--www/gallery2/Makefile51
1 files changed, 39 insertions, 12 deletions
diff --git a/www/gallery2/Makefile b/www/gallery2/Makefile
index 0efb6aabc14a..fc90679c4a44 100644
--- a/www/gallery2/Makefile
+++ b/www/gallery2/Makefile
@@ -6,21 +6,16 @@
#
PORTNAME= gallery2
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gallery
-DISTNAME= gallery-2.0.1-full
+DISTNAME= gallery-2.0.2-full
DIST_SUBDIR= gallery2
MAINTAINER= freebsd-ports@varju.ca
COMMENT= Gallery is a web based photo album written using PHP
-RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm \
- jhead:${PORTSDIR}/graphics/jhead \
- unzip:${PORTSDIR}/archivers/unzip \
- convert:${PORTSDIR}/graphics/ImageMagick
-
USE_PHP= pcre session mysql
WANT_PHP_WEB= yes
@@ -30,6 +25,42 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CPIOARGS= --quiet -pdum -R
PLIST_SUB+= GALLERY2DIR=${GALLERY2DIR}
+GALLERY2DIR?= www/data/gallery2
+WWWOWN?= www
+WWWGRP?= www
+
+OPTIONS= NETPBM "Enable netpbm support" on \
+ IMAGEMAGICK "Enable imagemagick support" on \
+ JHEAD "Enable jhead support" on \
+ UNZIP "Enable unzip support" on \
+ GD "Enable gd support" off \
+ DCRAW "Enable dcraw support" off \
+ FFMPEG "Enable ffmpeg support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NETPBM)
+RUN_DEPENDS+= giftopnm:${PORTSDIR}/graphics/netpbm
+.endif
+.if defined(WITH_IMAGEMAGICK)
+RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
+.endif
+.if defined(WITH_GD)
+RUN_DEPENDS+= pngtogd:${PORTSDIR}/graphics/gd
+.endif
+.if defined(WITH_JHEAD)
+RUN_DEPENDS+= jhead:${PORTSDIR}/graphics/jhead
+.endif
+.if defined(WITH_UNZIP)
+RUN_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
+.endif
+.if defined(WITH_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.endif
+.if defined(WITH_DCRAW)
+RUN_DEPENDS+= dcraw:${PORTSDIR}/graphics/dcraw
+.endif
+
pre-fetch:
.if !defined(GALLERY2DIR)
@${ECHO_MSG} ""
@@ -37,10 +68,6 @@ pre-fetch:
@${ECHO_MSG} ""
.endif
-GALLERY2DIR?= www/data/gallery2
-WWWOWN?= www
-WWWGRP?= www
-
post-configure:
@ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' \
-e 's#%%GALLERY2DIR%%#${GALLERY2DIR}#g' pkg-message > ${PKGMESSAGE}
@@ -55,4 +82,4 @@ post-install:
@ ${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>