aboutsummaryrefslogtreecommitdiff
path: root/www/gatling
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-03-17 06:07:55 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-03-17 06:07:55 +0000
commit7995a7f65ece75beb4e917a0e810d858f9463987 (patch)
tree19e2d6e12ae85ddc8658dd3e531d3eec944c3795 /www/gatling
parenta03143867bfb39aeccdc6db7b1d91aa7e97f5685 (diff)
downloadports-7995a7f65ece75beb4e917a0e810d858f9463987.tar.gz
ports-7995a7f65ece75beb4e917a0e810d858f9463987.zip
- Update to 0.7
- Remove a patch that is no longer needed PR: 78782 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de>
Notes
Notes: svn path=/head/; revision=131467
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile3
-rw-r--r--www/gatling/distinfo4
-rw-r--r--www/gatling/files/patch-Makefile4
-rw-r--r--www/gatling/files/patch-gatling.c11
4 files changed, 5 insertions, 17 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index e848d40e2bcb..a6cdda4983db 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gatling
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= www benchmarks ftp ipv6
MASTER_SITES= http://dl.fefe.de/
diff --git a/www/gatling/distinfo b/www/gatling/distinfo
index 09899c2a3ffc..eb0622cdd452 100644
--- a/www/gatling/distinfo
+++ b/www/gatling/distinfo
@@ -1,2 +1,2 @@
-MD5 (gatling-0.6.tar.bz2) = 2067d666c01834f2c8702b08644f95d8
-SIZE (gatling-0.6.tar.bz2) = 47267
+MD5 (gatling-0.7.tar.bz2) = 3c6d3e859b539f24b6ffaffd1659d3f7
+SIZE (gatling-0.7.tar.bz2) = 53029
diff --git a/www/gatling/files/patch-Makefile b/www/gatling/files/patch-Makefile
index 0d956eb7de8a..2fa840d4add5 100644
--- a/www/gatling/files/patch-Makefile
+++ b/www/gatling/files/patch-Makefile
@@ -24,8 +24,8 @@
$(CC) -c $< -I. $(CFLAGS)
tlsgatling: gatling.c ssl.o
-- $(CC) -o $@ $(CFLAGS) $^ $(LDFLAGS) -lssl -lcrypto $(LDLIBS)
-+ $(CC) -o $@ $(CFLAGS) $> -DSUPPORT_HTTPS $(LDFLAGS) -lssl -lcrypto $(LDLIBS)
+- -$(CC) -o $@ $(CFLAGS) $^ $(LDFLAGS) -lssl -lcrypto $(LDLIBS)
++ -$(CC) -o $@ $(CFLAGS) $> -DSUPPORT_HTTPS $(LDFLAGS) -lssl -lcrypto $(LDLIBS)
libsocket: trysocket.c
if $(DIET) $(CC) $(CFLAGS) -o trysocket trysocket.c >/dev/null 2>&1; then echo ""; else \
diff --git a/www/gatling/files/patch-gatling.c b/www/gatling/files/patch-gatling.c
deleted file mode 100644
index 394658b14458..000000000000
--- a/www/gatling/files/patch-gatling.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gatling.c.orig Mon Jan 31 17:14:45 2005
-+++ gatling.c Sun Feb 20 17:02:12 2005
-@@ -3088,7 +3088,7 @@ void forkslave(int fd,buffer* in) {
- }
- }
- error:
-- write(fd,&code,4);
-+ if (write(fd,&code,4)!=4) exit(0);
- code=strlen(msg);
- write(fd,&code,4);
- {