aboutsummaryrefslogtreecommitdiff
path: root/www/gatling
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-21 10:39:25 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-21 10:39:25 +0000
commit865089e0963cfecf01c5fde0564fead2086a029f (patch)
tree17f11dc2a864927d3711d10bc175041415ba340a /www/gatling
parentc47e97043ae0ab1c93a6feceeb5d59779268ffcd (diff)
downloadports-865089e0963cfecf01c5fde0564fead2086a029f.tar.gz
ports-865089e0963cfecf01c5fde0564fead2086a029f.zip
- Fix '-h' option in gatling
- Bump PORTREVISION PR: ports/77783 Submitted by: Thomas-Martin Seck (maintainer) Obtained from: gatling CVS
Notes
Notes: svn path=/head/; revision=129460
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile1
-rw-r--r--www/gatling/files/patch-gatling.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index ecce27243a31..e848d40e2bcb 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gatling
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= www benchmarks ftp ipv6
MASTER_SITES= http://dl.fefe.de/
diff --git a/www/gatling/files/patch-gatling.c b/www/gatling/files/patch-gatling.c
new file mode 100644
index 000000000000..394658b14458
--- /dev/null
+++ b/www/gatling/files/patch-gatling.c
@@ -0,0 +1,11 @@
+--- gatling.c.orig Mon Jan 31 17:14:45 2005
++++ gatling.c Sun Feb 20 17:02:12 2005
+@@ -3088,7 +3088,7 @@ void forkslave(int fd,buffer* in) {
+ }
+ }
+ error:
+- write(fd,&code,4);
++ if (write(fd,&code,4)!=4) exit(0);
+ code=strlen(msg);
+ write(fd,&code,4);
+ {