aboutsummaryrefslogtreecommitdiff
path: root/www/gatling
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2017-02-13 20:24:16 +0000
committerDavid Thiel <lx@FreeBSD.org>2017-02-13 20:24:16 +0000
commitf2808e66e178a5d791111b9e33a9f65f0f4356b2 (patch)
tree42950296c9f0aad665e2652b363b419c7a49701f /www/gatling
parentaa8bfe714768607368d821830937f7e3c61589a7 (diff)
downloadports-f2808e66e178a5d791111b9e33a9f65f0f4356b2.tar.gz
ports-f2808e66e178a5d791111b9e33a9f65f0f4356b2.zip
Update to 0.15, fixing security issues.
PR: 217064 Reported by: Jan Bramkamp MFH: 2017Q1 Security: File descriptor leakage and use after free bugs
Notes
Notes: svn path=/head/; revision=434051
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile29
-rw-r--r--www/gatling/distinfo5
-rw-r--r--www/gatling/files/patch-GNUmakefile6
3 files changed, 20 insertions, 20 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index 14a8063268a3..8f761f660602 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -2,19 +2,18 @@
# $FreeBSD$
PORTNAME= gatling
-PORTVERSION= 0.13
-PORTREVISION= 1
+PORTVERSION= 0.15
CATEGORIES= www benchmarks ftp ipv6
-MASTER_SITES= http://dl.fefe.de/
+MASTER_SITES= http://www.fefe.de/gatling/
MAINTAINER= coco@executive-computing.de
COMMENT= High performance webserver with scalability benchmark tools
LICENSE= GPLv2
-BUILD_DEPENDS= libowfat>=0.29:devel/libowfat
+BUILD_DEPENDS= libowfat>=0.31:devel/libowfat
-USES= gmake ssl tar:bzip2
+USES= gmake ssl tar:xz
USE_RC_SUBR= gatling
CFLAGS+= -I${LOCALBASE}/include/libowfat -I${OPENSSLINC} -I${LOCALBASE}/include
@@ -87,19 +86,19 @@ post-patch:
${WRKSRC}/GNUmakefile
pre-install:
- @cd ${WRKSRC} && ${CP} gatling.1 gatling.8
+ cd ${WRKSRC} && ${CP} gatling.1 gatling.8
do-install:
- @cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${STAGEDIR}${PREFIX}/bin
- @cd ${WRKSRC} && ${INSTALL_PROGRAM} ${sbin} ${STAGEDIR}${PREFIX}/sbin
- @${INSTALL_SCRIPT} ${FILESDIR}/gatling_wrapper ${STAGEDIR}${PREFIX}/sbin
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${sbin} ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${FILESDIR}/gatling_wrapper ${STAGEDIR}${PREFIX}/sbin
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
.if !empty(BENCH1)
- @cd ${WRKSRC} && ${INSTALL_MAN} ${BENCH1} ${STAGEDIR}${MAN1PREFIX}/man/man1
+ cd ${WRKSRC} && ${INSTALL_MAN} ${BENCH1} ${STAGEDIR}${MAN1PREFIX}/man/man1
.endif
- @cd ${WRKSRC} && ${INSTALL_MAN} ${GATLING8} ${STAGEDIR}${MAN8PREFIX}/man/man8
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_MAN} ${GATLING8} ${STAGEDIR}${MAN8PREFIX}/man/man8
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/www/gatling/distinfo b/www/gatling/distinfo
index 3a79526def35..35ee959b389e 100644
--- a/www/gatling/distinfo
+++ b/www/gatling/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gatling-0.13.tar.bz2) = b42145fdf7b66602fa8bc64661c2762172f6d33dbd9d53efebf821cd81e89245
-SIZE (gatling-0.13.tar.bz2) = 108128
+TIMESTAMP = 1487014927
+SHA256 (gatling-0.15.tar.xz) = 6fa329d0ced0c80deb8dde5460e9d9e984bee94f265043d7fdec0e253dce9aa4
+SIZE (gatling-0.15.tar.xz) = 121804
diff --git a/www/gatling/files/patch-GNUmakefile b/www/gatling/files/patch-GNUmakefile
index eeaa0f9132fd..53fb9adfbdb3 100644
--- a/www/gatling/files/patch-GNUmakefile
+++ b/www/gatling/files/patch-GNUmakefile
@@ -1,5 +1,5 @@
---- GNUmakefile.orig 2012-12-07 12:27:09.595489622 -0800
-+++ GNUmakefile 2012-12-07 12:35:03.890478583 -0800
+--- /tmp/GNUmakefile 2017-02-13 11:43:57.882750000 -0800
++++ GNUmakefile 2017-02-13 11:56:19.109139000 -0800
@@ -1,24 +1,22 @@
-#DEBUG=1
-ZLIB=1
@@ -42,7 +42,7 @@
+DIET=
+
ifneq ($(DEBUG),)
- CFLAGS+=-g
+ CFLAGS+=-g -Og
LDFLAGS+=-g
-else
-CFLAGS+=-O2 -fomit-frame-pointer -I/usr/local/include