aboutsummaryrefslogtreecommitdiff
path: root/www/gauche-makiki
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-12-29 13:25:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-12-29 13:25:32 +0000
commit98f57c60118bb31392ad830cff23ab6cacf93c03 (patch)
tree6b834e1d434d40396abaf861aea7113f96cb71c9 /www/gauche-makiki
parent52fdb8bd757cdce1359cd194f17272c3e5a0c7d0 (diff)
downloadports-98f57c60118bb31392ad830cff23ab6cacf93c03.tar.gz
ports-98f57c60118bb31392ad830cff23ab6cacf93c03.zip
Simple multithreaded HTTP server written in Gauche.
Notes
Notes: svn path=/head/; revision=488666
Diffstat (limited to 'www/gauche-makiki')
-rw-r--r--www/gauche-makiki/Makefile42
-rw-r--r--www/gauche-makiki/distinfo3
-rw-r--r--www/gauche-makiki/pkg-descr14
3 files changed, 59 insertions, 0 deletions
diff --git a/www/gauche-makiki/Makefile b/www/gauche-makiki/Makefile
new file mode 100644
index 000000000000..ca6c510f7dfc
--- /dev/null
+++ b/www/gauche-makiki/Makefile
@@ -0,0 +1,42 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= makiki
+PORTVERSION= 0.3
+DISTVERSIONPREFIX= release_
+CATEGORIES= www scheme
+PKGNAMEPREFIX= gauche-
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Simple multithreaded HTTP server written in Gauche
+
+LICENSE= BSD
+
+BUILD_DEPENDS= gosh:lang/gauche
+RUN_DEPENDS= gosh:lang/gauche
+
+HAS_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= shirok
+GH_PROJECT= Gauche-makiki
+
+GUILE_SITELIBDIR_REL= ${:!gauche-config --sitelibdir!:S,^${PREFIX}/,,}
+
+EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
+
+PLIST_FILES= ${GUILE_SITELIBDIR_REL}/.packages/Gauche-makiki.gpd \
+ ${GUILE_SITELIBDIR_REL}/makiki/cgi.scm \
+ ${GUILE_SITELIBDIR_REL}/makiki/connect.scm \
+ ${GUILE_SITELIBDIR_REL}/makiki.scm
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,0\.2,${PORTVERSION},' ${WRKSRC}/package.scm
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/www/gauche-makiki/distinfo b/www/gauche-makiki/distinfo
new file mode 100644
index 000000000000..59c54b9d4e10
--- /dev/null
+++ b/www/gauche-makiki/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1506466829
+SHA256 (shirok-Gauche-makiki-release_0.3_GH0.tar.gz) = abd79684f3f5f8825981c9f45ff964e5e81459d2a707c45bf202133727b6654c
+SIZE (shirok-Gauche-makiki-release_0.3_GH0.tar.gz) = 35311
diff --git a/www/gauche-makiki/pkg-descr b/www/gauche-makiki/pkg-descr
new file mode 100644
index 000000000000..034ce42a0652
--- /dev/null
+++ b/www/gauche-makiki/pkg-descr
@@ -0,0 +1,14 @@
+Gauche-makiki is a simple multithreaded HTTP server intended for applications
+that want to provide HTTP server capability easily. The main functionalities
+are available by just one file, `makiki.scm', so you can either install it as
+an ordinary Gauche extension library, or you can just copy the file into your
+application.
+
+You'll get the idea by looking at the minimal server:
+
+ (use makiki)
+ (define (main args) (start-http-server :port 6789))
+ (define-http-handler "/"
+ (^[req app] (respond/ok req "<h1>It worked!</h1>")))
+
+WWW: https://github.com/shirok/Gauche-makiki