aboutsummaryrefslogtreecommitdiff
path: root/www/get_flash_videos
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2012-07-22 22:12:40 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2012-07-22 22:12:40 +0000
commita6e499151ce51094c27f83bccb84e015d18de8f9 (patch)
tree0d5bb3c1a9d8fbd3cbc95154dc5c36d7a9b84dce /www/get_flash_videos
parent2a3105aff06d8d77e77f07c3fadca7ec4701031a (diff)
downloadports-a6e499151ce51094c27f83bccb84e015d18de8f9.tar.gz
ports-a6e499151ce51094c27f83bccb84e015d18de8f9.zip
Notes
Diffstat (limited to 'www/get_flash_videos')
-rw-r--r--www/get_flash_videos/Makefile51
-rw-r--r--www/get_flash_videos/distinfo2
-rw-r--r--www/get_flash_videos/pkg-descr14
3 files changed, 67 insertions, 0 deletions
diff --git a/www/get_flash_videos/Makefile b/www/get_flash_videos/Makefile
new file mode 100644
index 000000000000..f7fa254c0b45
--- /dev/null
+++ b/www/get_flash_videos/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: get_flash_videos
+# Date created: Sun Jul 22 20:49:07 UTC 2012
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= get_flash_videos
+DISTVERSION= 1.24.${DISTFILE_DATE}
+CATEGORIES= www perl5
+MASTER_SITES= https://github.com/downloads/njtaylor/get-flash-videos/
+DISTNAME= ${PORTNAME}-1.24-git-${DISTFILE_DATE}
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Download videos from various Flash-based video hosting sites
+
+LICENSE= AL2
+
+RUN_DEPENDS= \
+ p5-Crypt-Blowfish_PP>=0:${PORTSDIR}/security/p5-Crypt-Blowfish_PP \
+ p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-Data-AMF>=0:${PORTSDIR}/converters/p5-Data-AMF \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ rtmpdump>=2.4.0:${PORTSDIR}/multimedia/rtmpdump
+
+FETCH_ARGS= -Fpr # work around 302 redirect at github
+USE_PERL5= 5.8.0+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+DISTFILE_DATE= 20120610
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/env perl|${PERL}|' \
+ ${WRKSRC}/${DISTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} \
+ ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/www/get_flash_videos/distinfo b/www/get_flash_videos/distinfo
new file mode 100644
index 000000000000..87dc31f84c50
--- /dev/null
+++ b/www/get_flash_videos/distinfo
@@ -0,0 +1,2 @@
+SHA256 (get_flash_videos-1.24-git-20120610) = 5db795c055ee25997d2f5afe7fbdd0b4e4a863ebea19ee8851a9921115dca477
+SIZE (get_flash_videos-1.24-git-20120610) = 287984
diff --git a/www/get_flash_videos/pkg-descr b/www/get_flash_videos/pkg-descr
new file mode 100644
index 000000000000..41a79f05cb26
--- /dev/null
+++ b/www/get_flash_videos/pkg-descr
@@ -0,0 +1,14 @@
+[ excerpt from developer's web site ]
+
+Download videos from various Flash-based video hosting sites, without
+having to use the Flash player. Handy for saving videos for watching
+offline, and means you don't have to keep upgrading Flash for sites
+that insist on a newer version of the player.
+
+YouTube, eHow, Brightcove (used by many sites like Channel 4, Daily
+Telegraph ...), BBC (news, etc), Metacafe, 5min, Google, fliqz,
+nicovideo, vimeo, Blip, Break, Collegehumor, Muzu, Sevenload,
+Megavideo, Wat.tv. Also includes a 'generic' method which works on
+many other sites.
+
+WWW: http://code.google.com/p/get-flash-videos/