aboutsummaryrefslogtreecommitdiff
path: root/www/gist/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-07-02 17:35:35 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-07-02 17:35:35 +0000
commit20d9282c9653f52219848d18fa0afa0d8468a060 (patch)
tree22268ff986bbe9cce618959829e1092f0aa175c4 /www/gist/Makefile
parent983d5155b110c5fbed35cf84abdd77fc01cd2759 (diff)
downloadports-20d9282c9653f52219848d18fa0afa0d8468a060.tar.gz
ports-20d9282c9653f52219848d18fa0afa0d8468a060.zip
Notes
Diffstat (limited to 'www/gist/Makefile')
-rw-r--r--www/gist/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/www/gist/Makefile b/www/gist/Makefile
index 11f5396c8663..280166236416 100644
--- a/www/gist/Makefile
+++ b/www/gist/Makefile
@@ -2,23 +2,22 @@
# $FreeBSD$
PORTNAME= gist
-PORTVERSION= 3.1.0
-PORTREVISION= 4
+PORTVERSION= 4.2.1
CATEGORIES= www net
MAINTAINER= changlp@cs.nctu.edu.tw
COMMENT= Gist pastebin posting command
-OPTIONS_DEFINE= NSSCA
-NSSCA_DESC= Use certificates provided in security/ca_root_nss
-.include <bsd.port.options.mk>
+LICENSE= MIT
+
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
CONFLICTS= p5-App-gist-[0-9]*
USE_GITHUB= yes
GH_ACCOUNT= defunkt
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= 82ffb80
+GH_COMMIT= 82fe83c
USE_RUBY= YES
RUBY_NO_BUILD_DEPENDS= YES
@@ -29,21 +28,11 @@ PLIST_FILES= bin/gist \
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MNSSCA}
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-nssca-gist
-.else
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-cert-gist
-.endif
-
-.if ${PORT_OPTIONS:MNSSCA}
post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/gist
-.endif
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/build/gist
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/gist ${STAGEDIR}${PREFIX}/bin/gist
- ${INSTALL_MAN} ${WRKSRC}/man/gist.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/build/gist ${STAGEDIR}${PREFIX}/bin/gist
+ ${INSTALL_MAN} ${WRKSRC}/build/gist.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.post.mk>