aboutsummaryrefslogtreecommitdiff
path: root/www/gist
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-15 17:16:53 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-15 17:16:53 +0000
commit823fea27ba7fa857e5bbcd6d68b3598435704a6a (patch)
tree0bff54ee3cad0595fe21192a2db75ef534f76d20 /www/gist
parent14bbb099d9397321919dd7d6c8f92f1be373ac00 (diff)
downloadports-823fea27ba7fa857e5bbcd6d68b3598435704a6a.tar.gz
ports-823fea27ba7fa857e5bbcd6d68b3598435704a6a.zip
- Update to 2.0.1
PR: ports/156071 Submitted by: Lung-Pin Chang <changlp@cs.nctu.edu.tw> Approved by: maintainer timeout (two weeks)
Notes
Notes: svn path=/head/; revision=272757
Diffstat (limited to 'www/gist')
-rw-r--r--www/gist/Makefile16
-rw-r--r--www/gist/distinfo4
-rw-r--r--www/gist/files/patch-gist11
3 files changed, 25 insertions, 6 deletions
diff --git a/www/gist/Makefile b/www/gist/Makefile
index 2e933d59a856..8278fbe7de1f 100644
--- a/www/gist/Makefile
+++ b/www/gist/Makefile
@@ -6,23 +6,31 @@
#
PORTNAME= gist
-PORTVERSION= 1.0
+PORTVERSION= 2.0.1
CATEGORIES= www net
-MASTER_SITES= http://github.com/defunkt/gist/raw/master/
+MASTER_SITES= https://github.com/defunkt/gist/raw/7340b581e0b7219f5fe39cea3ee7e9e8a653f2dc/
DISTNAME= gist
-EXTRACT_SUFX= .rb
+EXTRACT_SUFX=
EXTRACT_ONLY=
MAINTAINER= codeblock@eighthbit.net
COMMENT= A gist pastebin posting command
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+
CONFLICTS= p5-WWW-GitHub-Gist-[0-9]*
USE_RUBY= YES
NO_BUILD= YES
+NO_WRKSUBDIR= YES
PLIST_FILES= bin/gist
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/gist ${WRKDIR}
+
do-install:
- ${INSTALL_SCRIPT} ${DISTDIR}/gist.rb ${PREFIX}/bin/gist
+ ${INSTALL_SCRIPT} ${WRKDIR}/gist ${PREFIX}/bin/gist
.include <bsd.port.mk>
diff --git a/www/gist/distinfo b/www/gist/distinfo
index 384b959876d5..35c843d0eae4 100644
--- a/www/gist/distinfo
+++ b/www/gist/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gist.rb) = 6b0010582486e828d26f9fec216bd08b3c5968b32d5f3aeec419ba7a71efe732
-SIZE (gist.rb) = 2172
+SHA256 (gist) = 1e5591286f012d65644efdec20430530716ea5db488a244bc52adb4847751dcb
+SIZE (gist) = 235655
diff --git a/www/gist/files/patch-gist b/www/gist/files/patch-gist
new file mode 100644
index 000000000000..638af6ab7b79
--- /dev/null
+++ b/www/gist/files/patch-gist
@@ -0,0 +1,11 @@
+--- gist.orig 2011-03-29 18:51:45.258852583 +0800
++++ gist 2011-03-29 14:51:47.060574433 +0800
+@@ -182,7 +182,7 @@
+
+ http.use_ssl = true
+ http.verify_mode = OpenSSL::SSL::VERIFY_PEER
+- http.cert = OpenSSL::X509::Certificate.new(ca_cert)
++ http.ca_file = "/usr/local/share/certs/ca-root-nss.crt"
+
+ req = Net::HTTP::Post.new(url.path)
+ req.form_data = data(files, private_gist)