aboutsummaryrefslogtreecommitdiff
path: root/www/gist
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-08-25 01:13:19 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-08-25 01:13:19 +0000
commit8e8e665cf9cf7baa161e0ec6bb93fb99b2688d8a (patch)
tree63f28d460629dd8b6981894ed337b4d33247764d /www/gist
parent4f5e76512c8ed655c62addb950625bc1e76db246 (diff)
downloadports-8e8e665cf9cf7baa161e0ec6bb93fb99b2688d8a.tar.gz
ports-8e8e665cf9cf7baa161e0ec6bb93fb99b2688d8a.zip
This port is for the Gist commandline tool, which allows for posting to the
Gist pastebin. WWW: http://github.com/defunkt/gist/ PR: ports/137829 Submitted by: "Rick E." <codeblock@eighthbit.net>
Notes
Notes: svn path=/head/; revision=240290
Diffstat (limited to 'www/gist')
-rw-r--r--www/gist/Makefile26
-rw-r--r--www/gist/distinfo3
-rw-r--r--www/gist/pkg-descr4
3 files changed, 33 insertions, 0 deletions
diff --git a/www/gist/Makefile b/www/gist/Makefile
new file mode 100644
index 000000000000..8c1bf41784bb
--- /dev/null
+++ b/www/gist/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gist
+# Date created: 2009-08-16
+# Whom: Ricky E. <codeblock@eighthbit.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gist
+PORTVERSION= 1.0
+CATEGORIES= www net
+MASTER_SITES= http://github.com/defunkt/gist/raw/master/
+DISTNAME= gist
+EXTRACT_SUFX= .rb
+EXTRACT_ONLY=
+
+MAINTAINER= codeblock@eighthbit.net
+COMMENT= A gist pastebin posting command
+
+USE_RUBY= YES
+NO_BUILD= YES
+PLIST_FILES= bin/gist
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/gist.rb ${PREFIX}/bin/gist
+
+.include <bsd.port.mk>
diff --git a/www/gist/distinfo b/www/gist/distinfo
new file mode 100644
index 000000000000..0e5fe3ba6681
--- /dev/null
+++ b/www/gist/distinfo
@@ -0,0 +1,3 @@
+MD5 (gist.rb) = 8c173f3c99878b01904b932f1e0c3b10
+SHA256 (gist.rb) = 6b0010582486e828d26f9fec216bd08b3c5968b32d5f3aeec419ba7a71efe732
+SIZE (gist.rb) = 2172
diff --git a/www/gist/pkg-descr b/www/gist/pkg-descr
new file mode 100644
index 000000000000..e901093de166
--- /dev/null
+++ b/www/gist/pkg-descr
@@ -0,0 +1,4 @@
+This port is for the Gist commandline tool, which allows for posting to the
+Gist pastebin.
+
+WWW: http://github.com/defunkt/gist/