aboutsummaryrefslogtreecommitdiff
path: root/www/gitlab-pages
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:34:31 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:34:31 +0000
commitfc95b3f0cf943e760e906eac92aac51eff4d0c1c (patch)
tree8b41993e1df35d7245f4013a2d3adcb758a276a1 /www/gitlab-pages
parent67c4b925b7fd606361a2152563b80da493232dfb (diff)
downloadports-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.tar.gz
ports-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.zip
Go ports: cleanup, finish transition to USES=go started with r505321 (cat. sysutils-x11)
- Remove custom build/install targets left in place after r505321 - Switch to the new GO_TARGET tuple syntax introduced in r512001 Reviewed by: tobik Approved by: araujo (mentor), portmgr (adamw) Differential Revision: https://reviews.freebsd.org/D21744
Notes
Notes: svn path=/head/; revision=513276
Diffstat (limited to 'www/gitlab-pages')
-rw-r--r--www/gitlab-pages/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/www/gitlab-pages/Makefile b/www/gitlab-pages/Makefile
index efd78fb411a4..18313bbd84aa 100644
--- a/www/gitlab-pages/Makefile
+++ b/www/gitlab-pages/Makefile
@@ -17,6 +17,9 @@ GL_ACCOUNT= gitlab-org
# Find the here: https://gitlab.com/gitlab-org/gitlab-pages/tags
GL_COMMIT= 520398c7154a50f7768ee52da71afd52efff85b1
+GO_BUILDFLAGS= -ldflags="-X main.VERSION=${PORTVERSION} -X main.REVISION=${GITHASH}"
+GO_PKGNAME= gitlab.com/gitlab-org/gitlab-pages
+
PLIST_FILES= bin/gitlab-pages
USE_RC_SUBR= gitlab_pages
@@ -24,17 +27,4 @@ USE_RC_SUBR= gitlab_pages
USERS= gitlab-pages
GROUPS= gitlab-pages
-post-patch:
- @${MV} ${WRKSRC}/vendor ${WRKSRC}/src
- @${MKDIR} ${WRKSRC}/src/gitlab.com/gitlab-org
- @${LN} -s ${WRKSRC} ${WRKSRC}/src/gitlab.com/gitlab-org/gitlab-pages
-
-do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
- go build -o gitlab-pages \
- --ldflags="-X main.VERSION=${PORTVERSION} -X main.REVISION=${GITHASH}"
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gitlab-pages ${STAGEDIR}${PREFIX}/bin/gitlab-pages
-
.include <bsd.port.mk>