aboutsummaryrefslogtreecommitdiff
path: root/www/gitlab-workhorse
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
commit3726f942547e374490d375baf83216d7644a7162 (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /www/gitlab-workhorse
parent1de291090d9121f4d238a639b441f64372c239c1 (diff)
downloadports-3726f942547e374490d375baf83216d7644a7162.tar.gz
ports-3726f942547e374490d375baf83216d7644a7162.zip
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Notes
Notes: svn path=/head/; revision=505321
Diffstat (limited to 'www/gitlab-workhorse')
-rw-r--r--www/gitlab-workhorse/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/www/gitlab-workhorse/Makefile b/www/gitlab-workhorse/Makefile
index 102b0ea12d5b..ace1667e5604 100644
--- a/www/gitlab-workhorse/Makefile
+++ b/www/gitlab-workhorse/Makefile
@@ -11,11 +11,10 @@ COMMENT= Smart reverse proxy for GitLab
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= go>=1.8.0:lang/go \
- git>=2.16.2:devel/git
+BUILD_DEPENDS= git>=2.16.2:devel/git
RUN_DEPENDS= p5-Image-ExifTool>=0:graphics/p5-Image-ExifTool
-USES= gmake
+USES= gmake go:no_targets
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org