aboutsummaryrefslogtreecommitdiff
path: root/www/gitlab
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-01-05 14:03:18 +0000
committerSteve Wills <swills@FreeBSD.org>2018-01-05 14:03:18 +0000
commit7878202b54d6c53748052ebee76a61643b3aca82 (patch)
tree561935eec58d291a58234f206247f9609e65604b /www/gitlab
parent9402cc24d3bf33d349e43cfd9571a56c29a1dfa2 (diff)
downloadports-7878202b54d6c53748052ebee76a61643b3aca82.tar.gz
ports-7878202b54d6c53748052ebee76a61643b3aca82.zip
Notes
Diffstat (limited to 'www/gitlab')
-rw-r--r--www/gitlab/Makefile4
-rw-r--r--www/gitlab/files/patch-Gemfile22
2 files changed, 17 insertions, 9 deletions
diff --git a/www/gitlab/Makefile b/www/gitlab/Makefile
index 071c05497732..e47989e9ce6c 100644
--- a/www/gitlab/Makefile
+++ b/www/gitlab/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gitlab
PORTVERSION= 10.1.5
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www devel
MAINTAINER= idefix@fechner.net
@@ -185,7 +185,7 @@ RUN_DEPENDS= git>=2.14.1:devel/git \
rubygem-vmstat>=2.3.0:sysutils/rubygem-vmstat \
rubygem-sys-filesystem>=1.1.6:sysutils/rubygem-sys-filesystem \
rubygem-net-ssh>=4.1.0:security/rubygem-net-ssh \
- rubygem-rbnacl>=4.0:security/rubygem-rbnacl \
+ rubygem-rbnacl4<=4.0.2:security/rubygem-rbnacl4 \
rubygem-rbnacl-libsodium>=0:security/rubygem-rbnacl-libsodium \
rubygem-bcrypt_pbkdf>=1.0:security/rubygem-bcrypt_pbkdf \
rubygem-gitaly-proto>=0.39.0:net/rubygem-gitaly-proto \
diff --git a/www/gitlab/files/patch-Gemfile b/www/gitlab/files/patch-Gemfile
index c5f4c8aa87d7..356ca0db5ee4 100644
--- a/www/gitlab/files/patch-Gemfile
+++ b/www/gitlab/files/patch-Gemfile
@@ -163,7 +163,7 @@
# GitLab settings
gem 'settingslogic', '~> 2.0.9'
-@@ -168,7 +168,7 @@ gem 're2', '~> 1.1.1'
+@@ -168,20 +168,20 @@ gem 're2', '~> 1.1.1'
# Misc
@@ -172,7 +172,10 @@
# Cache
gem 'redis-rails', '~> 5.0.1'
-@@ -178,10 +178,10 @@ gem 'redis', '~> 3.2'
+
+ # Redis
+-gem 'redis', '~> 3.2'
++gem 'redis', '>= 3.2'
gem 'connection_pool', '~> 2.0'
# HipChat integration
@@ -214,7 +217,7 @@
# Ace editor
gem 'ace-rails-ap', '~> 4.1.0'
-@@ -234,25 +234,25 @@ gem 'chronic', '~> 0.10.2'
+@@ -234,173 +234,89 @@ gem 'chronic', '~> 0.10.2'
gem 'chronic_duration', '~> 0.10.6'
gem 'webpack-rails', '~> 0.9.10'
@@ -245,9 +248,10 @@
-gem 'sentry-raven', '~> 2.5.3'
+gem 'sentry-raven', '>= 2.5.3'
- gem 'premailer-rails', '~> 1.9.7'
+-gem 'premailer-rails', '~> 1.9.7'
++gem 'premailer-rails', '>= 1.9.7'
-@@ -260,135 +260,51 @@ gem 'premailer-rails', '~> 1.9.7'
+ # I18n
gem 'ruby_parser', '~> 3.8', require: false
gem 'rails-i18n', '~> 4.0.9'
gem 'gettext_i18n_rails', '~> 1.8.0'
@@ -369,7 +373,8 @@
+gem 'email_reply_trimmer', '>= 0.1'
gem 'html2text'
- gem 'ruby-prof', '~> 0.16.2'
+-gem 'ruby-prof', '~> 0.16.2'
++gem 'ruby-prof', '>= 0.16.2'
# OAuth
-gem 'oauth2', '~> 1.4'
@@ -393,7 +398,10 @@
# Required for ED25519 SSH host key support
group :ed25519 do
-@@ -398,9 +314,9 @@ group :ed25519 do
+ gem 'rbnacl-libsodium'
+- gem 'rbnacl', '~> 4.0'
++ gem 'rbnacl', '~> 4.0.2'
+ gem 'bcrypt_pbkdf', '~> 1.0'
end
# Gitaly GRPC client